FocalTech touchpad stops working after suspend

Bug #1504445 reported by Thatoo on 2015-10-09
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have an Asus V502LX the persian version of the Asus K501LX.

I have Ubuntu 14.04 installed and the kernel 4.1.6 installed. I had to install the kernel 4.1.6 to have the touchpad recognised. Under kernel 3.19.30, as I am running now to file in this bug, the touchpad is recognised as a simple mouse (no two fingers scrolling...) and the problem I am describing below is also present...

I noticed one problem. The Focaltech touchpad is not working after suspending the computer.

Here is what I could find about the touchpad in /proc/bus/input/devices

I: Bus=0011 Vendor=0002 Product=0012 Version=0000
N: Name="FocalTechPS/2 FocalTech FocalTech Touchpad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse0 event4
B: PROP=5
B: EV=b
B: KEY=e520 10000 0 0 0 0
B: ABS=260800000000003

Before suspending the computer, I can deactivate and activate again the touchpad with the hotkey of my keyboard without problem. However, once the computer suspended, nothing work to re-activate the touchpad.

I tried a solution given on internet but it doesn't work properly.

I created a file here /etc/pm/sleep.d/0000trackpad
sudo gedit /etc/pm/sleep.d/0000trackpad

and add the following
#!/bin/sh
case "$1" in
    suspend|hibernate)
        modprobe -r psmouse;
    resume|thaw)
        modprobe psmouse;
esac

With this file, the computer refuse to suspend. The touchpad keep working so it does something but I can't make my computer sleeping...

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.19.0-30-generic 3.19.0-30.34~14.04.1
ProcVersionSignature: Ubuntu 3.19.0-30.34~14.04.1-generic 3.19.8-ckt6
Uname: Linux 3.19.0-30-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.15
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Oct 9 12:05:16 2015
InstallationDate: Installed on 2015-09-26 (12 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
SourcePackage: linux-lts-vivid
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.14.1-0ubuntu3.15
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: yogo 2073 F.... pulseaudio
 /dev/snd/controlC0: yogo 2073 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=943b03af-c1bf-489e-8e42-485931fc619c
InstallationDate: Installed on 2015-09-26 (12 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
 Bus 001 Device 003: ID 8087:07dc Intel Corp.
 Bus 001 Device 002: ID 04f2:b483 Chicony Electronics Co., Ltd
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. K501LX
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-30-generic.efi.signed root=UUID=37bd087e-a2f6-437e-8d20-b19536eb738a ro quiet splash acpi_osi= vt.handoff=7
ProcVersionSignature: Ubuntu 3.19.0-30.34~14.04.1-generic 3.19.8-ckt6
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-30-generic N/A
 linux-backports-modules-3.19.0-30-generic N/A
 linux-firmware 1.127.15
Tags: trusty
Uname: Linux 3.19.0-30-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo www-data
_MarkForUpload: True
dmi.bios.date: 04/16/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K501LX.203
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K501LX
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK501LX.203:bd04/16/2015:svnASUSTeKCOMPUTERINC.:pnK501LX:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnK501LX:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: K501LX
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Thatoo, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1504445

affects: linux-lts-vivid (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Thatoo (thatoo) wrote :

I've just discovered a solution to have the touchpad working under kernel 3.19.30 :
I needed to install the pilot in here, https://github.com/hanipouspilot/focaltech-dkms
as explain on this page, http://ubuntuforums.org/showthread.php?t=2253069&page=11 because if I use the ppa and "sudo apt-get install focaltech-dkms" then it tries to install on kernel 4.1.6 and it's not compatible.

With this pilot, under kernel 3.19.30, if I suspen the computer, the problem is the same.

Thatoo (thatoo) wrote :

I've just discovered a solution to have the touchpad working under kernel 3.19.30 :
I needed to install the pilot in here, https://github.com/hanipouspilot/focaltech-dkms
as explain on this page, http://ubuntuforums.org/showthread.php?t=2253069&page=11 because if I use the ppa and "sudo apt-get install focaltech-dkms" then it tries to install on kernel 4.1.6 and it's not compatible.

With this pilot, under kernel 3.19.30, if I suspend the computer, the problem is still the same. So I guess, but I'm not sure, kernel 4.1.6 include the same pilot than the one I've just found, available for kernel 3.19.30 and this pilot needs to be updated.

Pilot6 (hanipouspilot) wrote :

@thatoo

You do not need to install my backport on kernel 4.1.x. It is already there.

Thatoo (thatoo) wrote :

I should do
apport-collect 1504445
under kernel 3.19.30 or 4.1.6 is ok?

Thatoo (thatoo) wrote :

Thank you Pilot6, so my guess was right.
I had to do it because to file in this bug, I had to boot into the Ubuntu kernel (not mainline) and type the command "ubuntu-bug linux"

When I go to /usr/src,
sudo ls
here is the list of folders
bbswitch-0.7 linux-headers-4.1.6-040106
focaltech-1.5 linux-headers-4.1.6-040106-generic
linux-headers-3.13.0-65 linux-source-3.13.0
linux-headers-3.13.0-65-generic linux-source-3.13.0.tar.bz2
linux-headers-3.19.0-28 nvidia-355-355.11
linux-headers-3.19.0-28-generic psmouse-elantech-v7
linux-headers-3.19.0-30 psmouse-elantech-v7.tar.bz2
linux-headers-3.19.0-30-generic

Why is there psmouse-elantech-v7 and psmouse-elantech-v7.tar.bz2 whereas my touchpad is a focaltech???

tags: added: apport-collected
description: updated

apport information

description: updated
Pilot6 (hanipouspilot) wrote :

Your problem is that you installed a wrong Elantech driver. Please provide output of

dkms status

Pilot6 (hanipouspilot) wrote :

And this is not a bug report. You installed an unsupported kernel and some wrong driver.

Changed in linux (Ubuntu):
status: Incomplete → Invalid

Thatoo, please boot into the default Ubuntu kernel (not mainline) and then execute the apport-collect.

Changed in linux (Ubuntu):
status: Invalid → Incomplete
description: updated
Thatoo (thatoo) wrote :

I did
apport-collect 1504445
under kernel 4.1.6
it asked me to do it also under kernel 3.19.30
I did it but then it says that it didn't collect any new information

Thatoo (thatoo) wrote :

by the way, when I rebooted under kernel 4.19.30, the touchpad was again not recognised. I didn't reinstall the pilot this time so I have a simple mouse.

Pilot6 (hanipouspilot) wrote :

Please add output of

dkms status

Thatoo (thatoo) wrote :

Pilot6, my ubuntu is a fresh install of 14.04 and I didn't install in purpose any pilot for Elantech driver....
About kernel, I didn't install kernel 3.13 and neither 3.19 by myself, I guess they have been installed during the fresh install and some update.

The only thing I did myself was to install kernel 4.1.6 because I read somewhere that it makes the system recognise the touchpad. My problem at that time was not to solve the problem after suspending the computer but to make my touchpad recognise and not just be a simple mouse.

If that was wrong, I didn't know about your pilot, I've just discovered it this morning when I was researching more.

What should I do now?

Pilot6 (hanipouspilot) wrote :

With kernel 3.19 the touchpad is not recognized. That can be fixed by installing the Focaltech driver from my ppa.
It will not work if you installed another Elantech driver.

So this is not a bug report, but a support request.

In kernel 4.2 (Ubuntu 15.10) the touchpad is recognized out of the box.

Thatoo (thatoo) wrote :

@ Pilot6 : you want me to do
dkms status
from kernel 4.1.6 or kernel 3.19.30?

Thatoo (thatoo) wrote :

How can I uninstall the wrong Focaltech driver?

I install your pilot from your ppa from kernel 3.19.30 and this time it works.

Thatoo (thatoo) wrote :

here is the result of
yogo@yogo-ordi:~$ dkms status
bbswitch, 0.7, 3.13.0-65-generic, x86_64: installed
bbswitch, 0.7, 3.19.0-30-generic, x86_64: installed
bbswitch, 0.7, 4.1.6-040106-generic, x86_64: installed
focaltech, 1.5: added
focaltech, 1.5~trusty1, 3.19.0-30-generic, x86_64: installed
nvidia-355, 355.11, 3.13.0-65-generic, x86_64: installed
nvidia-355, 355.11, 3.19.0-30-generic, x86_64: installed
nvidia-355, 355.11, 4.1.6-040106-generic, x86_64: installed
yogo@yogo-ordi:~$

Pilot6 (hanipouspilot) wrote :

Kernel 4.1.6 is off-topic here.

Last time you installed an Elantech driver that was wrong.

If you install kernel 4.1+, you will need to uninstall the focaltech dkms module.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Pilot6 (hanipouspilot) wrote :

So you either install my dkms module or install new kenels. Not both.

Thatoo (thatoo) wrote :

sorry, earlier I meant How can I uninstalled the wrong Elantech driver?

If I go in synaptic and i type Elantech, nothing is coming out of it...

Thatoo (thatoo) wrote :

so, now that I have the kernel 4.1.6 already install and that grub automaticaly boot on it, waht should I do to remove your dkms module and uninstall the Elantech driver that I don't know about how it was installed...

Pilot6 (hanipouspilot) wrote :

You do not need kernel 4.1.6.

You can always uninstall my module by running

sudo apt-get remove focaltech-dkms

if you installed it from a deb package.

Or by

sudo dkms remove focaltech/1.5 --all
sudo dkms remove focaltech/1.5~trusty --all

as I see that you installed two versions for some reason.

Thatoo (thatoo) wrote :

In synaptic, I can't find anything like
psmouse-elantech-v7
elantech

so how can I remove the wrong driver?

In synaptic, should I select
focaltech-dkms
to delete
to delete completly
?

Thatoo (thatoo) wrote :

so you advise me rather to uninstall kernel 4.1.6 and boot with kernel 3.19.30 with your driver.

How to uninstall kernel 4.1.6 then?
Then should I run one of the two command
sudo dkms remove focaltech/1.5 --all
sudo dkms remove focaltech/1.5~trusty --all

Which one?

Finaly, how to remove psmouse-elantech-v7 ? you seems to say that will solve the problem.

Thatoo (thatoo) wrote :

I remember now, I think I tried something about elantech because I was following a tutorial for asus touchpad here https://doc.ubuntu-fr.org/touchpad_asus because I didn't know what to do.
It was wrong.
How to solve that mistake now?

Could you give me a step by step to uninstall kernel 4.1.6, have a clean install of your driver for focaltech (I'm sorry if I installed it two time, should I unistall both of them and reinstall from ppa again?) And how to remove the psmouse-elantech-v7 driver that you think is making trouble?

Thank you,

Thatoo

Thatoo (thatoo) wrote :

I followed this tutorial to remove kernel 4.1.6
https://askubuntu.com/questions/106031/how-can-i-remove-new-kernel-versions-after-downgrading

then, I did
sudo apt-get remove focaltech-dkms
sudo dkms remove focaltech/1.5 --all
sudo dkms remove focaltech/1.5~trusty --all

and finally

yogo@yogo-ordi:~$ sudo apt-get install focaltech-dkms
yogo@yogo-ordi:~$ sudo modprobe -r psmouse
yogo@yogo-ordi:~$ sudo modprobe psmouse

I'm going to restart the computer and I'll tell you how it is.

Thatoo (thatoo) wrote :

So now, I am running ubuntu 14.04 with kernel 3.19.30.
kernel 4.1.6 have been deleted
the driver focaltech-dkms is installed,

The touchpad works like it was working.

Before suspending the computer, I can deactivate and activate again the touchpad with the hotkey of my keyboard without problem.

I deleted this file /etc/pm/sleep.d/0000trackpad
that was containing

#!/bin/sh
case "$1" in
    suspend|hibernate)
        modprobe -r psmouse;
    resume|thaw)
        modprobe psmouse;
esac

I can suspend the computer but still the problem is on. After the computer come back from sleeping, the touchpad is not working anymore.
What should I do?

Is the Elantech driver the problem, I don't know and I don;t know how to delete it.

Thatoo (thatoo) wrote :

I am sorry pilot6 but it is still a bug, not "invalid", I don't bother people for support request or spam...

Thatoo (thatoo) on 2015-10-09
Changed in linux (Ubuntu):
status: Invalid → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1504445

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Thatoo (thatoo) wrote : AlsaInfo.txt

apport information

description: updated

apport information

Thatoo (thatoo) wrote : CRDA.txt

apport information

apport information

Thatoo (thatoo) wrote : IwConfig.txt

apport information

Thatoo (thatoo) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

Thatoo (thatoo) wrote : RfKill.txt

apport information

Thatoo (thatoo) wrote : UdevDb.txt

apport information

Thatoo (thatoo) wrote : UdevLog.txt

apport information

apport information

Thatoo (thatoo) wrote :

yogo@yogo-ordi:~$ apport-collect 1504445
dpkg-query: aucun paquet ne correspond à linux
yogo@yogo-ordi:~$
 done

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thatoo, thanks for that. To advise, if your touchpad doesn't just work (this includes resuming from suspend) after installing a supported Ubuntu release, and then doing standard updates (no PPAs, 3rd party software, compiling, etc.) the Ubuntu Project considers this a bug as outlined in https://wiki.ubuntu.com/Bugs/Status .

However, when providing further debugging information to this report, please first remove any 3rd party packages you installed.

Despite this, as per https://www.asus.com/Notebooks/K501LX/HelpDesk_Download/ an update to your computer's buggy and outdated BIOS is available (205). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful. Also, you don't have to create a new bug report.

Once the BIOS is updated, if the problem is still reproducible, and the information above is provided, then please mark this report Status Confirmed. Otherwise, please mark this as Invalid.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: bios-outdated-205
removed: focaltech touchpad
Thatoo (thatoo) wrote :

Thank you for your help,

I updated the bios to the 205 version. Nothing changed.
I entered the command you asked, here is the result :
yogo@yogo-ordi:~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
[sudo] password for yogo:
K501LX.205
08/05/2015
yogo@yogo-ordi:~$

The problem is still here!

The feww ppa I installed, after the fresh install of Ubuntu 14.04, are for the driver of the touchpad, otherwise it behaves only like a mouse, the driver for the nvidia graphic card, the plugin for SSTP VPN to be able to connect really to Internet from Iran, and then few software, Opera, LibreOffice 5, Telegram and google talk. I can't just remove them like that, first because I don't know how, and second, I need to work on my computer, it's not just a test machine...

Thank you for your help again

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: latest-bios-205
removed: bios-outdated-205

Thatoo, to clarify my last comment, the 3rd party software relating to the touchpad would be all you need to remove while performing the requested debugging.

With this in mind, could you please test the latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, Y, and Z are numbers corresponding to the kernel version.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Low → Medium
status: Confirmed → Incomplete
Thatoo (thatoo) wrote :

So I'm now writing to you with kernel-upstream-4.3.0-040300rc5 installed and the Focaltech driver uninstall as requested.

My computer boot almost normaly, just a small error display, "Error parsing PCC subspaces from PCCT” I think because of a conflict between the new kernel and the nvidia driver. It just slow down a little bit the boot time.

Everything works as usual. As it was the case when I tested the kernel 4.1.6, the touchpad is recognised and work without the need of any additional driver.

However, the problem is still on. After I close the lid of my computer or click on the button to suspend its activity, after awaking, everything seems to work except the touchpad. The keyboard works, the wifi reconnect but the touchpad is blocked. I have to restart to get it working again.

I hope that was the test you wanted me to do. Should I restart under kernel 3.19.30? and should I delete the kernel 4.3.0-rc5? or should I keep it like that for now?

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-4.3.0-040300rc5
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thatoo, could you please provide the missing information following https://wiki.ubuntu.com/DebuggingKernelSuspend ?

tags: added: kernel-bug-exists-upstream-4.3-rc5 resume suspend
removed: kernel-bug-exists-upstream-4.3.0-040300rc5
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Thatoo (thatoo) wrote :

here is the result of
cat /proc/acpi/wakeup > wakeup

when I boot on kernel 4.3-rc5

Thatoo (thatoo) wrote :

here is the result of
dmesg > dmesg.txt

just after resuming from the command
sudo sh -c "sync && echo 1 > /sys/power/pm_trace && pm-suspend"

when I boot with the kernel 4.3-rc5

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Thatoo (thatoo) wrote :

I found this line inside dmesg.txt
[ 0.506837] Magic number: 3:714:369

but nothing with "hash matches"

I hope that help.

Thatoo, the issue you are reporting is an upstream one. Could you please report this problem following the instructions verbatim at https://wiki.ubuntu.com/Bugs/Upstream/kernel to the appropriate venue (Dmitry Torokhov CC linux-input)?

Please provide a direct URL to your newly made report when it becomes available so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Thatoo (thatoo) wrote :

I add you, Christopher M. Penalver (penalvch) in bcc of the mail, like that if you want, and have time, you can check if I wrote my report properly.
I'll write here their answer and the direct URL to your newly made report when it becomes available.

Thank you again,
Thatoo

Thatoo (thatoo) wrote :

here is his answer (really fast)

Hmm, it looks there was another report with Asus losing touchpad
function after suspend:

https://bbs.archlinux.org/viewtopic.php?id=194810

Can you try unloading and reloading i8042 module (make sure it is a
module and not compiled into kernel).

Thanks.

--
Dmitry

I tried to follow the solution,

- pm-utils was already installed
- I created the file /etc/pm/config.d/modules
sudo gedit /etc/pm/config.d/modules
and I wrote
SUSPEND_MODULES="i8042"
- Then I tried to suspend using "sudo pm-suspend" to suspend or the shortkey etc..

but nothing change.
Maybe I have to write more inside /etc/pm/config.d/modules to "unload" on suspend and then "reload" on resume, no?
Maybe just the line SUSPEND_MODULES="i8042" is not enough but what should I write?
What means (make sure it is a module and not compiled into kernel)?

Thatoo (thatoo) wrote :

Dmitry Torokhov asked me to do

lsmod | grep i8042

It doesn't give any result. Is it good news?

Thatoo, could you please post a URL of your report upstream as previously requested in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1504445/comments/57 , so folks may follow the discussion?

Thatoo (thatoo) wrote :

I don't know what is the "URL of your report upstream".
So far, I exchange only two emails with Dmitry Torokhov. He didn't answer after I gave him the result of "lsmod | grep i8042" as he requested.
He didn't give me any link to anything or any instruction on what should I do afterwards.

Thatoo, as advised in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1504445/comments/57 , since you have been CC'ing the linux-input mailing list, your original report URL should be found at http://vger.kernel.org/vger-lists.html .

Thatoo (thatoo) wrote :

Thank you Christopher M. Penalver (penalvch), I found it. Here is the URL of my report upstream :

http://www.spinics.net/lists/linux-input/msg41617.html

I understand that I should have replied to all when I replied to Dmitry Torokhov, for my message to be displayed publicly.

he asked me to do lsmod | grep i8042
I did but that give no result.

Should I resend this email to Dmitry Torokhov and <email address hidden> again?

Thatoo (thatoo) wrote :

Harakhay, the guy who find a solution in here, https://bbs.archlinux.org/viewtopic.php?pid=1572218#p1572218 , told me a little bit more how he solved his problem :

Everybody suggested him to add SUSPEND_MODULES="psmouse" in /etc/pm/config.d/modules, but it didn't help for him. So he found all modules dependent upon psmouse, and some dependent upon those modules as well. He had about 6 of them. Then he did this trick with all these modules (unload on suspend, load on resume), and he found out that it works. Then only thing he needed to do was to find out what module from those 6 is needed to be reloaded....

Now, to try his solution, because i8042 doesn't works in my case, I need to how to find all modules dependent upon psmouse, and some dependent upon those modules as well...

Does anyone can help me with that?

Thatoo (thatoo) wrote :

Thanks to Harris Anggara (harrisanggara) and Daniel Drake (dsdrake) here, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1490130 , I could solve my problem by adding this patch to the kernel :
https://marc.info/?l=linux-input&m=144312209020616&w=2

now i'm using kernel 4.2 for Ubuntu 14.04 with the patch. i changed the DMI_PRODUCT_NAME with K501LX (because that is my laptop model).

I tried directly with kernel 4.2 because before that, kernel 3.19 and so, they need a driver for my touchpad. I followed the instruction here to obtain the source of kernel 4.2 for Ubuntu 14.04, https://wiki.ubuntu.com/Kernel/Dev/KernelGitGuide
git clone git://kernel.ubuntu.com/ubuntu/ubuntu-trusty.git
then from inside the folder you've just downloaded (cd ubuntu-trusty)
git tag -l Ubuntu-*
to know what is available for ubuntu 14.04
and then
git checkout -f -b temp Ubuntu-lts-4.2.0-6.6_14.04.1.1

After, to build the kernel, I followed this explanation, https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel
fakeroot debian/rules clean
fakeroot debian/rules binary-headers binary-generic
then
cd ..
ls *.deb
    linux-cloud-tools-4.2.0-6-generic_4.2.0-6.6~14.04.1.1_amd64.deb
    linux-headers-4.2.0-6_4.2.0-6.6~14.04.1.1_all.deb
    linux-headers-4.2.0-6-generic_4.2.0-6.6~14.04.1.1_amd64.deb
    linux-image-4.2.0-6-generic_4.2.0-6.6~14.04.1.1_amd64.deb
    linux-image-extra-4.2.0-6-generic_4.2.0-6.6~14.04.1.1_amd64.deb
    linux-tools-4.2.0-6-generic_4.2.0-6.6~14.04.1.1_amd64.deb

I deleted this two files because I don't need them
    linux-cloud-tools-4.2.0-6-generic_4.2.0-6.6~14.04.1.1_amd64.deb
    linux-tools-4.2.0-6-generic_4.2.0-6.6~14.04.1.1_amd64.deb
and finally,
sudo dpkg -i linux*4.2.0-6.6~14.04.1.1*.deb
sudo reboot

Now it works nicely. The touchpad works fine, without the need to install any driver and I can suspend the activity of my computer and resume without loosing the touchpad. I hope the patch will be integrated soon and I won't loose my touchpad again with updates in the future.

Thank you everybody,
Take care, always smiling,

Thatoo (thatoo) wrote :

I forgot to say that to identify your laptop model you can run
sudo dmidecode | grep Product\ Name

you'll need to change
DMI_MATCH(DMI_PRODUCT_NAME, "X455LAB"),
by
DMI_MATCH(DMI_PRODUCT_NAME, "XXXXX"),

XXXXX being your laptop model

Thatoo (thatoo) wrote :

I copied all this information to Dmitry Torokhov and <email address hidden>.

Is it normal to not receive answer?
Will I ever know that my contribution has been read by someone?
I can understand that by habit and a taste for conservatism, they like their email system but it's kind of opaque system that forbid all feedback to contributors. We don't know if we are taken under consideration, if we have been useful, or if we did all wrong and we need to review out approach to contributing...

Sorry for disturbing here, because this message doesn't belong here. I had great help here, but if I write over there, I'm afraid that my email (from a modest contributor) will not even be open... So if someone here knows how to get my remarks to the right person, thank you to do so.
And if someone can answer this last question, I'll be happy
How can I make sure that my efforts were not just for me but that later Ubuntu will not bring that same bug to other users?

I can confirm this issue on my Asus K501LX-NH52 on a fresh install (Xubuntu 14.04.3) from yesterday. Touchpad stops working after suspend, forced to use USB mouse for now.

The Elantech driver is installed automatically when Ubuntu installs.
Kernel 3.19.0-37 is installed as part of the first batch of updates.
I tried installing Pilot6's ppa:hanipouspilot/focaltech-dkms driver without any change.

dmidecode | grep Product\ Name
 Product Name: K501LX

uname -r
3.19.0-37-generic

dkms_status output:
bbswitch, 0.7, 3.19.0-37-generic, x86_64: installed
focaltech, 1.5~trusty1, 3.19.0-37-generic, x86_64: installed
nvidia-355, 355.11, 3.19.0-37-generic, x86_64: installed

lsmod | grep i8042
<no output>

I guess I'll try this kernel patch as suggested for now, while this issue is still pending.

Forgot one more detail, I am running the latest BIOS (I checked for updates from BIOS, it came installed)

sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
K501LX.205
08/05/2015

now we are in ubuntu 16.04 LTS and this problem persist

This bug also affects my Asus X455LF-WX055T with FocalTech Touchpad with Ubuntu 16.04 LTS installed.

I noticed a change in `xinput list` before and after suspending

Before I suspend, my `xinput list` contains `PS/2 FocalTech FocalTech Touchpad`:

xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech K270 id=10 [slave pointer (2)]
⎜ ↳ Logitech M315/M235 id=11 [slave pointer (2)]
⎜ ↳ PS/2 FocalTech FocalTech Touchpad id=15 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ USB2.0 VGA UVC WebCam id=12 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=13 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=14 [slave keyboard (3)]

When I wake it up after suspending it, my `xinput list` does not contain `PS/2 FocalTech FocalTech Touchpad` but it was replaced(?) by `AT Raw Set 2 keyboard id=15 [slave keyboard (3)]` which was not present before I suspend:

xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech K270 id=10 [slave pointer (2)]
⎜ ↳ Logitech M315/M235 id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ USB2.0 VGA UVC WebCam id=12 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=13 [slave keyboard (4)]
    ↳ AT Translated Set 2 keyboard id=14 [slave keyboard (3)]
    ↳ AT Raw Set 2 keyboard id=15 [slave keyboard (3)]

I hope this helps...

In my case, the xinput not change (x450ld-wx058h) but the mouse not work after suspend

before suspend
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ FocalTechPS/2 FocalTech FocalTech Touchpad id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ USB2.0 HD UVC WebCam id=10 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=11 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]

after suspend (touchpad not working)
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ FocalTechPS/2 FocalTech FocalTech Touchpad id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ USB2.0 HD UVC WebCam id=10 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=11 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]

Hi guys, Linus picked patch today that solves this problem for some Asus models:

A455LD
K401LB
K501LB
K501LX
R409L
V502LX
X302LA
X450LCP
X450LD
X455LAB
X455LDB
X455LF
Z450LA

So, can you please check this patch[1] and then report if this really fixes your problem? This patch will be available in kernel 4.9.

Also, if yuor version is not covered in this patch, please let me know.

Thanks!

[1] https://git.kernel.org/cgit/linux/kernel/git/dtor/input.git/commit/?id=930e19248e9b61da36c967687ca79c4d5f977919

Thatoo, could you please advise if the patch works for you via https://wiki.ubuntu.com/Kernel/KernelBisection#Testing_a_newly_released_patch_from_upstream ?

Changed in linux (Ubuntu):
status: Triaged → Incomplete

Hello, I tested kernel ubuntu 4.9 rc1 in my X450LD, the touchpad works perfectly after suspend thats a relief after a year of this bug, this patch is going to be merged in 4.8.x?

Thatoo (thatoo) wrote :

Hello,

I didn't tested that patch following that way, https://wiki.ubuntu.com/Kernel/KernelBisection#Testing_a_newly_released_patch_from_upstream , but I did test the pacth by building my own 4.8 kernel (https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel) with the Ubuntu-lts-4.8.0-25.27_16.04.1 kernel.

Sincerely,

Thatoo

Thatoo (thatoo) wrote :

Sorry, I forgot to mention that it does work :-)

tags: added: cherry-pick
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Thatoo (thatoo) wrote :

With newer kernel 4.15 for example, it does work out of the box.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers