8086:0f31 Ubuntu 15.04-15.10 freezes totally

Bug #1503731 reported by Chris Rainey on 2015-10-07
74
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Ever since I first installed 15.04 back in April/May on my new DELL Inspiron 3646 I have experienced frequent(daily/every-other-day)complete lockups(cannot even switch to console(Alt-F1,F2,etc.).

I have determined that the issue is related to the 'i915' driver in relation to my GPU.

I'm currently using intel-linux-graphics-installer_1.2.0-0intel1_amd64.deb from https://01.org/linuxgraphics with similar results (maybe a little better than the stock i915 stack in 15.04).

WORKAROUND: Use kernel boot parameter:
intel_idle.max_cstate=1

I have gained _significant_ improvements in reliability / stability by using parameters in the i915 module:

/etc/modprobe.d/i915.conf:
options i915 semaphores=1

and / or

/etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_pstate=disable"

and / or
/usr/share/X11/xorg.conf.d/20-intel.conf:

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "TearFree" "1"
EndSection

and / or
Disable "Intel Virtualization Technologies" in the BIOS.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: xorg (not installed)
ProcVersionSignature: Ubuntu 3.19.0-30.34-generic 3.19.8-ckt6
Uname: Linux 3.19.0-30-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.5
Architecture: amd64
CompositorRunning: None
Date: Wed Oct 7 09:32:47 2015
DistUpgraded: Fresh install
DistroCodename: vivid
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display [8086:0f31] (rev 0e) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:068d]
InstallationDate: Installed on 2015-09-17 (19 days ago)
InstallationMedia: Ubuntu-Server 15.04 "Vivid Vervet" - Release amd64 (20150422)
LightdmGreeterLog:
 ** (lightdm-gtk-greeter:1005): WARNING **: [PIDs] Failed to execute command: upstart

 ** (lightdm-gtk-greeter:1005): WARNING **: Failed to load user image: Failed to open file '/home/chris/.face': No such file or directory
MachineType: Dell Inc. Inspiron 3646
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-30-generic.efi.signed root=UUID=ef22be35-6f79-4356-be42-2689d1de0378 ro quiet
SourcePackage: xorg
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/17/2015
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0V6D8J
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A09
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd08/17/2015:svnDellInc.:pnInspiron3646:pvr:rvnDellInc.:rn0V6D8J:rvrA00:cvnDellInc.:ct3:cvrA09:
dmi.product.name: Inspiron 3646
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.60-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.5.9-2ubuntu1~vivid2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.5.9-2ubuntu1~vivid2
version.xserver-xorg-core: xserver-xorg-core 2:1.17.1-0ubuntu3.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2build1
xserver.bootTime: Tue Oct 6 20:05:51 2015
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 990
 vendor ACR
xserver.version: 2:1.17.1-0ubuntu3.1

Chris Rainey (ckrzen) wrote :
summary: - 15.04 freezes totally using Intel(i915) on BayTrail /ValleyView
+ 15.04 freezes totally using Intel(i915) on BayTrail / ValleyView
SoC(J2900 CPU)

Chris Rainey, thank you for reporting this and helping make Ubuntu better. Could you please test the latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, Y, and Z are numbers corresponding to the kernel version.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

tags: added: latest-bios-a09
Changed in xorg (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
affects: xorg (Ubuntu) → linux (Ubuntu)
Chris Rainey (ckrzen) wrote :

Thank you. Christopher M. Penalver (penalvch) for your guidance. Please see my findings with the upstream kernel, below:

chris@CKR-DKM:~$ uname -a
Linux CKR-DKM 4.3.0-040300rc4-generic #201510041330 SMP Sun Oct 4 17:32:10 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

description: updated
Chris Rainey (ckrzen) wrote :

Unfortunately, .... I hit the hard-stop(total freeze) within 2-minutes of booting into the upstream kernel while I was editing this bug report.

Alas, I feel the need to mark it as existing in the upstream kernel.

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-4.3.0-040300rc4

Chris Rainey, to see if this is already resolved upstream, could you please test http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/ and advise to the results?

tags: added: kernel-bug-exists-upstream-4.3-rc4
removed: kernel-bug-exists-upstream-4.3.0-040300rc4
Chris Rainey (ckrzen) wrote :

Christopher M. Penalver (penalvch), upstream DRM-NIGHTLY installed:

chris@CKR-DKM:~$ uname -a
Linux CKR-DKM 4.3.0-994-generic #201510092200 SMP Sat Oct 10 02:01:43 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

So far, .... so good:

chris@CKR-DKM:~$ uptime
 13:05:37 up 37 min, 3 users, load average: 0.03, 0.10, 0.13

Chris Rainey (ckrzen) wrote :

Christopher M. Penalver (penalvch), please let me know how long to test upstream-drm-nightly before reporting-back and/or next steps.

Thank you for your assist.

Chris Rainey (ckrzen) wrote :

ACK!

I hit the hard-stop(total freeze) about 10-mins after submitting comment #7.

I rebooted into single-user-mode(runlevel 1) and uninstalled the upstream-drm-nightly kernel and am running on stock:

chris@CKR-DKM:~$ uname -a
Linux CKR-DKM 3.19.0-30-generic #34-Ubuntu SMP Fri Oct 2 22:08:41 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

again.

FWIW: The trigger for the freeze might have been my opening multiple background tabs in chromnium using the middle-click-wheel on my mouse while looking into other information. I launched about 12-15 background tabs with about one second between each click. The freeze occurred after about 10-seconds of reading the first tab in sequence.

Please advise when able.

Chris Rainey, the issue you are reporting is an upstream one. Could you please report this problem following the instructions verbatim at https://wiki.ubuntu.com/Bugs/Upstream/kernel to the appropriate venue (intel-gfx)?

Please provide a direct URL to your newly made report when it becomes available so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Medium → High
status: Incomplete → Triaged
summary: - 15.04 freezes totally using Intel(i915) on BayTrail / ValleyView
- SoC(J2900 CPU)
+ 8086:0f31 Ubuntu 15.04-15.10 freezes totally
Chris Rainey (ckrzen) wrote :

**********

https://bugs.freedesktop.org/show_bug.cgi?id=92464

**********

On Tue, 13 Oct 2015, Chris Rainey <email address hidden> wrote:
> [1.] One line summary of the problem: 8086:0f31_freezes_totally
>
> [2.] Full description of the problem/report: Total lockup(cannot even
> switch to console via Alt-F1, F2, etc.). Bug is most easily
> reproducible via Chromium browser when opening multiple
> background-tabs(middle-button(wheel) mouse-clicks) and when using
> ALT-TAB to switch between browser and Xterms, etc. Very difficult to
> pin due to randomness(i.e. system may run for 30-seconds, 30-minutes
> or 30-hours before freeze). However -- it rarely runs stable for more
> that 24-48/hrs without a lockup.

Please file a bug at [1] running drm-intel-nightly and attach dmesg from boot with drm.debug=14 module parameter set.

BR,
Jani.

[1] https://bugs.freedesktop.org/enter_bug.cgi?product=DRI&component=DRM/Intel

--
Jani Nikula, Intel Open Source Technology Center

Chris Rainey (ckrzen) wrote :

It looks like my issue is a combination of i915 and intel_pstates.

I'm following the thread at this bug: https://bugs.freedesktop.org/show_bug.cgi?id=88012

After switching my DELL Inspiron 3646 to the 3.16 kernel, I've had little to no trouble(even stressing the system using: glmark2 --run-forever).

I got my 3.16 kernel here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16.7-ckt18-utopic/

Hope this helps !!

Chris Rainey, the next step is to fully commit bisect from kernel 3.16 to 3.19 in order to identify the last good kernel commit, followed immediately by the first bad one. This will allow for a more expedited analysis of the root cause of your issue. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: needs-bisect regression-release
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Chris Rainey (ckrzen) wrote :

Confirming that "intel_idle.max_cstate=1" has solved my complete freeze issues on Bay Trail running Linux 4.1.13(Slackware64-current(pre-4.2) formerly running Ubuntu 15.04/15.10 with stock kernels).

Thanx for all the hard-work and long-efforts to see this through!

*** PLEASE CONSIDER MARKING THIS AS A DUPLICATE OF:

https://bugs.freedesktop.org/show_bug.cgi?id=88012

Chris Rainey (ckrzen) wrote :

*************************

Now tracking this bug here: https://bugzilla.kernel.org/show_bug.cgi?id=109051

*************************

description: updated

Chris Rainey, to advise, given this is Lauchpad (downstream reporting system) it's impossible to mark it a duplicate of an freedesktop.org (upstream reporting system) report, or any other reporting system. Also, this is not considered being tracked at bugzilla, as this hasn't been confirmed to be related.

Despite that, this report (downstream) is still pending https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1503731/comments/12 . Given your belief there is a commonality to an upstream report, it would help to provide evidence of it by confirming the regression commit noted in the upstream report is indeed the same for your hardware.

Changed in linux (Ubuntu):
importance: High → Low
Jaime Pérez (jaime-91) wrote :

I have same problem.

Changed in linux (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Jaime Pérez (jaime-91) on 2016-04-13
summary: - 8086:0f31 Ubuntu 15.04-15.10 freezes totally
+ 8086:0f31 Ubuntu 14.04-15.10 freezes totally

Jaime Pérez, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - 8086:0f31 Ubuntu 14.04-15.10 freezes totally
+ 8086:0f31 Ubuntu 15.04-15.10 freezes totally
Jaime Pérez (jaime-91) wrote :

Well, I can't change kernel, as I'm using chromeos chroot. But I don't know if its a kernel issue or a xorg-video-intel one.

Yuriy (priymayuriy) wrote :

I have the same problem
can't work on system

Yuriy (priymayuriy) wrote :

I want to add that intel_idle.max_cstate=1 didn't help me

Yuriy, if the WORKAROUND doesn't work for you, then this report has nothing to do with your problem. Hence, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Yuriy (priymayuriy) wrote :

#21 comment was no correct I have used intel_idle.max_cstate=2
Right now it`s 1 day > without ant freezes

jbMacAZ (jbmacbrodie) wrote :

I've been following these freeze issues since kernel 4.2. cstate is no longer as effective since 4.6-rc7+ and 4.5.4+.

The known relevant commits are (from bugzilla #109051):

Freezing started after 3.16.7 with commit 31685c258e0b0ad6aa486c5ec001382cf8a64212
freezing worsened again between 4.1 and 4.2 with commit 8fb55197e64d5988ec57b54e973daeea72c3f2ff
Reverting these commits in later kernels does not solve the problem. But for some users, it extends run time before the next freeze, sometimes substantially. intel_idle.max_cstate={0,1} has helped the most users the most, but it is a just a bandaid, not always effective.

The most recent kernels have rendered the ..cstate argument ineffective. Other improvements in the kernel have reduced my freeze rate from < 30 minutes to about 10 hours. At those rates, it could take a month to bisect.

Freezing only seems to occur on Intel processors (atom and later). The freeze rates vary widely from minutes to weeks. It has dependencies on the particular Intel processor & revision, the hardware platform and the kernel version. Linux distro does not seem to matter much. I have experienced freezes with Ubuntu, Mint, Manjaro, and Android_x86 on multiple platforms (Asus T100CHI & 2 Dell laptops) For me, cstate worked to prevent freezes until very recent kernels.

As an intermittent problem, most freeze reports have been dismissed with "It's not in my arena". I believe this a cluster of problems requiring concurrent fixes. I'm not sure what Ubuntu can do to solve what seems to be obvious upstream kernel problems.

Maybe Canonical can exert some influence on kernel.org to work on these freezes rather than breaking features that work while they push the bleeding edge outward. Many thousands of systems are affected, some of which belong to IT professions who influence equipment purchase and configuration for large corporations. An 18 month old fatal bug is a PR disaster waiting to happen. By fatal I mean that the freeze can irreparably corrupt an installed system (and I've had to re-install twice so far.)

yustnip (yustnip) wrote :

Probably I have related issue (also i915) - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1490647?comments=all It's very very sad. :(

Vincent Gerris (vgerris) wrote :

Hi Christopher,

Why did you ask to file a new bug to be made regarding to kernel?
I have reported a similar bug and it seems that at least one of the issues is quite throughly pinned down to that one that can be worked around with the cstate=1 or 2 for some others. Bay Trail and some successor platforms are affected.
Wouldn't we prefer to keep things centralised?
Does Canonical have any contacts with intel to spearpoint this horrible bug?
I have seen thousands of users complaining and those are just the ones that do report.
So this is very likely to be related to:
https://bugzilla.kernel.org/show_bug.cgi?id=109051

The bisect of the kernel commit might to be :
https://bugs.freedesktop.org/show_bug.cgi?id=88012#c23

Somebody at least pitched it to intel and I replied:
https://communities.intel.com/thread/60984

Please do not ask many people to bisect kernels if it might already be done, it's very daunting and there is no point for the people affected by the bug, right?

Current work arounds are running a pre-3.17 kernel and use cstate=1 (this works for my Yoga 2 11 but affects battery life quite a lot):
http://askubuntu.com/questions/749349/how-to-set-intel-idle-max-cstate-1
or for some cstate=2.

For anyone looking for more workarounds, checkout the bugzilla.kernel.org bug, there are some more options.

And PLEASE, ANYONE having contacts with intel, alert them!
I am not sure if they are aware of this issue and I can't imagine they are not, but it would certainly help to try and put the pressure up.

Thanks, hope this helps.

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.