select's FD_ISSET returns true with no data to read

Bug #1502168 reported by Tarim on 2015-10-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 14.04.3 LTS
Release: 14.04

Ubuntu 3.13.0-65.105-generic 3.13.11-ckt26

  3.13.0-63-generic seems to work fine, but in 3.13.0-65-generic, when using select; FD_ISSET returns true even when there is no data on a tty with min=0, time=0. getchar() returns -1

  Wondering if it's anything to do with the fix for https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1397976 which was added in 3.13.0-65.105?

  Actually noticed this within sox:
play xx.wav
  hangs due to continually reading the tty (it's not great code - but it showed up the bug). Whereas:
play xx.wav < /dev/null
  is fine.

  Cheers,
    Tarim
---
ApportVersion: 2.14.1-0ubuntu3.15
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tarim 2172 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=a6e8d910-2435-40ac-a7da-169eaf499ccd
InstallationDate: Installed on 2010-07-17 (1903 days ago)
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 002: ID 1c4f:0034 SiGma Micro
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD MS-7530
Package: linux (not installed)
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-65-generic root=UUID=de43ae6e-c38c-45d1-a8eb-2a9a5d55735b ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-65.105-generic 3.13.11-ckt26
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-65-generic N/A
 linux-backports-modules-3.13.0-65-generic N/A
 linux-firmware 1.127.15
RfKill:

Tags: trusty
Uname: Linux 3.13.0-65-generic i686
UpgradeStatus: Upgraded to trusty on 2014-11-28 (308 days ago)
UserGroups: adm admin audio cdrom dialout lp lpadmin plugdev sambashare video www-data
_MarkForUpload: True
dmi.bios.date: 03/04/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.2
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P7NGM-Digital (MS-7530)
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.2:bd03/04/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7530:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnP7NGM-Digital(MS-7530):rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7530
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1502168

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Tarim (q-ubuntuone-p) wrote :

Verified that the same symptoms occur on the desktop logged above and also an Acer laptop running Lubuntu - with the problem only occurring with kernel 3.13.0-65-generic and not on previous kernels in both machines.

Amul Shah (tuskentower-amulz) wrote :

This bug affects fis-gtm. Affected desktops are 14.04.3 using 3.13.0-65-generic. Other 14.04.3 systems not using that kernel are unaffected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers