Wily: Skylake: intel_pstate: fix PCT_TO_HWP macro

Bug #1499040 reported by Jason Gerard DeRose on 2015-09-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Wily
Undecided
Tim Gardner

Bug Description

The intel pstate driver is currently quite broken on on Skylake hardware.

The symptom is that the pstate driver can scale the frequency up, but wont then scale it back down. So as soon as you hit a decent amount of CPU load, you get stuck fluctuating in the turbo frequency ranges, never even dropping as low as the base clock frequency. Obviously this has very negative consequences for battery life.

Commit 74da56ce5c6715630aed3ccc0fcb86a9210c1a56 fixes this upstream, which is included in 4.3rc2:

https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/?id=74da56ce5c6715630aed3ccc0fcb86a9210c1a56

I built a custom Ubuntu kernel with this commit and tested it on a laptop with a Skylake i7-6700 CPU. As measured by powerstat, this commit dropped the idle power consumption by 11 watts (from 34 to 23 watts, screen backlight was off during the test).

I also tested this custom kernel on Haswell and Ivy Bridge hardware to make sure it didn't introduce any behaviour changes in the pstate driver on older hardware. As far as I can tell, on this older hardware pstate is behaving exactly the same with and without this commit.

Thanks!

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1499040

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Tim Gardner (timg-tpi) on 2015-09-23
Changed in linux (Ubuntu Wily):
assignee: nobody → Tim Gardner (timg-tpi)
status: Incomplete → Fix Committed
Jason Gerard DeRose (jderose) wrote :

Thanks, Tim!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.2.0-12.14

---------------
linux (4.2.0-12.14) wily; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1499712

  [ Ben Pope ]

  * SAUCE: drivers/net/ethernet/atheros/alx: Add Killer E2400 device ID
    - LP: #1498633

  [ Knuth Posern ]

  * SAUCE: thunderbolt: Allow loading of module on recent Apple MacBooks
    with thunderbolt 2 controller
    - LP: #1497321

  [ Laurent Dufour ]

  * SAUCE: powerpc/hvsi: Fix endianness issues in the HVSI driver
    - LP: #1499357

  [ Upstream Kernel Changes ]

  * x86/hyperv: Mark the Hyper-V TSC as unstable
    - LP: #1498206
  * intel_pstate: fix PCT_TO_HWP macro
    - LP: #1499040
  * perf/x86/intel/rapl: Add support for Knights Landing (KNL)
    - LP: #1461370
  * drm/i915: Add audio pin sense / ELD callback
    - LP: #1398277
  * drm/i915: Call audio pin/ELD notify function
    - LP: #1398277
  * ALSA: hda - allow codecs to access the i915 pin/ELD callback
    - LP: #1398277
  * ALSA: hda - Wake the codec up on pin/ELD notify events
    - LP: #1398277
  * drm/i915: Add locks around audio component bind/unbind
    - LP: #1398277
  * drm/i915: Drop port_mst_index parameter from pin/eld callback
    - LP: #1398277

 -- Tim Gardner <email address hidden> Thu, 24 Sep 2015 09:19:23 -0600

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers