thunderbolt ethernet adapter not hotpluggable on MacbookPro12,1

Bug #1497321 reported by Joe Barnett on 2015-09-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux (Ubuntu)
Medium
Tim Gardner
Wily
Medium
Tim Gardner

Bug Description

It works if plugged in while booted, but not after removing / replugging, or if plugging in after booted.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: linux-image-4.2.0-10-generic 4.2.0-10.11
ProcVersionSignature: Ubuntu 4.2.0-10.11-generic 4.2.0
Uname: Linux 4.2.0-10-generic x86_64
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Sep 18 07:49:45 2015
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=dd225ec0-47f4-49d8-a51c-a2547f8eb945
InstallationDate: Installed on 2015-08-21 (28 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150819)
MachineType: Apple Inc. MacBookPro11,4
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-10-generic.efi.signed root=/dev/mapper/ubuntu--gnome--vg-root ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.2.0-10-generic N/A
 linux-backports-modules-4.2.0-10-generic N/A
 linux-firmware 1.147
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/05/2015
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP114.88Z.0172.B04.1506051511
dmi.board.name: Mac-06F11FD93F0323C5
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro11,4
dmi.chassis.type: 9
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-06F11FD93F0323C5
dmi.modalias: dmi:bvnAppleInc.:bvrMBP114.88Z.0172.B04.1506051511:bd06/05/2015:svnAppleInc.:pnMacBookPro11,4:pvr1.0:rvnAppleInc.:rnMac-06F11FD93F0323C5:rvrMacBookPro11,4:cvnAppleInc.:ct9:cvrMac-06F11FD93F0323C5:
dmi.product.name: MacBookPro11,4
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Joe Barnett (thejoe) wrote :
Joe Barnett (thejoe) wrote :

looks like the patch attached to this upstream bug should fix it. would it be possible to get that into ubuntu kernels?

Thanks

Joe Barnett, thank you for reporting this and helping make Ubuntu better.

The Ubuntu Kernel Team has a preference that patches would need to be accepted into the upstream stable release first before being integrated into Ubuntu. For more on this, please see https://www.kernel.org/releases.html .

Despite this, could you please test the latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, Y, and Z are numbers corresponding to the kernel version.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: kernel-da-key
Tim Gardner (timg-tpi) wrote :

UBUNTU: SAUCE: thunderbolt: Allow loading of module on recent Apple MacBooks with thunderbolt 2 controller

Changed in linux (Ubuntu Wily):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.2.0-12.14

---------------
linux (4.2.0-12.14) wily; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1499712

  [ Ben Pope ]

  * SAUCE: drivers/net/ethernet/atheros/alx: Add Killer E2400 device ID
    - LP: #1498633

  [ Knuth Posern ]

  * SAUCE: thunderbolt: Allow loading of module on recent Apple MacBooks
    with thunderbolt 2 controller
    - LP: #1497321

  [ Laurent Dufour ]

  * SAUCE: powerpc/hvsi: Fix endianness issues in the HVSI driver
    - LP: #1499357

  [ Upstream Kernel Changes ]

  * x86/hyperv: Mark the Hyper-V TSC as unstable
    - LP: #1498206
  * intel_pstate: fix PCT_TO_HWP macro
    - LP: #1499040
  * perf/x86/intel/rapl: Add support for Knights Landing (KNL)
    - LP: #1461370
  * drm/i915: Add audio pin sense / ELD callback
    - LP: #1398277
  * drm/i915: Call audio pin/ELD notify function
    - LP: #1398277
  * ALSA: hda - allow codecs to access the i915 pin/ELD callback
    - LP: #1398277
  * ALSA: hda - Wake the codec up on pin/ELD notify events
    - LP: #1398277
  * drm/i915: Add locks around audio component bind/unbind
    - LP: #1398277
  * drm/i915: Drop port_mst_index parameter from pin/eld callback
    - LP: #1398277

 -- Tim Gardner <email address hidden> Thu, 24 Sep 2015 09:19:23 -0600

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released

hi,
I'm using Ubuntu 15.10 with kernel version 4.3.0 on a dell xps13 9350.
I still have the problem of usb-c/thunderbolt to ethernet adapter: It works if plugged in while booted, but not after removing / replugging, or if plugging in after booted.

I remeber that when I was installing Unbuntu (kernel 4.2.0) the thunderbolt worked, but I upgreded the kernel version in order to have native support for skylake and intel grafics.

Recently I tried the live of ubuntu mate 16.04 beta1, but the issue on the thunderbolt is still there.

thanks

Francesco

francesco forastieri, given this report is closed, it has nothing to do with your problem. However, if you would like your issue addressed, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.