[LTCTest][Opal][OP810] Need to have the patches for Inband IPMI HPM upgrade to work

Bug #1493017 reported by bugproxy on 2015-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Tim Gardner
Wily
Undecided
Unassigned

Bug Description

== Comment: #0 - PAVAMAN SUBRAMANIYAM <email address hidden> - 2015-08-11 01:09:54 ==
---Problem Description---
Need to have the patches for Inband IPMI HPM upgrade to work

Contact Information = <email address hidden>

---uname output---
Linux p7pite26os 3.19.0-26-generic #27~14.04.1-Ubuntu SMP Wed Jul 29 16:50:33 UTC 2015 ppc64le ppc64le ppc64le GNU/Linux

Machine Type = P8

---Debugger---
A debugger is not configured

---Steps to Reproduce---
Install a PowerNV 8335-GTA Hardware with Ubuntu 14.04.3 Netboot images.
We want to try out Inband IPMI HPM firmware upgrade using ipmitool.
So for this to work we require the mentioned patches to be back-ported.

1) 64c862a839a8db2c02bbaa88b923d13e1208919d
    Subject: devres: add kernel standard devm_k.alloc functions
2) 6357882a38c5e5a78fb055aa932e1daa0bef47e0
    Subject: powerpc/powernv: Add OPAL IPMI interface
2) 6a11e5c67a397e9a64cfde6961c83a7a64d7980c
    Subject: drivers/char/ipmi: Add powernv IPMI driver") because the ipmi_register_smi interface
3) 8b80e2e4a7103ef900ff17169542de28bad6af9e
    Subject: ipmi/powernv: Fix minor locking bug

This bug is related to the original bug:
 https://bugzilla.linux.ibm.com/show_bug.cgi?id=128130

Userspace tool common name: /usr/bin/ipmitool

The userspace tool has the following bit modes: 64-bit

Userspace rpm: ipmitool-1.8.13-1

Userspace tool obtained from project website: na

*Additional Instructions for <email address hidden>:
-Post a private note with access information to the machine that the bug is occuring on.
-Attach ltrace and strace of userspace application.

== Comment: #12 - Breno Henrique Leitao <email address hidden> - 2015-08-17 06:02:36 ==
I understand that the ubuntu 15.10 ipmitool package contains the hpm fixes as the USB feature enabled already. Can you confirm it?

== Comment: #13 - PAVAMAN SUBRAMANIYAM <email address hidden> - 2015-08-25 06:34:12 ==
I have installed a Open Power P8 Hardware with Ubuntu 15.10 latest release.

root@ltc-fire13:~# uname -a
Linux ltc-fire13 4.1.0-3-generic #3-Ubuntu SMP Tue Jul 28 12:23:44 UTC 2015 ppc64le ppc64le ppc64le GNU/Linux
root@ltc-fire13:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="15.10 (Wily Werewolf)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu Wily Werewolf (development branch)"
VERSION_ID="15.10"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

root@ltc-fire13:~# which ipmitool
/usr/bin/ipmitool
root@ltc-fire13:~# dpkg -S /usr/bin/ipmitool
ipmitool: /usr/bin/ipmitool
root@ltc-fire13:~# dpkg --list | grep ipmitool
ii ipmitool 1.8.15-1ubuntu1 ppc64el utility for IPMI control with kernel driver or LAN interface (daemon)

root@ltc-fire13:~# ipmitool -I usb
No command provided!
Commands:
        raw Send a RAW IPMI request and print response
        i2c Send an I2C Master Write-Read command and print response
        spd Print SPD info from remote I2C device
        lan Configure LAN Channels
        chassis Get chassis status and set power state
        power Shortcut to chassis power commands
        event Send pre-defined events to MC
        mc Management Controller status and global enables
        sdr Print Sensor Data Repository entries and readings
        sensor Print detailed sensor information
        fru Print built-in FRU and scan SDR for FRU locators
        gendev Read/Write Device associated with Generic Device locators sdr
        sel Print System Event Log (SEL)
        pef Configure Platform Event Filtering (PEF)
        sol Configure and connect IPMIv2.0 Serial-over-LAN
        tsol Configure and connect with Tyan IPMIv1.5 Serial-over-LAN
        isol Configure IPMIv1.5 Serial-over-LAN
        user Configure Management Controller users
        channel Configure Management Controller channels
        session Print session information
        dcmi Data Center Management Interface
        sunoem OEM Commands for Sun servers
        kontronoem OEM Commands for Kontron devices
        picmg Run a PICMG/ATCA extended cmd
        fwum Update IPMC using Kontron OEM Firmware Update Manager
        firewall Configure Firmware Firewall
        delloem OEM Commands for Dell systems
        shell Launch interactive IPMI shell
        exec Run list of commands from file
        set Set runtime variable for shell and exec
        hpm Update HPM components using PICMG HPM.1 file
        ekanalyzer run FRU-Ekeying analyzer using FRU files
        ime Update Intel Manageability Engine Firmware

root@ltc-fire13:~# ipmitool -I usb lan print
Set in Progress : Set Complete
Auth Type Support : MD5
Auth Type Enable : Callback : MD5
                        : User : MD5
                        : Operator : MD5
                        : Admin : MD5
                        : OEM : MD5
IP Address Source : Static Address
IP Address : 9.3.190.248
Subnet Mask : 255.255.255.0
MAC Address : 70:e2:84:14:01:80
SNMP Community String : AMI
IP Header : TTL=0x40 Flags=0x40 Precedence=0x00 TOS=0x10
BMC ARP Control : ARP Responses Enabled, Gratuitous ARP Disabled
Gratituous ARP Intrvl : 0.0 seconds
Default Gateway IP : 9.3.190.1
Default Gateway MAC : 00:1f:6d:a3:04:00
Backup Gateway IP : 0.0.0.0
Backup Gateway MAC : 00:00:00:00:00:00
802.1q VLAN ID : Disabled
802.1q VLAN Priority : 0
RMCP+ Cipher Suites : 0,1,2,3,6,7,8,11,12,15,16,17
Cipher Suite Priv Max : caaaaaaaaaaaXXX
                        : X=Cipher Suite Unused
                        : c=CALLBACK
                        : u=USER
                        : o=OPERATOR
                        : a=ADMIN
                        : O=OEM

== Comment: #14 - Breno Henrique Leitao <email address hidden> - 2015-08-25 08:15:00 ==
(In reply to comment #13)
> I have installed a Open Power P8 Hardware with Ubuntu 15.10 latest release.
sorry, I am not able to understand if this works or not.

Seeing the USB command and 'print' command means it worked?

Thank you,
Breno

CVE References

bugproxy (bugproxy) on 2015-09-07
tags: added: architecture-ppc64le bugnameltc-128828 severity-high targetmilestone-inin14043

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1493017/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux
affects: linux → linux (Ubuntu)
Tim Gardner (timg-tpi) wrote :

The only patch missing from 15.04 in the Bug Description list is 'ipmi/powernv: Fix minor locking bug'.

Changed in linux (Ubuntu Wily):
status: New → Fix Released
Changed in linux (Ubuntu Vivid):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Brad Figg (brad-figg) on 2015-09-14
Changed in linux (Ubuntu Vivid):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-vivid' to 'verification-done-vivid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-vivid
Launchpad Janitor (janitor) wrote :
Download full text (10.5 KiB)

This bug was fixed in the package linux - 3.19.0-31.36

---------------
linux (3.19.0-31.36) vivid; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1503703

  [ Andy Whitcroft ]

  * Revert "SAUCE: aufs3: mmap: Fix races in madvise_remove() and
    sys_msync()"
    - LP: #1503655

  [ Ben Hutchings ]

  * SAUCE: aufs3: mmap: Fix races in madvise_remove() and sys_msync()
    - LP: #1503655
    - CVE-2015-7312

linux (3.19.0-31.35) vivid; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1503005

  [ Ben Hutchings ]

  * SAUCE: aufs3: mmap: Fix races in madvise_remove() and sys_msync()
    - CVE-2015-7312

  [ Craig Magina ]

  * [Config] Add XGENE_EDAC, EDAC_SUPPORT and EDAC_ATOMIC_SCRUB
    - LP: #1494357

  [ John Johansen ]

  * SAUCE: (no-up) apparmor: fix mount not handling disconnected paths
    - LP: #1496430

  [ Laurent Dufour ]

  * SAUCE: powerpc/hvsi: Fix endianness issues in the HVSI driver
    - LP: #1499357

  [ Tim Gardner ]

  * [Config] CONFIG_RTC_DRV_XGENE=y for only arm64
    - LP: #1499869

  [ Upstream Kernel Changes ]

  * Revert "sit: Add gro callbacks to sit_offload"
    - LP: #1500493
  * ipmi/powernv: Fix minor locking bug
    - LP: #1493017
  * mmc: sdhci-pci: set the clear transfer mode register quirk for O2Micro
    - LP: #1472843
  * perf probe ppc: Fix symbol fixup issues due to ELF type
    - LP: #1485528
  * perf probe ppc: Use the right prefix when ignoring SyS symbols on ppc
    - LP: #1485528
  * perf probe ppc: Enable matching against dot symbols automatically
    - LP: #1485528
  * perf probe ppc64le: Fix ppc64 ABIv2 symbol decoding
    - LP: #1485528
  * perf probe ppc64le: Prefer symbol table lookup over DWARF
    - LP: #1485528
  * perf probe ppc64le: Fixup function entry if using kallsyms lookup
    - LP: #1485528
  * perf probe: Improve detection of file/function name in the probe
    pattern
    - LP: #1485528
  * perf probe: Ignore tail calls to probed functions
    - LP: #1485528
  * seccomp: cap SECCOMP_RET_ERRNO data to MAX_ERRNO
    - LP: #1496073
  * EDAC: Cleanup atomic_scrub mess
    - LP: #1494357
  * arm64: Enable EDAC on ARM64
    - LP: #1494357
  * MAINTAINERS: Add entry for APM X-Gene SoC EDAC driver
    - LP: #1494357
  * Documentation: Add documentation for the APM X-Gene SoC EDAC DTS
    binding
    - LP: #1494357
  * EDAC: Add APM X-Gene SoC EDAC driver
    - LP: #1494357
  * arm64: Add APM X-Gene SoC EDAC DTS entries
    - LP: #1494357
  * EDAC, edac_stub: Drop arch-specific include
    - LP: #1494357
  * NVMe: Fix blk-mq hot cpu notification
    - LP: #1498778
  * blk-mq: Shared tag enhancements
    - LP: #1498778
  * blk-mq: avoid access hctx->tags->cpumask before allocation
    - LP: #1498778
  * x86/ldt: Make modify_ldt synchronous
    - LP: #1500493
  * x86/ldt: Correct LDT access in single stepping logic
    - LP: #1500493
  * x86/ldt: Correct FPU emulation access to LDT
    - LP: #1500493
  * md: flush ->event_work before stopping array.
    - LP: #1500493
  * ipv6: addrconf: validate new MTU before applying it
    - LP: #1500493
  * virtio-net: drop NETIF_F_FRAGLIST
    - LP: #1500493
  * RDS: verify the underlying transport exists bef...

Changed in linux (Ubuntu Vivid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers