dmesg shows "[drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!"

Bug #1488719 reported by Alexander List on 2015-08-26
742
This bug affects 140 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Unassigned

Bug Description

On a recent intel NUC using i915 graphics, I get the following errors in dmesg:

[drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!

There are two monitors connected to this box, one with mini-HDMI->HDMI, one with mini-DP->HDMI cable.

Maybe related:

https://bugs.freedesktop.org/show_bug.cgi?id=80896

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-generic 3.19.0.26.25
ProcVersionSignature: Ubuntu 3.19.0-26.28-generic 3.19.8-ckt4
Uname: Linux 3.19.0-26-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.3
Architecture: amd64
Date: Wed Aug 26 10:07:31 2015
InstallationDate: Installed on 2015-08-01 (24 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.19.0-26-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 102239
dmesg

==System Environment==
--------------------------
Regression: Yes.
Good commit on -next-queued: b6fdd0f2b990006daba19eec676b632faa523fc8

Non-working platforms: BDW

==kernel==
--------------------------
origin/drm-intel-nightly: eb638c7fabe97a9df752aeb2f59a9463ce4aed8e(fails)
    drm-intel-nightly: 2014y-07m-03d-14h-50m-16s integration manifest
origin/drm-intel-next-queued: 5e59f7175f96550ede91f58d267d2b551cb6fbba(fails)
    drm/i915: Try harder to get FBC
origin/drm-intel-fixes: 5549d25f642a7e6cfb8744d0031a9da404f696d6(works)
    drm/i915: Drop early VLV WA to fix Voltage not getting dropped to Vmin

==Bug detailed description==
dmesg error "<3>[ 1.954836] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!" after boot.

Output:
[root@x-bdw01 ~]# dmesg -r | egrep "<[1-3]>" |grep drm
<3>[ 1.955683] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!
<3>[ 1.955848] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!
<3>[ 3.683649] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!
<3>[ 3.686870] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!

==Reproduce steps==
----------------------------
1. boot
2. dmesg -r | egrep "<[1-3]>" |grep drm

Can you please bisect this? Which one is the bad commit?

No need to bisect, the error message was introduced by Oscar in

commit 38cc46d73ed99dd7002f1406002e52d7975d16cc
Author: Oscar Mateo <email address hidden>
Date: Mon Jun 16 16:10:59 2014 +0100

    drm/i915/bdw: Ack interrupts before handling them (GEN8)

And for those reason bit 23 of master ctl is set and the SDE IIR is 0.

Created attachment 102730
dmesg

(In reply to comment #2)
> No need to bisect, the error message was introduced by Oscar in
>
> commit 38cc46d73ed99dd7002f1406002e52d7975d16cc
> Author: Oscar Mateo <email address hidden>
> Date: Mon Jun 16 16:10:59 2014 +0100
>
> drm/i915/bdw: Ack interrupts before handling them (GEN8)
>
> And for those reason bit 23 of master ctl is set and the SDE IIR is 0.
Revert this commit on latest -next-queued,error "<3>[ 1.955683] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!" unable to reproduce, but here has another error. Please check the output below. Need we report a new bug for this?

Output:
[root@x-bdw01 ~]# dmesg -r | egrep "<[1-3]>" |grep drm
<3>[ 2.753243] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[ 2.768133] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[ 2.780219] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[ 2.792092] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[ 2.804271] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[ 2.813306] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[ 2.831054] [drm:intel_dp_start_link_train] *ERROR* failed to update link training
<3>[ 2.832254] [drm:intel_dp_complete_link_train] *ERROR* failed to train DP, aborting

Hi

It seems you're booting with eDP+HDMI. I can't reproduce this with eDP+HDMI or just eDP. Can you please confirm whether this only happens when you boot with DP (or DP+something) attached?

Thanks,
Paulo

(In reply to comment #4)
> Hi
>
> It seems you're booting with eDP+HDMI. I can't reproduce this with eDP+HDMI

What I wanted to say was: "It seems you're booting with eDP+DP."

> or just eDP. Can you please confirm whether this only happens when you boot
> with DP (or DP+something) attached?
>
> Thanks,
> Paulo

Created attachment 104474
dmesg(14bf99)

It doesn't happen on latest -queued and -nightly kernel.I guess someone fixed it.

(In reply to comment #6)
> Created attachment 104474 [details]
> dmesg(14bf99)
>
> It doesn't happen on latest -queued and -nightly kernel.I guess someone
> fixed it.

Closing bug then. If it still happens, please reopen.

Verified on latest -nightly(723dbbfb6ce02b5662c0c4cac9be3bcdfbb11d35)

[root@x-bdw01 ~]# dmesg -r | egrep "<[1-3]>" |grep drm
[root@x-bdw01 ~]#

Created attachment 115902
dmesg

I just saw this error while running the 4.0.3 kernel (4.0.3-300.fc22.x86_64).

Created attachment 116126
dmesg output, post event

Comment on attachment 116126
dmesg output, post event

This happens on a new NUC, with

CPU0: Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz (fam: 06, model: 3d, stepping: 04)

I'm running a 4K display off the miniDP port.

It happens almost every single time I walk away from the computer within 10-15 minutes.

*** Bug 90058 has been marked as a duplicate of this bug. ***

Created attachment 117855
master control interrupt lied event

Not exactly sure what I'm looking at here. Using live infrastructure (libdrm, mesa, xorg-server, xf86-video-intel, all -9999) on gentoo.

Linux hatshepsut 4.1.6-gentoo #1 SMP Thu Aug 20 13:12:11 CEST 2015 x86_64 Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz GenuineIntel GNU/Linux

If you need additional info, please let me know.

19 comments hidden view all 181 comments
Alexander List (alexlist) wrote :
Alexander List (alexlist) wrote :
Alexander List (alexlist) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → High
Timo Aaltonen (tjaalton) wrote :
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Alexander List (alexlist) wrote :

Nope. Still get that message.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Alexander List (alexlist) wrote :
Changed in linux:
importance: Unknown → High
status: Unknown → Confirmed
14 comments hidden view all 181 comments
Peter Matulis (petermatulis) wrote :

Tried 4.3-rc1 [1] on an Asus Zenbook trying to escape bug 1492632 and I am now getting this message.

[1]: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-rc1-unstable/

cboettig (cboettig) wrote :

Also getting this error sporadically, only with an external monitor, on the Dell XPS-13 developer edition (ships w/ ubuntu) on either 5.04 with 3.18 kernel or 5.10 beta with 4.2 kernel. Appears to be some kind of buffer overrun triggered by certain intensive tasks.

Stefan Langeland (morphuspam) wrote :

Getting this error as well on a Dell XPS-13 developer edition (ubuntu 14.04 LTE) with Kernel 4.3.0-rc2 from mainline[1].

Error occurs when I connect an external monitor on DisplayPort with 4k/60hz: Monitor flickers, turns black every five seconds and turns off completely after two or three minutes.

Error message (constantly with dmesg)

[14142.692434] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
...

After changing resolution back to 1920x1080 everything works fine again without any error messages.
Reproducable with stock kernel on ubuntu (3.13.0-37).

[1]: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-rc2-unstable/

Stephen Thirlwall (l-sdt) wrote :

I've just started getting this after updating to linux-image-3.19.0-30-generic from linux-image-3.19.0-28-generic.

NUC 5i3RYH connected via the mini-hdmi port to a 720p tv.

100% repeatable for me using Kodi 15.1. If I play a video I get audio, but the video is all black. If I activate the on-screen display items they render fine, but the video content itself is missing. Audio is fine.

Entering and exiting a video I get this each time:

[ 29.275053] [drm:gen8_irq_handler [i915_bpo]] *ERROR* The master control interrupt lied (SDE)!
[ 29.275763] [drm:gen8_irq_handler [i915_bpo]] *ERROR* The master control interrupt lied (SDE)!
[ 29.316539] sound hdaudioC0D0: HDMI: ELD buf size is 0, force 128
[ 29.316579] sound hdaudioC0D0: HDMI: invalid ELD data byte 0
[ 29.348980] [drm:gen8_irq_handler [i915_bpo]] *ERROR* The master control interrupt lied (SDE)!
[ 29.363813] [drm:gen8_irq_handler [i915_bpo]] *ERROR* The master control interrupt lied (SDE)!

Always the first six lines, sometimes more of the (SDE!) lines follow. Always one set when playback begins, and another when playback ends.

Further to this, if I disable VAAPI acceleration in Kodi, the video playback works again, but the kernel messages still appear.

Both the black-video and the messages are completely new in 3.19.0-30 - haven't seen either in earlier kernels.

Billy Olsen (billy-olsen) wrote :

Just saw this new after updating to the 3.19.0-30-generic kernel in vivid.

Alex (leo-tv) wrote :

Have the same problem on NUC5i5RYH connected to monitor via DisplayPort

> Ubuntu Server 14.04.3 LTS (GNU/Linux 3.19.0-30-generic x86_64)

1 comments hidden view all 181 comments

Created attachment 118836
The master control interrupt lied

kernel output on a
Lenovo X1 Carbon (3rd gen) connected to a lenovo onelink pro dock

(In reply to Kim Carlsen from comment #14)
> Created attachment 118836 [details]
> The master control interrupt lied
>
> kernel output on a
> Lenovo X1 Carbon (3rd gen) connected to a lenovo onelink pro dock

Outputting 2560x1440@60 works fine, outputting 3840x2160@60 produces no picture on external monitor.

When removing the onelink prodock and connecting the dp cable directly to the laptop then all resolutions works (3840x2160@60).

Whenever running xrandr it adds 36 lines to kernel log of 'The master control interrupt lied'

When 4k resolution is working, these error message is still present in kernel.log. Maybe resolution issue is unrelated to IRQ issue

(In reply to Kim Carlsen from comment #16)
> When 4k resolution is working, these error message is still present in
> kernel.log. Maybe resolution issue is unrelated to IRQ issue

Please file that as a separate bug to not conflate this one, thanks.

3 comments hidden view all 181 comments
Brian Neltner (neltnerb) wrote :

I can verify that I also am getting this error now that I am running 3.19.0-30 on Intel NUC5i7RYH with Iris 6100 graphics.

I don't know what the error means, but definitely getting it. Upon update now my boot screen doesn't properly load and I have to decrypt the disk with nothing on the screen, clear regression from 3.19.0-28, but not sure if it's related.

4 comments hidden view all 181 comments
stan383 (stan383) wrote :

I have Lenovo Thinkpad L450 with Intel HD Graphics 5500 and I can confirm the issue is present in the mainline kernel 4.3.0-040300rc. I did not have real noticeable issue - I just see the error messages in the log. It can be reproduced by executing xrandr while an external monitor is connected to the laptop. Any time I execute it, it will produce the error messages. Also connecting the external monitor to DP2 (analog VGA) will produce the error messages in dmesg.

When there is only laptop screen on and no external display connected, it looks executing xrandr will not produce the errors.

The problem is present in 3.19.0-30 but it is not present in 3.19.0-15.
I tried also 3.19.0-28, but using this kernel, my external monitor and even my external USB mouse and keyboard did not work.

rolfinator (seb2) wrote :

Affects me too on HP 820 G2 with Xubuntu 15.04 on Kernel 3.19.0-31-generic.

commit 97e5ed1111dcc5300a0f59a55248cd243937a8ab
Author: Daniel Vetter <email address hidden>
Date: Fri Oct 23 10:56:12 2015 +0200

    drm/i915: shut up gen8+ SDE irq dmesg noise

Changed in linux:
status: Confirmed → Fix Released
Morten Clausen (morten-c) wrote :

Maybe I don't get it, but: Is the fix only shutting up the kernel messages or is this fixing the cause?

I'm expiriencing this messages on a Lenovo T450 (20BX011GE) running 15.10 with 4.2.0-16-generic kernel. I see this messages wether external monitor is connected or not, although with much higher frequency with external monitor connected (dp via dock).

It seems like this messages is related to random GDM crashes. I tried to reproduce this behaviour, but I've got no clue when this is happening so far. I will try to investigate this further.

Puggan (from-ubuntu-b) wrote :

Got this error in my dmesg, and gets daily KDM crashes.

Have an Asus X555L with 2 external monitors connected,
each morning when i get back to the computer, the laptop screen dosn't start,
and I have no working window managment => I can use the active window, but can't change active window.

Also, if i activate the wireless-card, I can see the si (software interupt) in top raise to 100%, and then I lose all controll.
And all I found so far is this error message 1836 times in the dmesg-log

Jeroko (jeroko) wrote :
Download full text (3.1 KiB)

I get this error on my new Toshiba P50t-C-104, with kernel 4.3. No monitors attached, just the default laptop screen. I get a black screen after this message on boot. The only way to boot is to use the 'nomodeset' kernel parameter, but that dissables the intel graphics card.

[ 6.254918] [drm:i915_gem_open]
[ 6.254990] [drm:drm_mode_getresources] CRTC[3] CONNECTORS[2] ENCODERS[2]
[ 6.254993] [drm:drm_mode_getresources] [CRTC:21]
[ 6.254995] [drm:drm_mode_getresources] [CRTC:25]
[ 6.254996] [drm:drm_mode_getresources] [CRTC:29]
[ 6.254997] [drm:drm_mode_getresources] [ENCODER:31:TMDS-31]
[ 6.254999] [drm:drm_mode_getresources] [ENCODER:39:TMDS-39]
[ 6.255000] [drm:drm_mode_getresources] [CONNECTOR:32:eDP-1]
[ 6.255002] [drm:drm_mode_getresources] [CONNECTOR:40:HDMI-A-1]
[ 6.255003] [drm:drm_mode_getresources] CRTC[3] CONNECTORS[2] ENCODERS[2]
[ 6.255008] [drm:drm_mode_getconnector] [CONNECTOR:32:?]
[ 6.255010] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:32:eDP-1]
[ 6.255011] [drm:intel_dp_detect] [CONNECTOR:32:eDP-1]
[ 6.255018] [drm:edp_panel_vdd_on] Turning eDP port A VDD on
[ 6.255024] [drm:edp_panel_vdd_on] PP_STATUS: 0x80000008 PP_CONTROL: 0xabcd000f
[ 6.255476] [drm:drm_edid_to_eld] ELD: no CEA Extension found
[ 6.255480] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:32:eDP-1] probed modes :
[ 6.255483] [drm:drm_mode_debug_printmodeline] Modeline 33:"3840x2160" 60 533250 3840 3888 3920 4000 2160 2163 2168 2222 0x48 0xa
[ 6.255487] [drm:drm_mode_getconnector] [CONNECTOR:32:?]
[ 6.255497] [drm:drm_mode_getconnector] [CONNECTOR:40:?]
[ 6.255498] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:40:HDMI-A-1]
[ 6.255500] [drm:intel_hdmi_detect] [CONNECTOR:40:HDMI-A-1]
[ 6.255657] [drm:gmbus_xfer] GMBUS [i915 gmbus dpb] NAK for addr: 0050 w(1)
[ 6.255658] [drm:gmbus_xfer] GMBUS [i915 gmbus dpb] NAK on first message, retry
[ 6.255815] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[ 6.255817] [drm:gmbus_xfer] GMBUS [i915 gmbus dpb] NAK for addr: 0050 w(1)
[ 6.255819] [drm:drm_do_probe_ddc_edid] drm: skipping non-existent adapter i915 gmbus dpb
[ 6.255821] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:40:HDMI-A-1] disconnected
[ 6.255824] [drm:drm_mode_getconnector] [CONNECTOR:40:?]
[ 6.255826] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:40:HDMI-A-1]
[ 6.255828] [drm:intel_hdmi_detect] [CONNECTOR:40:HDMI-A-1]
[ 6.255986] [drm:gmbus_xfer] GMBUS [i915 gmbus dpb] NAK for addr: 0050 w(1)
[ 6.255988] [drm:gmbus_xfer] GMBUS [i915 gmbus dpb] NAK on first message, retry
[ 6.256147] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[ 6.256149] [drm:gmbus_xfer] GMBUS [i915 gmbus dpb] NAK for addr: 0050 w(1)
[ 6.256150] [drm:drm_do_probe_ddc_edid] drm: skipping non-existent adapter i915 gmbus dpb
[ 6.256152] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:40:HDMI-A-1] disconnected
[ 6.302099] init: alsa-restore main process (976) terminated with status 99
...

Read more...

Tim Holy (holy-wustl) wrote :

I'm still getting this on 4.2.0-17-generic with a Lenovo W550s. Moreover, [if you read the patch](http://www.spinics.net/lists/intel-gfx/msg78796.html) you'll see it just affects whether it prints the warning, and doesn't correct the underlying problem. Related or not, I'm also seeing the blank-screen symptoms [reported here](https://github.com/NixOS/nixpkgs/issues/9755).

I am getting this as well WITHOUT any external monitors plugged.
4.2.0-17-generic

I was getting similar behavior on arch Linux with 4.2.x

I also get this error prior:
[drm:intel_pipe_config_compare [i915]] *ERROR* mismatch in base.adjusted_mode.crtc_clock (expected 138780, found 92519)

Changed in linux:
importance: High → Unknown
status: Fix Released → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
101 comments hidden view all 181 comments

(In reply to darkbasic from comment #26)
> When did you shut up the messages for the first time? I always saw them in
> every RC, including latest 4.4-rc8.

drm-next, not Linus' upstream.

Please see this bug report:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1520040

This bug makes my Dell Latitude laptop shutdown (power off). In that bug report I provided a lot of information about my system, logs and tests I did. Currently, only kernel "3.13.0-36-generic" running module "/lib/modules/3.13.0-36-generic/kernel/ubuntu/i915/i915_bdw.ko" doesn't have this bug.

Hence, this bug is far from "solved" and shutting up dmesg definitely won't solve it.

(In reply to Yuri from comment #28)
> Please see this bug report:
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1520040
>
> This bug makes my Dell Latitude laptop shutdown (power off). In that bug
> report I provided a lot of information about my system, logs and tests I
> did. Currently, only kernel "3.13.0-36-generic" running module
> "/lib/modules/3.13.0-36-generic/kernel/ubuntu/i915/i915_bdw.ko" doesn't have
> this bug.
>
> Hence, this bug is far from "solved" and shutting up dmesg definitely won't
> solve it.

That has nothing to do with these error messages.

Changed in linux:
status: Confirmed → Fix Released
Gronor (tonut) wrote :

So did 4.5.0 RC6 fixed it for you guys?

It still reproduces for me even with this kernel

dancer7162 (dancer7162) wrote :

Yes it fixed it for me.
System is NUC5i7RYH using the HDMI port (using linux-image-4.5.0-040500rc6-generic, amd64)
thank you guys

Carroarmato0 (carroarmato0) wrote :

After some longer tests looks like this is still not 100% with RC6 :(

Raniz (raniz-1) wrote :

I haven't noticed any issues in my day-to-day work with RC6. Can't say all issues are completely resolved since I haven't done any exhaustive testing but it's a major improvement over RC5.

darkhawk (info-sarazin) wrote :

Hey folks,

there is an BIOS Update for the Lenovo T450s

[Problem fixes]
- Fixed an issue related to system unable to power on due to chipset hang in some specific situation.

Will try this....

Feedback will come

darkhawk (info-sarazin) wrote :

Ok, nothing new

[ 1510.565374] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!

thomas955 (thoehlig) wrote :

Hi,

we recently got our new E7450 Notebooks from Dell and encountered the same Problems.
Main Problem - Displays flickering or turn to black at all.
We use 3 Displays 2x externeal via DP / HDMI 1920x1080 + E7450 build in with 1920x1080.

OS is Ubuntu 14.04LTS with Kernel 4.2.0-30-generic.
I also tested few hours ago the latest Kernel 4.5.0-040500rc7-generic but after a few minutes one Display started to flicker again.

The dmesg messag "[drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!" occurs in 4.2 but not in 4.5.

There is another dmesg message in 4.5 that seems to be related to the i915 driver:

[Di Mär 8 17:51:44 2016] pci_bus 0000:02: Allocating resources
[Di Mär 8 17:51:44 2016] pci_bus 0000:03: Allocating resources
[Di Mär 8 17:51:44 2016] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[Di Mär 8 17:51:44 2016] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
.
.
.
[Di Mär 8 17:53:14 2016] WARNING: CPU: 0 PID: 1278 at /home/kernel/COD/linux/drivers/gpu/drm/i915/intel_uncore.c:599 hsw_unclaimed_reg_debug+0x69/0x90 [i915]()
[Di Mär 8 17:53:14 2016] Unclaimed register detected after reading register 0x223a0

modinfo i915
filename: /lib/modules/4.5.0-040500rc7-generic/kernel/drivers/gpu/drm/i915/i915.ko
license: GPL and additional rights
description: Intel Graphics
author: Intel Corporation
author: Tungsten Graphics, Inc.
firmware: i915/bxt_dmc_ver1.bin
firmware: i915/skl_dmc_ver1.bin
firmware: i915/skl_guc_ver4.bin
srcversion: A8C37B25F49F03AE77E49D0

Hardware:
E7450
Graphics:
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Dell Device 062e
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 51
 Region 0: Memory at f5000000 (64-bit, non-prefetchable) [size=16M]
 Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at f000 [size=64]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
  Address: fee00018 Data: 0000
 Capabilities: [d0] Power Management version 2
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [a4] PCI Advanced Features
  AFCap: TP+ FLR+
  AFCtrl: FLR-
  AFStatus: TP-
 Kernel driver in use: i915

in addition i have a:
03:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M]
but its not in use.

If you need more Information ...
Thank you in advance
Thomas

Gronor (tonut) wrote :

@thoehlig can you check if you lower the resolution to 1280 x 1024 you still have this problem? If i switch my external monitors to that resolution, the flickering is gone.

thomas955 (thoehlig) wrote :

I will check this, but its not a solution for me and my users to lower the screen resolution to avoid flickering.

Btw. today with Kernel 4.5 i also had flickering but there were no messages in dmesg.

Dr4K4n (stefan-dr4k4n) wrote :

I'm having similar problems on my Dell XPS 13 9343 running 15.10 with 4.5.0-040500rc6-generic.
I've ran 2 FullHD displays daisy-chained to the miniDP of the notebook, both monitors switched to DP 1.2. This lead to flickering. I since then dropped that configuration and run a single display set to DP 1.1 without flickering.
Still there are some problems.
When watching a YouTube video fullscreen and changing the volume the screen freezes. The volume overlay doesn't appear, but the video seems to play along and the PC doesn't react to keypresses.
The only way out is switching to a TTY (Ctrl+Alt+F1) and restarting lightdm.

Also since I've switched from 4.2.0-30-generic to 4.5.0-040500rc6-generic the messages in dmesg disappeared.
Please let me know when you need any more infos from me.

thomas955 (thoehlig) wrote :

@Gronor Tested 1280x720 on all Displays, same problem.

Gronor (tonut) wrote :

That is strange. On that resolution I don't get the flicker. But as you said, it's not an option, though would have been a good indicator for people looking into this.

Christian George (radu-j) wrote :

I have a Dell XPS 13 9343 running Ubuntu 15.10 with 4.2.0-16-generic . Every few days my system freezes and I can move the mouse pointer but can't click on anything. Pressing anything on the keyboard has no effect.

I am using the laptop display + an external monitor Dell U2913WM (2560x1080 @60Hz). I see no flicker or anything else on the displays. I only experience the freeze just as Dr4K4n (stefan-dr4k4n) wrote above.

thomas955 (thoehlig) wrote :

I think the flickering problem only occurs if you use two external monitors with e-port-dock.

"I think the flickering problem only occurs if you use two external monitors with e-port-dock."

In my case, my laptop suddenly powers off. But another bug that happens in it is this: after a while with Xscreensaver running, the screen flickers and remains that way for some 3 extra seconds after I type my password and the screen is unlocked.

Weird thing is that after the screen is unlocked, some 3 seconds later the flickering stops.

Morten Clausen (morten-c) wrote :

I'm still not sure what we're looking at here, especially if the original message this bug deals with has anything to do with the other described buggy behaviour here, which are: random freezes, display flickering, not working external displays etc. I watched the development of the comments in this bug really closely (not at least because of my own interests being affected as well) and there hasn't been any real progress in investigating this issue(s) further. I think this is not least caused by the complexity and variatons of issues regarding graphics.

IMHO this leads to three taks which has to be done:

1. Identifiying distinct issues and filing distinct bug reports while being aware of possible duplicates.

2. If you're affected and feeling confident in providing more information, investigate those distinct issues further and provide proper amounts of logs/traces etc. possbile related to those distinct issues.

3. Pushing those issues to the proper upstream bugtrackes. (For me this is one of the hardest parts, since I'm not sure which parts play a role here, e.g. kernel, display manager etc.) When I look at my own logs (attached) my issue still looks like a kernel problem.

I've tested the 4.5RC7, the origial message is gone, but my external display (connected to DP of my advanced lenovo dock) stays black if the T450s is docked while booting. If I undock after boot and then dock it again, the system freezes totally and syslog is showing some serious kernel issues. The only way to cirumvent this behaviour is to boot undocked and then dock when the system is fully booted. I'm currently using this workaround in my daily work to see if there are other issues. I think I will file a bug report on bugs.freedesktop.org later.

Happens to me on a NUC i7 DP port..... it happens when monitor goes idle power save mode or when i turn off the monitor.

Linux nuc 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Distributor ID: Ubuntu
Description: Ubuntu 15.10
Release: 15.10
Codename: wily

Manu Cogolludo (makova) wrote :

Lenovo Think Pad X1 Carbon Intel® Core™ i7-5600U CPU @ 2.60GHz × 4

Kernel solved

uname -a

Linux 4.5.0-040500-generic #201603140130 SMP Mon Mar 14 05:32:22 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Gronor (tonut) wrote :

@Manu, what exactly is fixed? I am running this kernel now and the display flicker issue is not gone

Gronor (tonut) wrote :

We might as well close this report, nobody seems to care

Piotr (thisredoned) wrote :

uname -a
Linux 4.5.0-040500rc7-generic #201603061830 SMP Sun Mar 6 23:33:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

the issue (massive flickering, turning off) is still very much a problem. I'm on dell xps 13 with two dell monitors daisy chained. The second one is getting most of the flickering.

I am facing same issue after once I force shutdown My OS(laptop). And, now I cannot logon.

Download full text (5.7 KiB)

I have been affected by this bug for a while as well. This is my setup:

Dell E5450 with Ubuntu 14.04.04 LTS with kernel: 4.2.0-34-generic

The laptop is connected to a Dell E-Port Plus Advanced Port Replicator.

The port replicator is connected via two seperate DP -> mDP cables to two monitors of model Dell 27" QHD U2715H.

I get the same annoying error in dmesg but that is the least of my problems. I also get complete crashes where changing TTY is impossible. The entire laptop will also at times reboot, even when not being used. I also get the same problem others have reported where waking up the laptop causes the second screen to go back into power-save mode. I used to have screen flickering in Windows 10 Professional. But i have not seen this behavior in Ubuntu.

I also get this suspicious error in /var/log/syslog

Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931613] ------------[ cut here ]------------
Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931631] WARNING: CPU: 1 PID: 1367 at /build/linux-lts-wily-MVxxD8/linux-lts-wily-4.2.0/drivers/gpu/drm/i915/intel_ddi.c:756 intel_ddi_get_crtc_new_encoder+0x94/0xa0 [i915]()
Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931632] 2 encoders on crtc for pipe A
Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931633] Modules linked in: pci_stub vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) cmac dm_crypt dell_wmi sparse_keymap dell_laptop dcdbas dell_smm_hwmon hid_logitech_hidpp uvcvideo intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp videobuf2_vmalloc videobuf2_memops kvm_intel snd_soc_rt5640 videobuf2_core btusb btrtl btbcm v4l2_common btintel kvm videodev snd_soc_rl6231 media crct10dif_pclmul snd_soc_core crc32_pclmul bnep rfcomm snd_compress arc4 ac97_bus snd_pcm_dmaengine bluetooth snd_seq_midi aesni_intel aes_x86_64 iwlmvm lrw gf128mul glue_helper ablk_helper cryptd mac80211 snd_seq_midi_event snd_rawmidi dell_led iwlwifi snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic joydev input_leds snd_hda_intel snd_hda_codec cfg80211 serio_raw snd_seq mei_me snd_hda_core snd_hwdep mei lpc_ich shpchp snd_pcm snd_seq_device snd_timer dw_dmac snd dw_dmac_core int3403_thermal 8250_fintek snd_soc_sst_acpi dell_smo8800 parport_pc soundcore 8250_dw ppdev i2c_hid int3400_thermal spi_pxa2xx_platform processor_thermal_device acpi_thermal_rel acpi_pad dell_rbtn i2c_designware_platform intel_soc_dts_iosf i2c_designware_core mac_hid int3402_thermal acpi_als int340x_thermal_zone lp parport kfifo_buf industrialio hid_logitech_dj hid_generic usbhid hid i915 psmouse i2c_algo_bit ahci drm_kms_helper e1000e libahci drm ptp sdhci_pci pps_core wmi sdhci_acpi video sdhci
Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931682] CPU: 1 PID: 1367 Comm: Xorg Tainted: G OE 4.2.0-34-generic #39~14.04.1-Ubuntu
Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931683] Hardware name: Dell Inc. Latitude E5450/09X6YN, BIOS A10 09/01/2015
Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931684] ffffffffc026b130 ffff8804085eb9c8 ffffffff817b5fed 0000000000000000
Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931686] ffff8804085eba18 ffff8804085eba08 ffffffff8107799a 0000000100020101
Apr 12 08:53:43 SIKR-E5450 kernel: [ 5.931687] f...

Read more...

xeno678g (e3-hvag-jl) wrote :

On NUC NUC5i3RYB
(Lubuntu 15.10 amd64)
BIOS : RYBDWi35.86A.0354.2016.0120.0912 Date: 01/20/2016

kernel 4.6.0-040600rc3-generic from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc3-wily/

Finally fixed this for me (Yamaha RX-V475 hdmi handling was/is still buggy).

Ed Broadley (rebroad+ubuntu) wrote :

Getting this on: Linux UX303LNB 4.2.0-35-generic #40-Ubuntu SMP Tue Mar 15 22:15:45 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Also seeing these messages in tty1: [drm:intel_pipe_config_compare [i915]] *ERROR* mismatch in base.adjusted_mode.crtc_clock (expected 138780, found 91519)

Ed Broadley (rebroad+ubuntu) wrote :

Also getting this on: Linux UX303LNB 4.2.6-040206-generic #201511091832 SMP Mon Nov 9 23:34:22 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Gronor (tonut) wrote :

Hey Ivan,
so with kernel 4.6.0-040600rc3-generic the monitor(s) don't turn on and off anymore?

Gronor (tonut) wrote :

Unfortunately 4.6.0-040600rc3-generic still has the intermittent screen blinking issue for me.

Ed Broadley (rebroad+ubuntu) wrote :

No longer happening with the latest git build of: Linux UX303LNB 4.6.0-rc3-custom #1 SMP Fri Apr 15 00:59:30 BST 2016 x86_64 x86_64 x86_64 GNU/Linux

Gronor (tonut) wrote :

Ed, can you specify what is no longer happening?

zeine77 (mohamed-eyil) wrote :

I have written the comment 52 above; those eroor messages seem to be gone with 16.04 release. I have no longer those errors.

Gronor (tonut) wrote :

Error messages have been gone for a long time for me. Symptoms however, have not

[ 35.769534] Bluetooth: RFCOMM socket layer initialized
[ 35.769539] Bluetooth: RFCOMM ver 1.11
[ 367.276773] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[ 367.277129] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[ 367.278570] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[ 367.278928] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[ 367.279650] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!

Ubuntu got stuck (I re-booted without dropping to shell), only mouse movement worked. It was a low memory condition and an external display was connected. The system setup was 15.10 Ubuntu 4.2.0-42-generic #49-Ubuntu SMP using NUC5i7RYH.

"[Bug 1488719] Re: dmesg shows "[drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!""
David Valdivieso doc

1 comments hidden view all 181 comments

Win yesterday $15044
[Bug 1488719] Re: dmesg shows "[drm:gen8_irq_handler [i915]] ERROR The master control interrupt lied (SDE)!"

Displaying first 40 and last 40 comments. View all 181 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.