Broadcom bluetooth modules sometimes fail to initialize

Bug #1483101 reported by Jesse Sung on 2015-08-10
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Jesse Sung
linux (Ubuntu)
Medium
Jesse Sung
Nominated for Xenial by Thadeu Lima de Souza Cascardo
Nominated for Yakkety by Thadeu Lima de Souza Cascardo
Zesty
Medium
Jesse Sung

Bug Description

This message can be found in dmesg:
[ 15.080247] Bluetooth: hci0 command 0x1001 tx timeout

Currently known affected modules:
* 0a5c:216a
* 0a5c:6410
* 0a5c:6412

Jesse Sung (wenchien) on 2015-08-10
Changed in hwe-next:
status: New → In Progress
assignee: nobody → Jesse Sung (wenchien)
elrosti (elrosti) wrote :

I'm affected too.

My module is 0a5c:216c

Thanks in advance.

andrew.gedz (andrew.gedz) wrote :

same problem on Lenovo x1 carbon 1st gen
0a5c:21e6
 9903.370351] usb 1-1.4: new full-speed USB device number 9 using ehci-pci
[ 9903.467690] usb 1-1.4: New USB device found, idVendor=0a5c, idProduct=21e6
[ 9903.467697] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 9903.467701] usb 1-1.4: Product: BCM20702A0
[ 9903.467705] usb 1-1.4: Manufacturer: Broadcom Corp
[ 9903.467708] usb 1-1.4: SerialNumber: 7CE9D3E9491F
[ 9903.475850] Bluetooth: hci0: BCM: chip id 63
[ 9903.491894] Bluetooth: hci0: BCM20702A
[ 9903.492904] Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000
[ 9906.994358] Bluetooth: hci0 command 0x1001 tx timeout
[ 9914.990488] Bluetooth: hci0: BCM: Reading local version info failed (-110)
[ 9916.994516] Bluetooth: hci0 command 0x0c03 tx timeout
[ 9924.990576] Bluetooth: hci0: BCM: Reset failed (-110)

Seth Forshee (sforshee) on 2017-03-15
Changed in linux (Ubuntu Zesty):
importance: Undecided → Medium
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (17.1 KiB)

This bug was fixed in the package linux - 4.10.0-14.16

---------------
linux (4.10.0-14.16) zesty; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1673805

  * msleep() bug causes Nuvoton I2C TPM device driver delays (LP: #1667567)
    - tpm: msleep() delays - replace with usleep_range() in i2c nuvoton driver
    - SAUCE: tpm: add sleep only for retry in i2c_nuvoton_write_status()

  * C++ demangling support missing from perf (LP: #1396654)
    - [Config] added binutils-dev to Build-deps

  * dm-queue-length module is not included in installer/initramfs (LP: #1673350)
    - [Config] d-i: Also add dm-queue-length to multipath modules

  * move aufs.ko from -extra to linux-image package (LP: #1673498)
    - [config] aufs.ko moved to linux-image package

  * Using an NVMe drive causes huge power drain (LP: #1664602)
    - nvme: Add a quirk mechanism that uses identify_ctrl
    - nvme: Enable autonomous power state transitions

  * Broadcom bluetooth modules sometimes fail to initialize (LP: #1483101)
    - Bluetooth: btbcm: Add a delay for module reset

  * Need support of Broadcom bluetooth device [413c:8143] (LP: #1166113)
    - Bluetooth: btusb: Add support for 413c:8143

  * Zesty update to v4.10.3 stable release (LP: #1673118)
    - serial: 8250_pci: Add MKS Tenta SCOM-0800 and SCOM-0801 cards
    - KVM: s390: Disable dirty log retrieval for UCONTROL guests
    - KVM: VMX: use correct vmcs_read/write for guest segment selector/base
    - Bluetooth: Add another AR3012 04ca:3018 device
    - phy: qcom-ufs: Don't kfree devres resource
    - phy: qcom-ufs: Fix misplaced jump label
    - s390/qdio: clear DSCI prior to scanning multiple input queues
    - s390/dcssblk: fix device size calculation in dcssblk_direct_access()
    - s390/kdump: Use "LINUX" ELF note name instead of "CORE"
    - s390/chsc: Add exception handler for CHSC instruction
    - s390: TASK_SIZE for kernel threads
    - s390/topology: correct allocation of topology information
    - s390: make setup_randomness work
    - s390: use correct input data address for setup_randomness
    - net: mvpp2: fix DMA address calculation in mvpp2_txq_inc_put()
    - cxl: Prevent read/write to AFU config space while AFU not configured
    - cxl: fix nested locking hang during EEH hotplug
    - brcmfmac: fix incorrect event channel deduction
    - mnt: Tuck mounts under others instead of creating shadow/side mounts.
    - IB/ipoib: Fix deadlock between rmmod and set_mode
    - IB/IPoIB: Add destination address when re-queue packet
    - IB/mlx5: Fix out-of-bound access
    - IB/SRP: Avoid using IB_MR_TYPE_SG_GAPS
    - IB/srp: Avoid that duplicate responses trigger a kernel bug
    - IB/srp: Fix race conditions related to task management
    - Btrfs: fix data loss after truncate when using the no-holes feature
    - orangefs: Use RCU for destroy_inode
    - memory/atmel-ebi: Fix ns <-> cycles conversions
    - tracing: Fix return value check in trace_benchmark_reg()
    - ktest: Fix child exit code processing
    - ceph: remove req from unsafe list when unregistering it
    - target: Fix NULL dereference during LUN lookup + active I/O shutdown
    - drivers/pci/hotplug: Han...

Changed in linux (Ubuntu Zesty):
status: Fix Committed → Fix Released

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
tags: added: verification-needed-yakkety

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-yakkety' to 'verification-done-yakkety'. If the problem still exists, change the tag 'verification-needed-yakkety' to 'verification-failed-yakkety'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Jesse Sung (wenchien) on 2017-04-17
tags: added: verification-done-xenial verification-done-yakkety
removed: verification-needed-xenial verification-needed-yakkety
Changed in hwe-next:
status: In Progress → Fix Released
Jason Sommerfeld (jason108) wrote :

The error message appears again in Ubuntu 18.04, kernel 4.15.0-22-generic, with module 0a5c:216c. I already posted this on
https://askubuntu.com/questions/1043171/broadcom-bcm43242a0-bluetooth-adapter-not-detected-in-ubuntu-18-04
Is it possible that the fix got lost in a newer kernel version?

Jesse Sung (wenchien) wrote :

@jason108:

This patch has been landed in upstream since 4.11, so, yes, we have it in bionic.

From the log in askubuntu, there's a line:
"[ 31.964068] Bluetooth: hci0: BCM: Patch command 0a0a failed (-110)"
This indicates that something goes wrong when the driver is sending firmware to the module. It is different from the bug we have here.

Jason Sommerfeld (jason108) wrote :

@wenchien: Ok, thank you for the info.

Kai-Heng Feng (kaihengfeng) wrote :

Well, there are some refactoring for btbcm.c in latest mainline kernel, so might worth a try.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers