MFG:Firestone, Linux Error message: SYSPARAM: Opal sysparam node not found

Bug #1478513 reported by bugproxy on 2015-07-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Vivid
Medium
Unassigned

Bug Description

SRU Justification

[Impact]

When using Firestone POWER8 hardware, the following message gets printed to the kernel log:
SYSPARAM: Opal sysparam node not found

[Test Case]
1) Boot affected hardware.
2) dmesg | grep 'Opal sysparam node not found'

[Fix]
$ git describe --contains 38c0488770983b2654f075540cc1fc71f55b6df5
v4.2-rc1~135^2~144

--

== Comment: #0 - Application Cdeadmin <email address hidden> - 2015-07-22 11:35:05 ==

== Comment: #1 - Application Cdeadmin <email address hidden> - 2015-07-22 11:35:06 ==
==== State: Open by: knodelk on 22 July 2015 10:25:15 ====

The following message is being posted to the linux message log on Firestone systems, and we need to know what action to take.
 - is this caused by a code bug that needs to be fixed?
 - does the message indicate a real hardware problem?
   or can the message be ignore?

Until we here otherwise, manufacturing is ignoring this message

dmesg --level=alert,crit,err

SYSPARAM: Opal sysparam node not found

system is running with the following code levels:
       ver 1.5.4.3 - OS, HTX, Firmware and Machine details

                           OS: GNU/Linux
                   OS Version: Ubuntu 14.04.2 LTS \n \l
               Kernel Version: 3.16.0-30-generic
                  HTX Version: htxubuntu-343

== Comment: #2 - MAMATHA INAMDAR <email address hidden> - 2015-07-27 06:18:20 ==
"SYSPARAM: Opal sysparam node not found" we get this warning on firestone system for every boot because For OpenPower BMC machines we do not place any sysparams in the device tree.

This issue is addressed in the attached patch and patch is available in upstream.
We need to backport following patch in ubuntu to address this issue.
Commit ID:38c0488770983b2654f075540cc1fc71f55b6df5
0001-powerpc-powernv-Silence-SYSPARAM-warning-on-boot.patch

== Comment: #3 - MAMATHA INAMDAR <email address hidden> - 2015-07-27 06:25:34 ==
Please find upstream commit ID link

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=38c0488770983b2654f075540cc1fc71f55b6df5

Default Comment by Bridge

tags: added: architecture-ppc64 bugnameltc-127910 severity-high targetmilestone-inin---

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1478513/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)
Chris J Arges (arges) on 2015-07-29
description: updated
Changed in linux (Ubuntu Vivid):
assignee: nobody → Chris J Arges (arges)
Changed in linux (Ubuntu):
assignee: nobody → Chris J Arges (arges)
importance: Undecided → Medium
Changed in linux (Ubuntu Vivid):
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Vivid):
status: New → In Progress
Brad Figg (brad-figg) on 2015-07-30
Changed in linux (Ubuntu Vivid):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-vivid' to 'verification-done-vivid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-vivid
Launchpad Janitor (janitor) wrote :
Download full text (14.6 KiB)

This bug was fixed in the package linux - 3.19.0-28.30

---------------
linux (3.19.0-28.30) vivid; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1490606

  [ Gary Wang ]

  * SAUCE: i915_bpo: drm/i915: set CDCLK if DPLL0 enabled during resuming
    from S3
    - LP: #1490035

  [ Timo Aaltonen ]

  * Revert "SAUCE: i915_bpo: drm/i915/skl: DDI-E and DDI-A shares 4 lanes."
    - LP: #1490038

linux (3.19.0-27.29) vivid; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1485113

  [ Adam Lee ]

  * SAUCE: serial: 8250_pci: Add support for Pericom PI7C9X795[1248]
    - LP: #1480142

  [ Arun Siluvery ]

  * SAUCE: i915_bpo: drm/i915/gen8: Add infrastructure to initialize WA
    batch buffers
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915/gen8: Re-order init pipe_control in lrc mode
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915/gen8: Add WaDisableCtxRestoreArbitration
    workaround
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915/gen8: Add
    WaFlushCoherentL3CacheLinesAtContextSwitch workaround
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915: Bail out early if WA batch is not available
    for given Gen
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915/gen8: Add WaClearSlmSpaceAtContextSwitch
    workaround
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915: Update
    WaFlushCoherentL3CacheLinesAtContextSwitch
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915: Enable WA batch buffers for Gen9
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915/gen9: Add WaDisableCtxRestoreArbitration
    workaround
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915: Update wa_ctx_emit() macro as per kernel
    coding guidelines
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915/gen9: Add
    WaFlushCoherentL3CacheLinesAtContextSwitch workaround
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915/gen9: Add
    WaSetDisablePixMaskCammingAndRhwoInCommonSliceChicken
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915:skl: Add WaEnableGapsTsvCreditFix
    - LP: #1484486

  [ Chris Wilson ]

  * SAUCE: i915_bpo: drm/i915: Use two 32bit reads for select 64bit
    REG_READ ioctls
    - LP: #1484482
  * SAUCE: i915_bpo: drm/i915: Replace WARN inside I915_READ64_2x32 with
    retry loop
    - LP: #1484482
  * SAUCE: i915_bpo: drm/i915: Mark PIN_USER binding as GLOBAL_BIND without
    the aliasing ppgtt
    - LP: #1484482
  * SAUCE: i915_bpo: drm/i915: Declare the swizzling unknown for L-shaped
    configurations
    - LP: #1484482

  [ Damien Lespiau ]

  * SAUCE: i915_bpo: drm/i915/skl: Don't expose the top most plane on gen9
    display
    - LP: #1484486

  [ Daniel Vetter ]

  * SAUCE: i915_bpo: drm/i915: Fixup dp mst encoder selection
    - LP: #1484482

  [ David Weinehall ]

  * SAUCE: i915_bpo: drm/i915: Allow parsing of variable size child device
    entries from VBT
  * SAUCE: i915_bpo: drm/i915: Allow parsing of variable size child device
    entries from VBT, addendum v2
    - LP: #1484482

  [ Jani Nikula ]

  * SAUCE: i915_bpo: drm/i915/skl: WaIgnoreDDIAStrap is forever, always
    init DDI A
    - LP: #1484486
  * SAUCE: i915_bpo: drm/i915: reduce indent in i9xx_hpd_irq_handler
    - LP: #1484531
  * SAUCE: i915_bpo: drm/i91...

Changed in linux (Ubuntu Vivid):
status: Fix Committed → Fix Released
bugproxy (bugproxy) wrote :

Default Comment by Bridge

tags: added: targetmilestone-inin14043
removed: targetmilestone-inin---

------- Comment From <email address hidden> 2015-09-30 20:45 EDT-------
== Comment: #1 - Application Cdeadmin <email address hidden> - 2015-07-22 11:35:06 ====== State: Working by: lieder on 30 September 2015 15:40:18 ====

#=#=# 2015-09-30 15:40:05 (CDT) #=#=#
New Fix_Potential = [P810.00D]
#=#=#=#=#=#=#=#=#=#=#=#=#=#=#=#=#=#=#

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2015-09-30 22:24 EDT-------
I don't know why there's a Fix Potential of P810.00D, this is an Ubuntu kernel issue and has nothing to do with any release anywhere named P810.00.

this is probably yet another example of the bug bridge breaking in stupid ways.

Sorry Ubuntu peeps - I'll attempt to poke someone internally.

bugproxy (bugproxy) on 2015-10-14
tags: added: verification-done-vivid
removed: verification-needed-vivid
Chris J Arges (arges) on 2016-09-21
Changed in linux (Ubuntu):
assignee: Chris J Arges (arges) → nobody
Changed in linux (Ubuntu Vivid):
assignee: Chris J Arges (arges) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers