[Acer Aspire 5250] Black screen after upgrade to 3.19.0-22-generic

Bug #1472794 reported by zub on 2015-07-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

After upgrade to linux-image-3.19.0-22-generic on Acer Aspire 5250/HMA51-BZ there is nothing displayed after Grub. Playing with (Ctrl-)Alt-F1, F2, ..., F7, F8... doesn't have any visible effect - so neither VT nor X is visible. Removing "quiet splash" from kernel arguments also doesn't show anything after the message from grub that it's loading the kernel.

The laptop seems to boot normally, I can hear the lightdm sound that it's ready, but I cannot see anything on the display. I can log in remotely. The backlight is on, so it's not a cause of no backlight. (I checked this by poking around /sys/class/backlight and I see it's set at full brightness.)

If I boot linux-image-3.19.0-21-generic everything works OK.

I don't see anything obvious when I look at the diff of dmesg between 3.19.0-21 and 3.19.0.22, but if it's useful I can attach dmesg from 3.19.0-21.

According to lspci this is the GPU:
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6310]

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-3.19.0-22-generic 3.19.0-22.22
ProcVersionSignature: Ubuntu 3.19.0-22.22-generic 3.19.8-ckt1
Uname: Linux 3.19.0-22-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/controlC0', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Date: Wed Jul 8 22:49:55 2015
HibernationDevice: RESUME=UUID=2552e9df-add8-4cc9-abe7-e75f869c1d08
InstallationDate: Installed on 2013-02-14 (873 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
Lsusb:
 Bus 002 Device 002: ID 064e:d250 Suyin Corp.
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Acer Aspire 5250
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-22-generic root=UUID=84cf2e2d-2e23-4ced-a3ed-94d793f6cefd ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-22-generic N/A
 linux-backports-modules-3.19.0-22-generic N/A
 linux-firmware 1.143.1
SourcePackage: linux
UpgradeStatus: Upgraded to vivid on 2015-07-02 (5 days ago)
dmi.bios.date: 11/17/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: HMA51-BZ
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.06
dmi.modalias: dmi:bvnAcer:bvrV1.06:bd11/17/2011:svnAcer:pnAspire5250:pvrV1.06:rvnAcer:rnHMA51-BZ:rvrBaseBoardVersion:cvnAcer:ct10:cvrV1.06:
dmi.product.name: Aspire 5250
dmi.product.version: V1.06
dmi.sys.vendor: Acer

zub (zub-linux) wrote :
zub (zub-linux) wrote :

I can boot OK when I add "nomodeset" kernel argument, so it's KMS.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: bios-outdated-1.08
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
zub (zub-linux) wrote :

Thank you for the advice, Christopher.

I updated the BIOS to v1.08. When I run "sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date" I get:

V1.08
09/26/2012

Unfortunately the issue still persists and I don't observe any change. When I power up the laptop:

1) the acer splash screen shows up
2) grub shows up (I disabled GRUB_HIDDEN_TIMEOUT in /etc/default/grub, so grub always shows up)
3) after grub there is nothing, only purplish screen that eventually turns black
4) I can hear lightdm play the "drum" sound it plays when it's ready for log in - but I see nothing on the display; I can log in remotely via ssh and apart from the display the laptop seems to work OK

If I remove "quiet splash $vt_handoff" from the kernel command line I can see kernel messages for some time, but eventually the display turns off and then stays black.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-da-key regression-update

zub, could you please test the latest upstream kernel available from the very top line at the top of the page (the release names are irrelevant for testing, and please do not test the daily folder) following https://wiki.ubuntu.com/Kernel/MainlineBuilds ? It will allow additional upstream developers to examine the issue.

If the test did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, Y, and Z are numbers corresponding to the kernel version.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

tags: added: latest-bios-1.08
removed: bios-outdated-1.08
Changed in linux (Ubuntu):
importance: Low → Medium
status: Confirmed → Incomplete
zub (zub-linux) wrote :

I tested with 4.2.0-040200rc4-generic #201507271251 (linux-image-4.2.0-040200rc4-generic_4.2.0-040200rc4.201507271251_amd64.deb) and the issue is fixed. Display works again.

I could dig into this further to see which version fixed it, but I assume this is not important as the fix will eventually reach official Ubuntu kernel. If so, this bug can be closed.

tags: added: kernel-fixed-upstream kernel-fixed-upstream-4.2.0-rc4
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

zub, the next step is to fully reverse commit bisect from kernel 3.19 to 4.2-rc4 in order to identify the last bad commit, followed immediately by the first good one. Once this commit has been identified, then it may be reviewed as a candidate for backporting into your release. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: kernel-fixed-upstream-4.2-rc4
removed: kernel-fixed-upstream-4.2.0-rc4
tags: added: needs-reverse-bisect
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
zub (zub-linux) wrote :

I did the full reverse commit bisect and found out the commit that fixes the issue is:

commit 0434848e444b31ea862743b720585c127b8114c2
Author: Adam Lee <email address hidden>
Date: Wed Jan 28 15:30:27 2015 -0500

    Bluetooth: ath3k: workaround the compatibility issue with xHCI controller

I have no idea why this BT driver change affects backlight, but I checked twice, and I can confirm that with commit 9786567e45eee30e68af97926de96905e765e48d the display is indeed black (i.e. the issue reported in this ticket manifests) and with 0434848e444b31ea862743b720585c127b8114c2 the display works again.

I looked into BIOS Setup to see if I could perhaps disable bluetooth there to see if it changes anything, but there it no option to disable bluetooth.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: reverse-bisect-done
removed: needs-reverse-bisect
Changed in linux (Ubuntu):
status: Confirmed → Triaged
zub (zub-linux) wrote :

Just to clarify my last comment: I mention "backlight", but it's not backlight, as described before. It's simply black display, but backlight is on.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers