1385:4251 Netgear WG111T not auto-sensed

Bug #147203 reported by Nicolas Khadivi on 2007-09-30
26
Affects Status Importance Assigned to Milestone
MadWifi
Invalid
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

My WG111T works fine on 7.04, recognized right after installation. However, under 7.10, it doesn't work directly, and seems not to be recognized as a WiFi USB Key

shclim (shclim) wrote :

I've had exactly the same problem using Ubuntu 7.10 i386.

I also tried using ndiswrapper (from the ubuntu CD) and the windows drivers but this didn't work either.

Yup, I tried using ndiswrapper on the final version but it still doesn't
work, and the installation is quite complicated compared to the other USB
dongles as the WG111T needs 2 drivers.
I finally abandonned and decided to use Ethernet ;)

2007/10/29, Scott Hosking <email address hidden>:
>
> I've had exactly the same problem using Ubuntu 7.10 i386.
>
> I also tried using ndiswrapper (from the ubuntu CD) and the windows
> drivers but this didn't work either.
>
> --
> WG111T not working on 7.10 but functional on 7.04
> https://bugs.launchpad.net/bugs/147203
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Iknow this is cliche to say, but have you had any luck with this under Hardy Heron?

Craig Maloney (craig-decafbad) wrote :

Or have you tried it with 8.10?

Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Is this still reproducable? If yes,
please run the following command which will attach necessary information:

apport-collect 147203
if you are using Karmic Koala (9.10) or newer, or

apport-collect -p linux-image-`uname -r` 147203
if you are using Jaunty Jackalope (9.04).

Bear in mind that you may need to install the python-launchpadlib package from the universe repository with 'sudo apt-get install python-launchpadlib'. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report.

If you are using an older release or cannot use apport please at least add the following information (pay attention to lspci's additional options):

First run the following commands:
1) uname -a > uname-a.log
2) dmesg > dmesg.log
3) sudo lspci -vvnn > lspci-vvnn.log
4) cat /proc/version_signature > version.log
then attach the files separately to the bug report (not pasted into comments or tar/zip-ed).

For your reference, the full description of procedures for kernel related bug reports is available at https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies. Thanks in advance!

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

shclim (shclim) wrote :
shclim (shclim) wrote :
shclim (shclim) wrote :
shclim (shclim) wrote :

Here are the files as requested.

Sorry for the delay. I only have access to this PC + wifi card once every few months or so.

If I can be of any further help please let me know.

shclim (shclim) wrote :

I've just tried the Ubuntu 10.10 beta (i386) live CD and the WiFi dongle still isn't showing up in the wifi panel applet

summary: - WG111T not working on Hardy
+ Netgear WG111T not auto-sensed

Scott Hosking, thank you for responding quickly with testing results of the Maverick Meerkat Live CD for the Netgear WG111T http://kb.netgear.com/app/products/model/a_id/2559 To better assist the Ubuntu Community, may we please have an attachment of the Terminal output with the USB adapter attached:

sudo lsusb -v
lsusb

and with it unattached:

lsusb

Thank you for your efforts in helping make Ubuntu better for everyone.

Changed in linux (Ubuntu):
status: Incomplete → New
shclim (shclim) wrote :

Here is the output for "sudo lsusb -v"

shclim (shclim) wrote :

... and lsusb

shclim (shclim) wrote :

... and lusb without the usb dongle unattached.

Scott Hosking thank you for rapidly responding to the information request. The lsusb with & without the Netgear USB Adapter plugged provided, indicates the next step to focus on is:
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 1385:4251 Netgear, Inc WG111T (no firmware)

Confirming based on this.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in madwifi:
status: Unknown → New

Update on this issue, openBSD has a driver for the WG111T USB Adapter at: http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/usb/if_uath.c?rev=1.10&content-type=text/x-cvsweb-markup

Nicolas Khadivi, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

summary: - Netgear WG111T not auto-sensed
+ 1385:4251 Netgear WG111T not auto-sensed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
dino99 (9d9) wrote :

unsupported project since a while

Changed in madwifi:
importance: Unknown → Undecided
status: New → Invalid
dino99 (9d9) wrote :

closing that old report, as it has not got recent comment.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.