Acer Aspire 5315: Fan turns off when loading linux, resulting in system overheat and emergency shutdown

Bug #1471530 reported by Danny Edel on 2015-07-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

First off: I'm running Ubuntu 14.04.2 LTS "Trusty Tahr", yet ubuntu-bug linux started the bug report against linux-lts-utopic. I hope it knows what it's doing : )

uname -a says "Linux aspire5315 3.16.0-41-generic #57~14.04.1-Ubuntu SMP Thu Jun 18 18:01:13 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux".

Now to the problem.
The fan on this particular Laptop seems to be either controlled by BIOS or - after the operating system signals somehow(tm) that it's capable of doing so - completely by software. There is (I assume it's implemented in the mainboard firmware) an emergency-power-off once the temperature exceeds a certain threshold, that's what causing the sudden poweroff after a while.

Without any modifications, if you power it up (assuming its already warm from a previous session), the fan works correctly. If you load BIOS or GRUB, no problems. I could confirm temperature-dependent control works by loading a memtest86 and letting it run for a few hours; Fan speed kept going up and down, machine did not crash.

Once you load a linux kernel (LiveCD exhibits the same behaviour), the fan stops completely and the system starts heating up. I was able to get through a complete ubuntu installation before poweroff by not using an internet connection and clicking defaults as fast as possible, starting with the machine cold.

After I had ubuntu installed, thanks to much help at bug report #728733 I have made the following discoveries.

(1) Booting linux with "acpi=off" results in a kernel panic (I had to replace "quiet splash" with "verbose" to see that), but the fan stays on.
(2) Booting linux with "acpi=off noapic" or "acpi=off nolapic" results in the fan working correctly, but the wifi card doen't work.
(3) Booting linux normally, if you monitor /sys/class/thermal/thermal_zone0/temp it stays at 40000 (40°C) even if lm-sensors' coretemp tells me that the processor is quite beyond that. [note: It is possible that the fan is just so quiet at the 40°C setting that I'm thinking its off]. Thermald also seems to depend on this temperature reading and therefore does not throttle the CPU.
(4) Sending the machine to standby and waking it up again results in the thermal_zone0/temp getting updated regularly (it seems to follow coretemp with a few seconds lag) and the fan turning faster and slower. In this state, the system is perfectly usable.

What I would like is to have the system in state 4 (fan turning and adjusting to temperature) without requiring human intervention, either by avoiding the fan stopping in the first place (preferred) or by re-starting it automated sometime in the boot process.

> We also need:
1) The release of Ubuntu you are using
'lsb_release -rd' gives
Description: Ubuntu 14.04.2 LTS
Release: 14.04

2) The version of the package you are using
'apt-cache policy linux-image-$(uname -r)' says I'm running
3.16.0-41.57~14.04.1

3) What you expected to happen
System fan stays on after grub->linux handoff (or only stays off for a brief time period and comes back up automatically)

4) What happened instead
System fan stays off until I suspend and wakeup the machine, possibly resulting in heat emergency poweroff if I am too slow or forget to do it

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.16.0-41-generic 3.16.0-41.57~14.04.1
ProcVersionSignature: Ubuntu 3.16.0-41.57~14.04.1-generic 3.16.7-ckt11
Uname: Linux 3.16.0-41-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.11
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Jul 5 12:16:55 2015
InstallationDate: Installed on 2001-01-02 (5296 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64+mac (20150218.1)
SourcePackage: linux-lts-utopic
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.14.1-0ubuntu3.11
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dannyedel 1385 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2001-01-02 (5297 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64+mac (20150218.1)
MachineType: Acer Aspire 5315
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-41-generic root=UUID=36a742e5-ee21-43a3-b931-ce78a8734631 ro verbose
ProcVersionSignature: Ubuntu 3.16.0-41.57~14.04.1-generic 3.16.7-ckt11
RelatedPackageVersions:
 linux-restricted-modules-3.16.0-41-generic N/A
 linux-backports-modules-3.16.0-41-generic N/A
 linux-firmware 1.127.12
Tags: trusty
Uname: Linux 3.16.0-41-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/27/2007
dmi.bios.vendor: Acer
dmi.bios.version: V1.18
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Acadia
dmi.board.vendor: Acer
dmi.board.version: V1.18
dmi.chassis.type: 1
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.18
dmi.modalias: dmi:bvnAcer:bvrV1.18:bd09/27/2007:svnAcer:pnAspire5315:pvrV1.18:rvnAcer:rnAcadia:rvrV1.18:cvnAcer:ct1:cvrV1.18:
dmi.product.name: Aspire 5315
dmi.product.version: V1.18
dmi.sys.vendor: Acer

Danny Edel (dannyedel) wrote :

Danny Edel, thank you for reporting this and helping make Ubuntu better.

Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1471530

affects: linux-lts-utopic (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Danny Edel (dannyedel) wrote :

Since the machine was cold, I was able to get the apport-collect run before the wakeup. For completness, here's the output of dmesg after the suspend/wakeup cycle:

Danny Edel, as per http://us.acer.com/ac/en/US/content/drivers an update to your computer's buggy and outdated BIOS is available (1.45). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful. As well, you don't have to create a new bug report.

Once the BIOS is updated, and the information above is provided, then please mark this report Status Confirmed.

Thank you for your understanding.

tags: added: bios-outdated-1.45
Danny Edel (dannyedel) wrote :

Christopher, thank you for that information and the direct link, I've been able to download the BIOS file.

Unfortunately, it's a windows-only download. I've extracted it with archive manager, and the program inside is called "InsydeFlash.exe". Going by the wiki article you linked, it seems the only option for me is to use a Windows 7 repair disc, since I don't have a windows 8 system, the BIOS update is not dos based, and flashrom's wiki says it won't work on a laptop.

Just one question: Do you know if I can use a windows-7 repair disc created on another computer to do the BIOS update? Because this laptop is ubuntu-only, and right now my windows desktop PC does not have a CD burner (I would get one for it if that could help me run the BIOS update). The system-restore thing doesn't want to create an ISO, otherwise I'd have moved it to the ubuntu laptop and burned it there already.

Danny Edel (dannyedel) wrote :

Hello Christopher,

Good news first: Updating the BIOS to v1.45 actually *fixed the fan issue.* It still stops briefly during kernel load, but resumes rotation within a second. If I run stress, the temperature sensor acpitz-virtual-0 updates within a few seconds to whatever coretemp-0 says, rounded to 10 degrees and the fan adjusts its speed. Before and after sleep/wakeup.

A big THANK YOU for taking the time to help me on this.

Now to the bad news: Updating the BIOS was no easy task at all and did not work as specified on the help page. (That's why my answer took so long)

But maybe some of the things I discovered can be added to the BIOSupdate help page you linked, so other users dont't have to try and fail on the same things again.

Note: This may be specific to the "InsydeFlash" system, but googling it seems to suggest it is in use for many different computers.

* A windows 7 system repair disc created on one computer is not bound to its hardware (after installing a DVD Burner in my desktop computer, the generated disc booted on the laptop)

* A windows 7 64bit system repair disc *does not* run 32-bit applications. (InsydeFlash is a 32bit application, you get an error about a required subsystem not being available).
Note that you cannot choose whether to create 32bit or 64bit discs. A 64bit installation will always generate 64bit discs.

* After acquiring a windows 7 32bit installation and generating a rescue disc from it, InsydeFlash still did not start. It was missing oledlg.dll (and probably others, I'm assuming it would tell me which one it tries to load next if I found out how to give oledlg it to it).

* Copying oledlg.dll from the windows\system32 directory onto the same directory as the bios update file did *not work*, it still complains about not finding the dll.

* Talking to a professional windows system administrator, I was told they often use the Boot-CD from www.hirensbootcd.org, which contains a minimal windows xp. Using this boot cd's XP, I was *finally* able to run the BIOS update file and the fan works now.

So maybe you want to add this boot cd to the links on the BIOSupdate page, to help future users who are running into similar problems.

Danny Edel, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1471530/comments/22 regarding this being fixed with a BIOS update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers