linux-image-xen on amd64 not detected by update-grub.

Bug #147014 reported by Steven Wagner on 2007-09-29
16
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Ubuntu Xen Team

Bug Description

Binary package hint: linux-image-xen

Clean install of gutsy server beta amd64.

$ sudo apt-get install linux-image-xen

output..
Fetched 5929kB in 1m30s (65.3kB/s)
Selecting previously deselected package linux-image-2.6.22-12-xen.
(Reading database ... 15265 files and directories currently installed.)
Unpacking linux-image-2.6.22-12-xen (from .../linux-image-2.6.22-12-xen_2.6.22-12.39_amd64.deb) ...
Done.
Selecting previously deselected package linux-ubuntu-modules-2.6.22-12-xen.
Unpacking linux-ubuntu-modules-2.6.22-12-xen (from .../linux-ubuntu-modules-2.6.22-12-xen_2.6.22-12.32_amd64.deb) ...
Selecting previously deselected package linux-image-xen.
Unpacking linux-image-xen (from .../linux-image-xen_2.6.22.12.15_amd64.deb) ...
Setting up linux-image-2.6.22-12-xen (2.6.22-12.39) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.22-12-xen
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /vmlinuz-2.6.22-12-server
Found kernel: /memtest86+.bin
Updating /boot/grub/menu.lst ... done

Setting up linux-ubuntu-modules-2.6.22-12-xen (2.6.22-12.32) ...
update-initramfs: Generating /boot/initrd.img-2.6.22-12-xen

Setting up linux-image-xen (2.6.22.12.15) ...
$

Next, when I look in my menu.lst file I see there is no xen kernel configured.

ls /boot shows that vmlinuz-2.6.22-12-xen does in fact exist.

If I manually edit my menu.lst and try to boot with the xen kernel, grub reports Error 13: Invalid or unsupported executable format.

Tags: xen Edit Tag help
Changed in linux-meta:
assignee: nobody → ubuntu-xen
Steven Wagner (stevenwagner) wrote :

This is related to 133986 and possibly 146986

Steven Wagner (stevenwagner) wrote :

This was being caused by linux-image-xen not really being usable without the hypervisor installed. Perhaps a dependency should be set here. Once the ubuntu-xen-server package exists for amd64, that will also help alleviate the issue.

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
David T (ubuntuwiki-datmail) wrote :

I think I ran into this myself.

Xen Server 5.5
Installing Ubuntu 8.04 TLS into XEN using these instructions:
http://community.citrix.com/blogs/citrite/anilma/2008/07/02/Installing+Ubuntu+on+XenServer

In the section regarding "You now need to workaround a bug in grub. Due to the switch in recent versions of Linux to work with the hypervisor-independent paravirt_ops interface, update-grub doesn't update the grub configuration with your newly installed Xen kernel. :"

I've done the "sudo apt-get install linux-image-xen"

and it installed vmlinuz-2.6.24-24-xen but didn't put it in the grub list.

When I manually modify menu.lst to use the xen kernel for booting it gives the Error 13.

Ask if you need further info for troubleshooting.

David T (ubuntuwiki-datmail) wrote :

Xen Server 5.5 slight modification: Installing Ubuntu 8.04 TLS *amd64*

Not sure if this issue is specific to amd64 build or not, haven't tried the x86 ubuntu

tags: added: xen

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in linux (Ubuntu):
status: New → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers