[MacBook8,1] TouchPad doesn't work

Bug #1462761 reported by reroute on 2015-06-07
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Touchpad doesn't work.

---
ApportVersion: 2.17.3-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1889 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1889 F.... pulseaudio
CasperVersion: 1.360
CurrentDesktop: Unity
DistroRelease: Ubuntu 15.10
LiveMediaBuild: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150603)
MachineType: Apple Inc. MacBook8,1
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash ---
ProcVersionSignature: Ubuntu 3.19.0-20.20-generic 3.19.8
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-20-generic N/A
 linux-backports-modules-3.19.0-20-generic N/A
 linux-firmware 1.144
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: wily
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
Uname: Linux 3.19.0-20-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 03/24/2015
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB81.88Z.0164.B02.1503241252
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-BE0E8AC46FE800CC
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBook8,1
dmi.chassis.asset.tag: Chassis Board Asset Tag#
dmi.chassis.type: 9
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-BE0E8AC46FE800CC
dmi.modalias: dmi:bvnAppleInc.:bvrMB81.88Z.0164.B02.1503241252:bd03/24/2015:svnAppleInc.:pnMacBook8,1:pvr1.0:rvnAppleInc.:rnMac-BE0E8AC46FE800CC:rvrMacBook8,1:cvnAppleInc.:ct9:cvrMac-BE0E8AC46FE800CC:
dmi.product.name: MacBook8,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1462761

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
reroute (samplesaron) on 2015-06-07
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
tags: removed: keyboard macbook trackpad
reroute (samplesaron) wrote :

Sure, this issue is reproducible with 14.04 LTS, 15.04, 15.10.
When system is booted, keyboard and trackpad don't work at all.

reroute, are you able to at least plug in an external keyboard and mouse and use that as a WORKAROUND?

tags: added: trusty vivid wily
reroute (samplesaron) wrote :

Yes, I can, but it makes work with this laptop an absolute hell due to small screen size.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

reroute, as multiple, disparate issues are referenced, this report will focus on the first one reported regarding the touchpad.

For the keyboard and wireless issues, please file one report per issue via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to both.

Regarding this report, could you please test the latest upstream kernel available from the very top line at the top of the page (the release names are irrelevant for testing, and please do not test the daily folder) following https://wiki.ubuntu.com/Kernel/MainlineBuilds ? It will allow additional upstream developers to examine the issue.

If the test did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where XY and Z are numbers corresponding to the kernel version.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Low → High
summary: - Macbook Early 2015 TouchPad+Keyboard dont work at all
+ [MacBook8,1] TouchPad doesn't work
description: updated
tags: added: latest-bios
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Oliver Arnold (derarnold) wrote :

Hi Guys.

This is quite a serious bug. I have installed 15.10Beta1 and still no keyboard no mouse ... basically completely useless :( I updated to kernel 4.2 from the ubuntu kernel team. same behavior.

I saw comments, that is because of USB-c ?

How can I help to debug this? You guys need new logfiles?

Tanks derarnold

Changed in linux (Ubuntu):
status: Expired → Confirmed
Oliver Arnold (derarnold) wrote :

Hi Guys.

To solve this issue upstream, I have found and added this information to an existing kernel.org bugreport. This can be found here:

https://bugzilla.kernel.org/show_bug.cgi?id=99891

Regards

Oliver

Oliver Arnold, it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Oliver Arnold (derarnold) wrote :

Hi Christopher.

I would and I tried. Unfortunately the tool said, that I did not use a supported kernel (4.2) and died on me :(

Is there anything I can do to prevent this from happening?

Oliver

Oliver Arnold, you need to use a kernel provided by the Ubuntu repositories (not PPAs or mainline/upstream).

Nell Hardcastle (nell.h) wrote :

I filed #1520874 and #1520875 for the other issues with the MacBook 8,1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.