System freeze when using LibreOffice Writer

Bug #1453812 reported by vmagnin on 2015-05-11
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

LibreOffice Writer is freezing the system after a few minutes (Ubuntu 15.04, libreoffice-writer 4.4.2-0ubuntu1): the only possible action is moving the mouse pointer on the screen. Impossible to connect to a tty session to kill Xorg. A physical reboot is necessary. Note that I used LibreOffice Calc without problem.

The problem has been encountered also under Fedora 21:
http://forums.fedora-fr.org/viewtopic.php?id=63428

WORKAROUND: Use nvidia-304-updates or 340.76.

---
.tmp.unity.support.test.0:

ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CasperVersion: 1.360
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
DistUpgraded: Fresh install
DistroCodename: vivid
DistroRelease: Ubuntu 15.04
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation G96GL [Quadro FX 580] [10de:0659] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:063a]
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: Hewlett-Packard HP Z400 Workstation
Package: xorg 1:7.7+7ubuntu4
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash --- debian-installer/language=fr keyboard-configuration/layoutcode?=fr keyboard-configuration/variantcode?=oss
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Tags: vivid ubuntu compiz-0.9
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
Uname: Linux 3.19.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 04/06/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786G3 v03.07
dmi.board.asset.tag: CZC0195Y06
dmi.board.name: 0B4Ch
dmi.board.vendor: Hewlett-Packard
dmi.board.version: D
dmi.chassis.asset.tag: CZC0195Y06
dmi.chassis.type: 6
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786G3v03.07:bd04/06/2010:svnHewlett-Packard:pnHPZ400Workstation:pvr:rvnHewlett-Packard:rn0B4Ch:rvrD:cvnHewlett-Packard:ct6:cvr:
dmi.product.name: HP Z400 Workstation
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12.1+15.04.20150410.1-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.60-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.5.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.5.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.17.1-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2build1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2build1
xserver.bootTime: Wed May 20 08:19:58 2015
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.17.1-0ubuntu3

vmagnin (vincent-magnin) on 2015-05-11
affects: network-manager (Ubuntu) → libreoffice (Ubuntu)
affects: libreoffice (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
vmagnin (vincent-magnin) wrote :

OK.
I reinstalled the "nouveau" driver and reproduced the bug. I was obliged to reboot the system because everything is frozen except the mouse cursor: no access to any terminal.

Then I typed in a terminal:
$ sudo apt-get install xdiagnose
$ sudo apt-get install python-apport
$ apport-collect -p xorg 1453812
ERROR: Could not import module, is a package upgrade in progress? Error: No module named PyQt5.QtCore

vmagnin (vincent-magnin) wrote :

Note that I just have also a problem in LibreOffice Calc with the "nouveau" driver: it has some difficulties to display my spreadsheet and draw correctly the window. But the system is not frozen as in Writer.

Same thing here. Most commonly the hard freeze occurs when doing things in quick succession, like pasting a large chunk of text from the clipboard and immediately trying to select all text or jumping to the end of the document.

Sebastian Thürrschmidt, it will help immensely if you filed a new report via a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

apport information

tags: added: apport-collected compiz-0.9 ubuntu vivid
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

vmagnin (vincent-magnin) wrote :

I have just reproduced the bug, then booted into http://cdimage.ubuntu.com/daily-live/current/vivid-desktop-amd64.iso and then typed in a terminal:
$ sudo apt-get install python-apport
$ apport-collect -p xorg 1453812

vmagnin (vincent-magnin) wrote :

The bug has also been reported on Fedora:
https://bugzilla.redhat.com/show_bug.cgi?id=1189332

tags: added: bios-outdated-3.57
vmagnin (vincent-magnin) wrote :

I have updated the BIOS:
$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
786G3 v03.57
07/15/2013

But the bug still occurs. LibreOffice can still freeze totally the system.

Changed in xorg (Ubuntu):
status: Incomplete → New
tags: added: latest-bios-3.57
removed: bios-outdated-3.57
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

vmagnin, could you please test the latest upstream kernel available from the very top line at the top of the page (the release names are irrelevant for testing, and please do not test the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue.

If the test did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where XY and Z are numbers corresponding to the kernel version.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

affects: xorg (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Confirmed
yazid (mailboost) wrote :

This bug affects me too! Same behavior. You should consider that this is a DATA LOSS bug, just because every time the pc freezes I lost all my work not yet saved. So the importance should be set to high. By the way a bug that causes a system freeze can't be considered "low importance" just because the final user can't trust the distro anymore. I'm very upset with this because I use Ubuntu at job and it's not nice to waste job time.
I tried to disable the "use anti-alias" option in Options -> general -> view-> menu in libreoffice BUT this causes Libreoffice writer to freeze the entire system just after it was launched (after the splash screen disappears and when you are prompted to type something in the blank page). So probably it's a graphic driver problem. I have a nvidia 8500GT and I use nouveau driver. Hardware acceleration is enabled (gallium 0.4 on NV86). Tell me if I can be more useful and thank you in advance for your precious work on free software

yazid (mailboost) wrote :

I don't know if it can be useful or not. I replaced the nouveau video driver with proprietary nvidia driver (340.76, tested). No more freezing experienced with LO writer BUT when I was using Evince to read some pdf (while LO writer was running) I experienced a GUI freeze by clicking on the top bar of Evince going to select "always on top" option. Fortunately I was able to enter in a tty session; after killing evince I was able to come back to the GUI and take control over it (and save the LO writer document).
Kernel running: 3.19.0-21-generic
OS: Ubuntu Gnome 64bit 15.04

vmagnin (vincent-magnin) wrote :

Sorry Christopher M. Penalver,
I have not yet found time to test other kernels, this PC being at my job office.
But I can confirm that the bug is still there.

yazid (mailboost) wrote :

Tested kernel -3.19.0-22-generic on Ubuntu 15.04 64 bit. The bug still exists.

xan (xan-zappa) wrote :

This bug affects me as well - fresh new install of 15.04

Kernel Version: 3.19.0-25-generic
32 bits version
Nouveau driver installed.

I solved the problem.(but just until Ubuntu has a better update on drivers or something else). There it goes:

I just verified it on nvidia video cards.

Select the driver options. Then, select: [nvidia legacy binary driver - version 304.125 of nvidia-304-updates (proprietary)]

I don't know why this is the option which works, but it does.

vmagnin (vincent-magnin) wrote :

Thank you Rafael.
No more freeze since I use nvidia-304-updates.

Lars Risan (lars-risan) wrote :

One way to reproduce the bug: In LibreOffice, mark text across several text types (e.g. "standard" and "Headline"). In Kubuntu only LibreOffice freezes,in Ubuntu the entire desktop freezes.

Rafaels solution worked for me as well, afrer i reboot.

description: updated

Affected. Like others said, selecting anything in a LibreOffice document would freeze the system. Cannot change tty, cannot do anything other than hard reset. Relevant kern.log entry (sans timestamp and hostname):

nouveau E[ PFIFO][0000:02:00.0] still angry after 101 spins, halt

Switching to proprietary nvidia driver (340.76-0ubuntu2) resulted with the problem no longer appearing.

Kernel: 3.19.0-28-generic
Ubuntu: 15.04 64-bit
Nvidia: NVIDIA Corporation G92 [GeForce GTS 250] (rev a2)

Vlad K., it will be most helpful if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

Witold Szczeponik (wsz) wrote :

Bug #1481129, which I marked as a duplicate of this bug, contains some more information.

Christopher, what for? So a duplicate can raise the bug heat?

Also, why is this designated as low priority? Isn't this a very critical bug for a very likely use case of running Ubuntu on a system with nvidia, default nouveau driver and editing a LibreOffice document.

Vlad K., if you want your issue addressed as soon as possible, open a new report as previously advised.

Daniel M (dlmiller) wrote :

Christopher, I am facing the same issue as others here. I have just filed a new bug report as per your request to Vlad K.
The bug report number is 1504321.

I hope its helpful.

GLehnhoff (glehnhoff) wrote :

Libreoffice freezes complete system, whether it is Kubuntu 15.04 or Ubuntu15.04. Very annoying. I will to nvidia driver and will see, whether this helps.

GLehnhoff, it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

yurx cherio (cherio) wrote :

I might add a twist into this saga. I run some backend document processing on a VMWare virtualized server (Ubuntu 14.04) with no UI at all. soffice is started as a headless instance and accepts connections on port 8100. After the upgrade to 5.1 the backend document generation slowed down to a crawl. Now it takes 15 minutes(!!!) to build a 30-page long document. The same process before the upgrade used to take less than 15 seconds.

yurx cherio, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Same problem running Ubuntu 16.04 on legacy machine, with nouveau-drivers for NVidia graphic chipset
on HP laptop. LibreOffice Writer freezes (running version 5.1):

"The only possible action is moving the mouse pointer on the screen. Impossible to connect to a tty session to kill Xorg."

I did manage to reboot using FN + ALT + SYSRQ + REISUB rather than a hard reboot being necessary using the power button.

LibreOffice Writer tried to recover my document, but some data was lost, after reboot and restart of the app.

Kernel: 4.4.0-47-generic
Ubuntu: 16.04 64-bit
Nvidia: GeForce 6150

I want to modify the above comment, as I just had similar misbehavior from my Ubuntu install running a different app, Synaptics.

System froze after a few minutes use of Synaptics (running Ubuntu 16.04): "the only possible action is moving the mouse pointer on the screen. Impossible to connect to a tty session to kill Xorg."

Again, I did manage to reboot using FN + ALT + SYSRQ + REISUB, same as above.

ADTopkek (adtopkek) wrote :

Using Linux Mint 17.3. Happened to me when I had half a page of various formatted text, changed size to 16, then scrolled a little. Whole system froze up. Alt + F2 did not work. I was using Novuveau 1:1.0.10-1 unbuntu2 drivers. I changed to using Nviedia drivers and the problem hasn't happened when it used to take under a minute to happen and reliably crashed on demand.

tags: added: bios-outdated-3.60
removed: latest-bios-3.57

Same problem running Ubuntu 16.04 on Lenovo-B51-80 (AMD Radeon R5 M330 with open source drivers). The problem persists longer than 1 year for me (1 year of updates did not solve the problem). Not sure why importance of this problem marked as "low": the software in unusable, and I've been using Google Docs ever since.

Vitaly Yevstigneyev, given you have different hardware, you likely have a different root cause altogether (i.e. not the same problem). For example, I have Intel hardware, and cannot reproduce the issue on various versions of Ubuntu and LibreOffice.

Hence, it will help immensely if you use the computer the problem is reproducible with, file a new report with Ubuntu by first ensuring the package xdiagnose is installed, click the Yes button for attaching additional debugging information after running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.