[gm45] 3.19.0-17 freeze

Bug #1453593 reported by volker kempter on 2015-05-10
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Unassigned
Vivid
Critical
Timo Aaltonen

Bug Description

boot with 3.19.0-17 freezes at very early stage, way before the appearance of login screen.

no such problems with kernel 3.19.0-16.

Tested upstream kernels 4.0.0-1, 4.01, 4.0.2 and 4.1-rc2: all of them boot normally.

No problems to boot with 3.19.0-17 in a lubuntu15.04 virtual machine under virtualbox (running on the same hardware platform).

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-3.19.0-16-generic 3.19.0-16.16
ProcVersionSignature: Ubuntu 3.19.0-16.16-generic 3.19.3
Uname: Linux 3.19.0-16-generic i686
ApportVersion: 2.17.2-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: volker 2576 F.... pulseaudio
CurrentDesktop: LXDE
Date: Sun May 10 21:09:41 2015
HibernationDevice: RESUME=UUID=56d8d5bd-f32d-4192-a0d4-2395d9df1637
InstallationDate: Installed on 2014-02-12 (451 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
MachineType: Dell Inc. Latitude E6500
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-16-generic root=UUID=6ff58f38-956b-49de-99d4-01dfc84b96ad ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-16-generic N/A
 linux-backports-modules-3.19.0-16-generic N/A
 linux-firmware 1.143
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/18/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0NY667
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd12/18/2008:svnDellInc.:pnLatitudeE6500:pvr:rvnDellInc.:rn0NY667:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6500
dmi.sys.vendor: Dell Inc.

volker kempter (v-kempter) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

volker kempter, thank you for reporting this and helping make Ubuntu better. As per http://www.dell.com/support/home/us/en/19/product-support/product/latitude-e6500/drivers an update to your computer's buggy and outdated BIOS is available (A29). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful. As well, you don't have to create a new bug report.

Once the BIOS is updated, and the information above is provided, then please mark this report Status Confirmed.

Thank you for your understanding.

tags: added: bios-outdated-a29
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
volker kempter (v-kempter) wrote :

at #3 - bios upgrade:

considering the fact that such an upgrade is a sensitive matter, I feel that the suggested procedures are somewhat risky because not being really transparent to me.

On the other hand, I have a virtual win7 machine (32bit install) (under virtualbox) at my disposal.
Maybe, you could suggest a simple, more transparent way for a successful BIOS upgrade by using this virtual machine?

volker kempter (v-kempter) wrote :

at #3 - bios upgrade:

i just discover that sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date do not work with kernel 4.0, but still work under 3.19.0-16.
I get the response: "/dev/mem: no such file"

Is this a bug or a new feature?

Joseph Salisbury (jsalisbury) wrote :

Can you also test the upstream stable 3.19.6 kernel ,which Ubuntu 3.19.0-17 is based on? This will tell us if this is an Ubuntu specific issue.

The 3.19.6 kernel can be downloaded from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.19.6-vivid/

Thanks in advance!

Changed in linux (Ubuntu):
importance: Low → Medium
tags: added: kernel-da-key
volker kempter (v-kempter) wrote :

at #6:

3.19.6-vivid boots normally. Startup time (kernel) under systemd is 4.8s (about what is found for other recent kernels).
For completeness, I tested also 3.19.8-vivid: boots also normally. However, startup time (kernel) is considerably longer, about 8s!

taiebot65 (dedreuil) wrote :

I am having the same problem but i will not be able to upgrade my bios. I have an old gateway computer.

taiebot65 (dedreuil) wrote :

By the way on my computer with kernel 3.19.0-17 my computer fails to start

Alan Fry (alan-fry) wrote :

HP Elitebook 6930p, Intel graphics, with fully updated Ubuntu Wily and kernel 3.19.0-17 also freezes early in the boot. It appears to happen just as the low resolution display changes to higher resolution.

Booting in recovery mode results in low resolution display.

Kernel 3.19.0-16 is OK as is mainline 3.19.6

Alan Fry (alan-fry) wrote :

Mainline kernel 4.0.3 also boots OK.

Changed in linux (Ubuntu):
importance: Medium → High
status: Incomplete → Triaged
tags: added: kernel-key
Changed in linux (Ubuntu Vivid):
importance: Undecided → High
status: New → Triaged
Changed in linux (Ubuntu):
importance: High → Critical
Changed in linux (Ubuntu Vivid):
importance: High → Critical
Joseph Salisbury (jsalisbury) wrote :

@Alan Fry and @taiebot65

Can you post the output of : 'sudo lspci -vvvnn'

Timo Aaltonen (tjaalton) wrote :

also, test v4.0-rc7 mainline

Timo Aaltonen (tjaalton) on 2015-05-14
Changed in linux (Ubuntu Vivid):
assignee: nobody → Timo Aaltonen (tjaalton)
volker kempter (v-kempter) wrote :

at #13:

v4.0-rc7 mainline boots okay on dell e6500.
Startup time under systemd is about 5.7sec (kernel)

Timo Aaltonen (tjaalton) wrote :

please attach the kern.log after booting the bad kernel once with 'drm.debug=0xe'

volker kempter (v-kempter) wrote :

at #15:
one time boot with 3.19.0-17:

added 'drm.debug=0xe' to the boot options, removed "quiet no splash".
Boot attempt with 3.19.0-17 was made at 10:56, I suppose.

Later, successfully booted was with 4.0.
Included /var/log/kern.log.

Timo Aaltonen (tjaalton) wrote :

nope, all were with some 4.0 based mainline, could you try again?

Timo Aaltonen (tjaalton) wrote :

although it's also possible that it didn't get far enough to start logging to the disk.. boot the bad one without drm.debug, quiet and splash, hoping that you'll get something on the screen instead.. take a picture if you do

Alan Fry (alan-fry) wrote :

As requested in Post #12 above

Timo Aaltonen (tjaalton) wrote :

so it's confirmed this affects gm45, and possibly only that.. thanks

summary: - 3.19.0-17 freeze
+ [gm45] 3.19.0-17 freeze
volker kempter (v-kempter) wrote :

ad #17:

tried again with 3.19.0-17 (14:30).
Aterwards, restart with with 4.0.2.

kern.log attached

Timo Aaltonen (tjaalton) wrote :

if someone has time to test bisect kernels more interactively, I'm on IRC (#ubuntu-x)

volker kempter (v-kempter) wrote :

ad #18:

... boot the bad one without drm.debug, quiet and splash, hoping that you'll get something on the screen instead.. take a picture if you do

did it ... produces some pages... I could send you /var/log/boot?
On the other hand, how could I write the boot messages into a file?

Please give me some more advice!

Timo Aaltonen (tjaalton) wrote :

if you have a mobile phone with a camera, take a picture. /var/log/boot doesn't have anything, kern.log would have had the info already.. the machine hung before it had a chance to write anything to the disk

first bisect kernel at
http://koti.kapsi.fi/~tjaalton/gm45

Timo Aaltonen (tjaalton) wrote :

added another, assuming the first is ok

volker kempter (v-kempter) wrote :

#24:
"first bisect kernel at
http://koti.kapsi.fi/~tjaalton/gm45"

my architecture is i386, 32bit? Can I contribute something?

Timo Aaltonen (tjaalton) wrote :

ugh, I'm afraid not, at least with these builds..

Timo Aaltonen (tjaalton) wrote :

Alan Fry, taiebot65:

Do you have a 64bit install? If yes, could you test the builds I put in http://koti.kapsi.fi/~tjaalton/gm45 ?

Alan Fry (alan-fry) wrote :

Yes, I am using 64 bit version.

Your modified build boots OK both systemd and upstart.

Well done!

Timo Aaltonen (tjaalton) wrote :

Which one did you try, or both? These only bisect the changes to drivers/gpu/drm between 3.19.0-16..3.19.0-17, in order to find out which one broke it for you..

Alan Fry (alan-fry) wrote :

In my ignorance I downloaded all 4 files then ran 'sudo dpkg -i *.deb'.

alan@alan-ubuntu:~$ uname -a
Linux alan-ubuntu 3.19.0-17-generic #17+bis2 SMP Fri May 15 16:32:43 EEST 2015 x86_64 x86_64 x86_64 GNU/Linux
alan@alan-ubuntu:~$

If you want me to try biz1 on its own, please ask.

Timo Aaltonen (tjaalton) wrote :

no need, there's now bis3 which just reverts a single commit that I think might have caused this issue..

Alan Fry (alan-fry) wrote :

Biz3 applied to std 3.19.0-17 boots OK

Timo Aaltonen (tjaalton) wrote :

just checking, but you installed both +bis3 packages, right?

Alan Fry (alan-fry) wrote :

Yes.

tags: removed: kernel-key
Luis Henriques (henrix) on 2015-05-19
Changed in linux (Ubuntu Vivid):
status: Triaged → Fix Committed
Changed in linux (Ubuntu):
status: Triaged → Invalid
volker kempter (v-kempter) wrote :

kernel 3.19.0-18:

works for me with dell e6500 under 15.04-lubuntu (i386 architecture) (while kernel 3.19.0-17 was not working).
Startup time is 4.9s (kernel), similar to other recent kernels.

Launchpad Janitor (janitor) wrote :
Download full text (18.1 KiB)

This bug was fixed in the package linux - 3.19.0-18.18

---------------
linux (3.19.0-18.18) vivid; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1456732

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: remove intel_pipe_set_base() (v4)"
    - LP: #1453593

linux (3.19.0-17.17) vivid; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1452000

  [ Damien Lespiau ]

  * SAUCE: i915_bpo: drm/i915/skl: Fix stepping check for a couple of W/As
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Implement WaDisableVFUnitClockGating
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Add the INIT power domain to the MISC
    I/O power well
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Fix the CTRL typo in the DPLL_CRTL1
    defines
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Make the Misc I/O power well part of the
    PLLS domain
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Deinit/init the display at
    suspend/resume
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Change CDCLK behind PCU's back
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: gen6+ platforms support runtime PM
    - LP: #1449469

  [ Imre Deak ]

  * SAUCE: i915_bpo: drm/i915/gen9: fix PIPE_CONTROL flush for
    VS_INVALIDATE
    - LP: #1449469

  [ Leann Ogasawara ]

  * [Config] Set CONFIG_XEN_MAX_DOMAIN_MEMORY defaults

  [ Matt Roper ]

  * SAUCE: i915_bpo: drm/i915: Switch to full atomic helpers for plane
    updates/disable, take two
    - LP: #1449469

  [ Sonika Jindal ]

  * SAUCE: i915_bpo: drm/i915/skl: Allow universal planes to position
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Support for 90/270 rotation
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Add back HDMI translation table
    - LP: #1449469

  [ Stefan Bader ]

  * SAUCE: vesafb: Set mtrr:3 (write-combining) as default
    - LP: #1434581

  [ Timo Aaltonen ]

  * SAUCE: Call i915_bpo specific functions from the hda driver
    - LP: #1449464
  * SAUCE: i915_bpo: Use get_display_clock_speed
    - LP: #1449469
  * SAUCE: i915_bpo: Add a few register definitions
    - LP: #1449469

  [ Upstream Kernel Changes ]

  * Revert "sparc/PCI: Clip bridge windows to fit in upstream windows"
    - LP: #1446316
  * Revert "PM / hibernate: avoid unsafe pages in e820 reserved regions"
    - LP: #1446316
  * Revert "libceph: use memalloc flags for net IO"
    - LP: #1446316
  * Revert "net: Reset secmark when scrubbing packet"
    - LP: #1451996
  * ASoC: da732x: Fix control-less DAPM routes
    - LP: #1446316
  * ASoC: ak4671: Fix control-less DAPM routes
    - LP: #1446316
  * ASoC: sn95031: Fix control-less DAPM routes
    - LP: #1446316
  * ASoC: sgtl5000: remove useless register write clearing CHRGPUMP_POWERUP
    - LP: #1446316
  * ASoC: pcm1681: Fix wrong value references for boolean kctl
    - LP: #1446316
  * ASoC: cs4271: Fix wrong value references for boolean kctl
    - LP: #1446316
  * ASoC: es8238: Fix wrong value references for boolean kctl
    - LP: #1446316
  * ASoC: wm8960: Fix wrong value references for boolean kctl
    - LP: #1446316
  * ASoC: tas5086: Fix wrong value references for boolean kctl
    - ...

Changed in linux (Ubuntu):
status: Invalid → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-vivid' to 'verification-done-vivid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-vivid
Luis Henriques (henrix) wrote :

According to comment #36, verification has been done already. Tagging bug as verified.

tags: added: verification-done-vivid
removed: verification-needed-vivid
Launchpad Janitor (janitor) wrote :
Download full text (18.1 KiB)

This bug was fixed in the package linux - 3.19.0-18.18

---------------
linux (3.19.0-18.18) vivid; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1456732

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: remove intel_pipe_set_base() (v4)"
    - LP: #1453593

linux (3.19.0-17.17) vivid; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1452000

  [ Damien Lespiau ]

  * SAUCE: i915_bpo: drm/i915/skl: Fix stepping check for a couple of W/As
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Implement WaDisableVFUnitClockGating
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Add the INIT power domain to the MISC
    I/O power well
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Fix the CTRL typo in the DPLL_CRTL1
    defines
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Make the Misc I/O power well part of the
    PLLS domain
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Deinit/init the display at
    suspend/resume
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Change CDCLK behind PCU's back
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: gen6+ platforms support runtime PM
    - LP: #1449469

  [ Imre Deak ]

  * SAUCE: i915_bpo: drm/i915/gen9: fix PIPE_CONTROL flush for
    VS_INVALIDATE
    - LP: #1449469

  [ Leann Ogasawara ]

  * [Config] Set CONFIG_XEN_MAX_DOMAIN_MEMORY defaults

  [ Matt Roper ]

  * SAUCE: i915_bpo: drm/i915: Switch to full atomic helpers for plane
    updates/disable, take two
    - LP: #1449469

  [ Sonika Jindal ]

  * SAUCE: i915_bpo: drm/i915/skl: Allow universal planes to position
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Support for 90/270 rotation
    - LP: #1449469
  * SAUCE: i915_bpo: drm/i915/skl: Add back HDMI translation table
    - LP: #1449469

  [ Stefan Bader ]

  * SAUCE: vesafb: Set mtrr:3 (write-combining) as default
    - LP: #1434581

  [ Timo Aaltonen ]

  * SAUCE: Call i915_bpo specific functions from the hda driver
    - LP: #1449464
  * SAUCE: i915_bpo: Use get_display_clock_speed
    - LP: #1449469
  * SAUCE: i915_bpo: Add a few register definitions
    - LP: #1449469

  [ Upstream Kernel Changes ]

  * Revert "sparc/PCI: Clip bridge windows to fit in upstream windows"
    - LP: #1446316
  * Revert "PM / hibernate: avoid unsafe pages in e820 reserved regions"
    - LP: #1446316
  * Revert "libceph: use memalloc flags for net IO"
    - LP: #1446316
  * Revert "net: Reset secmark when scrubbing packet"
    - LP: #1451996
  * ASoC: da732x: Fix control-less DAPM routes
    - LP: #1446316
  * ASoC: ak4671: Fix control-less DAPM routes
    - LP: #1446316
  * ASoC: sn95031: Fix control-less DAPM routes
    - LP: #1446316
  * ASoC: sgtl5000: remove useless register write clearing CHRGPUMP_POWERUP
    - LP: #1446316
  * ASoC: pcm1681: Fix wrong value references for boolean kctl
    - LP: #1446316
  * ASoC: cs4271: Fix wrong value references for boolean kctl
    - LP: #1446316
  * ASoC: es8238: Fix wrong value references for boolean kctl
    - LP: #1446316
  * ASoC: wm8960: Fix wrong value references for boolean kctl
    - LP: #1446316
  * ASoC: tas5086: Fix wrong value references for boolean kctl
    - ...

Changed in linux (Ubuntu Vivid):
status: Fix Committed → Fix Released
majid hussain (mhussaincov93) wrote :

hi there, is there an x86 version of this?

Timo Aaltonen (tjaalton) wrote :

Guys, anyone willing to help bisecting the fix for GM45 (= your HW) so that the rotate bugfix for HSW/BDW could be applied again?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers