suggest patches for be2iscsi in ubuntu 14.04

Bug #1440156 reported by minh tran on 2015-04-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
minh tran
Vivid
Undecided
Unassigned

Bug Description

These patches to be applied over ubuntu 3.13 kernel:

0001-SCSI-be2iscsi-fix-memory-leak-in-error-path.patch:commit 0e7c60cb8cd7b0250b1cf40012e5015c90bb89db
0002-block-remove-old-blk_iopoll_enabled-variable.patch:commit 89f8b33ca1ea881d1d84542282cb85d07d02e78d
0003-SCSI-be2iscsi-Fix-handling-timed-out-MBX-completion-.patch:commit 1957aa7f62462dc888dfc9a94373b27f936f2e10
0004-SCSI-be2iscsi-Fix-doorbell-format-for-EQ-CQ-RQ-s-per.patch:commit e08b3c8b11e9c49ac95cf0fff5bd6cff32de13a4
0005-SCSI-be2iscsi-Fix-the-session-cleanup-when-reboot-sh.patch:commit 9343be749085c2229622ef47058dca4937e30882
0006-SCSI-be2iscsi-Fix-scsi_cmnd-leakage-in-driver.patch:commit da3349771c7ca01415df49929b265c21bc4295c3
0007-SCSI-be2iscsi-Fix-DMA-Out-of-SW-IOMMU-space-error.patch:commit 6c57625b3c08f67f562e8db3ba44bb5a27aaf7d2
0008-be2iscsi-Fix-retrieving-MCCQ_WRB-in-non-embedded-Mbo.patch:commit daa8dc081cd801635b2757aa6f257a79d9ac6d2c
0009-be2iscsi-Fix-exposing-Host-in-sysfs-after-adapter-in.patch:commit 0598b8afd65d6b0893d217f7cf77ea315cdfcb5b
0010-be2iscsi-Fix-interrupt-Coalescing-mechanism.patch:commit 73af08e11c6638e2abd6b1fa13cdab58c2bbdbf8
0011-be2iscsi-Fix-TCP-parameters-while-connection-offload.patch:commit b3c202dc57607174468b3ea6b4220b7ca5643f05
0012-be2iscsi-Fix-memory-corruption-in-MBX-path.patch:commit 8fc01eaa8793b7c2277b4a84c218a5f8fe45ccdd
0013-be2iscsi-Fix-destroy-MCC-CQ-before-MCC-EQ-is-destroy.patch:commit 231881677083647271796bfa4fd385fbae8efaf6
0014-be2iscsi-add-an-missing-goto-in-error-path.patch:commit 5f2d25efa4c4567fa72b70de4e041252c72aa10e
0015-be2iscsi-remove-potential-junk-pointer-free.patch:commit beff65497ab12821c65739557c77d85bdd4ca618
0016-be2iscsi-Fix-memory-leak-in-mgmt_set_ip.patch:commit 6d67726bd898151e688d8729b3997ba8417c2c6b
0017-be2iscsi-Fix-the-sparse-warning-introduced-in-previo.patch:commit 39033413e22aa64944baf21b29e134d52be67038
0018-be2iscsi-Fix-updating-the-boot-enteries-in-sysfs.patch:commit a3d313ea56fada1c73be022140b8d2b14ff1fc7b
0019-be2iscsi-Fix-processing-CQE-before-connection-resour.patch:commit b7ab35b13379e709a2a1c3f1b3a59e5db62ce4e3
0020-be2iscsi-Fix-kernel-panic-during-reboot-shutdown.patch:commit 53281edb2942c4d7abf12846b6b0591caf2bee4d
0022-fixed-invalid-assignment-of-64bit-mask-to-host-dma_b.patch:commit f76a610a8b4b6280eaedf48f3af9d5d74e418b66

Other patches not pulled in to upstream and may needs to be regenerated before they can be reviewed:
 Patch 1: https://marc.info/?l=linux-scsi&m=141897754917474&w=2
 Patch 2 : https://marc.info/?l=linux-scsi&m=141897755017476&w=2
 Patch 3 : https://marc.info/?l=linux-scsi&m=141897763517510&w=2
 Patch 5: http://marc.info/?l=linux-scsi&m=142364460501271&w=2

CVE References

minh tran (minh-tran) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1440156

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Tim Gardner (timg-tpi) wrote :

The following changes since commit 82400710768af709372eaf040b77f81dcfdb4f7e:

  UBUNTU: [Config] CONFIG_DEFAULT_MMAP_MIN_ADDR needs to match on armhf and arm64 (2015-03-31 10:54:49 -0700)

are available in the git repository at:

  git://kernel.ubuntu.com/rtg/ubuntu-trusty.git emulex-lp1440156

for you to fetch changes up to 3add37272c04d913a81f5e6689e03c30522bb2de:

  fixed invalid assignment of 64bit mask to host dma_boundary for scatter gather segment boundary limit. (2015-04-03 12:59:24 -0600)

----------------------------------------------------------------
Geyslan G. Bem (1):
      be2iscsi: fix memory leak in error path

Jayamohan Kallickal (14):
      be2iscsi: Fix handling timed out MBX completion from FW
      be2iscsi: Fix doorbell format for EQ/CQ/RQ s per SLI spec.
      be2iscsi: Fix the session cleanup when reboot/shutdown happens
      be2iscsi: Fix scsi_cmnd leakage in driver.
      be2iscsi : Fix DMA Out of SW-IOMMU space error
      be2iscsi: Fix retrieving MCCQ_WRB in non-embedded Mbox path
      be2iscsi: Fix exposing Host in sysfs after adapter initialization is complete
      be2iscsi: Fix interrupt Coalescing mechanism.
      be2iscsi: Fix TCP parameters while connection offloading.
      be2iscsi: Fix memory corruption in MBX path
      be2iscsi: Fix destroy MCC-CQ before MCC-EQ is destroyed
      be2iscsi: Fix the sparse warning introduced in previous submission
      be2iscsi: Fix updating the boot enteries in sysfs
      be2iscsi: Fix processing CQE before connection resources are freed

Jens Axboe (1):
      block: remove old blk_iopoll_enabled variable

John Soni Jose (1):
      be2iscsi : Fix kernel panic during reboot/shutdown

Maurizio Lombardi (1):
      be2iscsi: Fix memory leak in mgmt_set_ip()

Minh Duc Tran (1):
      fixed invalid assignment of 64bit mask to host dma_boundary for scatter gather segment boundary limit.

Tomas Henzl (2):
      be2iscsi: add an missing goto in error path
      be2iscsi: remove potential junk pointer free

 block/blk-iopoll.c | 3 -
 drivers/scsi/be2iscsi/be.h | 22 ++++++
 drivers/scsi/be2iscsi/be_cmds.c | 159 ++++++++++++++++++++++++++++++++----------
 drivers/scsi/be2iscsi/be_cmds.h | 63 +++++++++++++----
 drivers/scsi/be2iscsi/be_iscsi.c | 60 ++++++++++++----
 drivers/scsi/be2iscsi/be_main.c | 402 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++----------------------------------------------
 drivers/scsi/be2iscsi/be_main.h | 30 ++++++--
 drivers/scsi/be2iscsi/be_mgmt.c | 110 ++++++++++++++++++++---------
 drivers/scsi/be2iscsi/be_mgmt.h | 2 +
 drivers/scsi/ipr.c | 15 ++--
 include/linux/blk-iopoll.h | 2 -
 kernel/sysctl.c | 12 ----
 12 files changed, 580 insertions(+), 300 deletions(-)

Changed in linux (Ubuntu Vivid):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
tags: added: kernel-da-key
Brad Figg (brad-figg) on 2015-04-07
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Tim Gardner (timg-tpi) on 2015-04-17
Changed in linux (Ubuntu Trusty):
assignee: Tim Gardner (timg-tpi) → minh tran (minh-tran)
minh tran (minh-tran) on 2015-04-20
tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (13.4 KiB)

This bug was fixed in the package linux - 3.13.0-51.84

---------------
linux (3.13.0-51.84) trusty; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1444141
  * Merged back Ubuntu-3.13.0-49.83 security release

linux (3.13.0-50.82) trusty; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1442285

  [ Andy Whitcroft ]

  * [Config] CONFIG_DEFAULT_MMAP_MIN_ADDR needs to match on armhf and arm64
    - LP: #1418140

  [ Chris J Arges ]

  * [Config] CONFIG_PCIEASPM_DEBUG=y
    - LP: #1398544

  [ Upstream Kernel Changes ]

  * KEYS: request_key() should reget expired keys rather than give
    EKEYEXPIRED
    - LP: #1124250
  * audit: correctly record file names with different path name types
    - LP: #1439441
  * KVM: x86: Check for nested events if there is an injectable interrupt
    - LP: #1413540
  * be2iscsi: fix memory leak in error path
    - LP: #1440156
  * block: remove old blk_iopoll_enabled variable
    - LP: #1440156
  * be2iscsi: Fix handling timed out MBX completion from FW
    - LP: #1440156
  * be2iscsi: Fix doorbell format for EQ/CQ/RQ s per SLI spec.
    - LP: #1440156
  * be2iscsi: Fix the session cleanup when reboot/shutdown happens
    - LP: #1440156
  * be2iscsi: Fix scsi_cmnd leakage in driver.
    - LP: #1440156
  * be2iscsi : Fix DMA Out of SW-IOMMU space error
    - LP: #1440156
  * be2iscsi: Fix retrieving MCCQ_WRB in non-embedded Mbox path
    - LP: #1440156
  * be2iscsi: Fix exposing Host in sysfs after adapter initialization is
    complete
    - LP: #1440156
  * be2iscsi: Fix interrupt Coalescing mechanism.
    - LP: #1440156
  * be2iscsi: Fix TCP parameters while connection offloading.
    - LP: #1440156
  * be2iscsi: Fix memory corruption in MBX path
    - LP: #1440156
  * be2iscsi: Fix destroy MCC-CQ before MCC-EQ is destroyed
    - LP: #1440156
  * be2iscsi: add an missing goto in error path
    - LP: #1440156
  * be2iscsi: remove potential junk pointer free
    - LP: #1440156
  * be2iscsi: Fix memory leak in mgmt_set_ip()
    - LP: #1440156
  * be2iscsi: Fix the sparse warning introduced in previous submission
    - LP: #1440156
  * be2iscsi: Fix updating the boot enteries in sysfs
    - LP: #1440156
  * be2iscsi: Fix processing CQE before connection resources are freed
    - LP: #1440156
  * be2iscsi : Fix kernel panic during reboot/shutdown
    - LP: #1440156
  * fixed invalid assignment of 64bit mask to host dma_boundary for scatter
    gather segment boundary limit.
    - LP: #1440156
  * quota: Store maximum space limit in bytes
    - LP: #1441284
  * ip: zero sockaddr returned on error queue
    - LP: #1441284
  * net: rps: fix cpu unplug
    - LP: #1441284
  * ipv6: stop sending PTB packets for MTU < 1280
    - LP: #1441284
  * netxen: fix netxen_nic_poll() logic
    - LP: #1441284
  * udp_diag: Fix socket skipping within chain
    - LP: #1441284
  * ping: Fix race in free in receive path
    - LP: #1441284
  * bnx2x: fix napi poll return value for repoll
    - LP: #1441284
  * net: don't OOPS on socket aio
    - LP: #1441284
  * bridge: dont send notification when skb->len == 0 in rtnl_bridge_notify
    - LP: #1441284
  * ipv4: tcp: get rid of ugly unicast_sock
...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers