devel: consider fq_codel as the default qdisc for networking

Bug #1436945 reported by Andy Whitcroft on 2015-03-26
82
This bug affects 15 people
Affects Status Importance Assigned to Milestone
linux (Debian)
New
Unknown
linux (Ubuntu)
Low
Andy Whitcroft

Bug Description

This was raised on the kernel-team@ mailing list, we should look at this if other distros are starting to move.

===

Date: Tue, 24 Mar 2015 10:54:37 -0700
From: Dave Taht <email address hidden>
To: Joseph Salisbury <email address hidden>
Cc: Kernel Team <email address hidden>, <email address hidden>
Subject: Re: Minutes from the Ubuntu Kernel Team meeting, 2015-03-24

I must confess I had hoped ubuntu would adopt fq_codel as the default
qdisc in this go-around. It is still not quite part of fedora´s
default either, but is now in arch, (and nearly everyone else
downstream from systemd), and has long been the default in openwrt,
and at this point, just requires a single sysctl to enable.

It certainly could use more widespread testing, perhaps in the next release?

d@nuc-client:~$ cat /etc/sysctl.d/10-bufferbloat.conf
net.core.default_qdisc=fq_codel

Andy Whitcroft (apw) on 2015-03-26
Changed in linux (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Andy Whitcroft (apw)
milestone: none → ubuntu-15.03

Happy Arch user running with the fq_codel default for a while. I have also enabled it manually on the Ubuntu systems I administer (running 12.04 with the updated kernel packages, and 14.04). Will definitely second it being turned on by default!

Conficio (kajkandler) wrote :

Yes, lets fight #bufferbloat, especially for OS that goes into mobile devices (phone, tablet, laptop, netbook, internet audio player, TV, etc. which might connect to the network via WiFi and other wireless networks, as their speed might be different from the surrounding (home / small office) network. Because speed steps are the locations where bufferbloat piles up.

And lets keep a keen eye on Dave Taht's work on Wifi core as this will have another round of improvements to our mobile networked lives.

Andy Whitcroft (apw) on 2015-07-08
Changed in linux (Ubuntu):
milestone: ubuntu-15.03 → ubuntu-15.07
Andy Whitcroft (apw) on 2015-07-31
Changed in linux (Ubuntu):
milestone: ubuntu-15.07 → ubuntu-15.08
Andy Whitcroft (apw) on 2015-08-25
Changed in linux (Ubuntu):
milestone: ubuntu-15.08 → ubuntu-15.10
Andy Whitcroft (apw) on 2015-11-04
Changed in linux (Ubuntu):
milestone: ubuntu-15.10 → ubuntu-15.11
Andy Whitcroft (apw) on 2015-12-07
Changed in linux (Ubuntu):
milestone: ubuntu-15.11 → ubuntu-15.12
Andy Whitcroft (apw) on 2016-01-19
Changed in linux (Ubuntu):
milestone: ubuntu-15.12 → ubuntu-16.01
Andy Whitcroft (apw) on 2016-02-01
Changed in linux (Ubuntu):
milestone: ubuntu-16.01 → ubuntu-16.02
Andy Whitcroft (apw) on 2016-03-10
Changed in linux (Ubuntu):
milestone: ubuntu-16.02 → ubuntu-16.03
tags: added: artful bionic
Changed in systemd (Debian):
status: Unknown → New
affects: systemd (Debian) → linux (Debian)

From what I can see, updates in ubuntu have now fixed this, bionic system certainly seems to now be booting with /proc/sys/net/core/default_qdisc = fq_codel now!.

Can somebody confirm this and close this bug as 'fixed' ?

SECONDLY, Related bufferbloat-matter to make fq_codel work better to avoid packet-drops is outbound tcp ECN-enablement on ubuntu end-hosts -- please see related ubuntu bug #1773157 and mark/comment there please:-

https://bugs.launchpad.net/ubuntu/+source/procps/+bug/1773157

I also see fq_codel used as default:

# cat /proc/sys/net/core/default_qdisc
fq_codel

# ip addr
[...]
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000

Changed in linux (Ubuntu):
status: Confirmed → Fix Released

Interestingly, turns out that seemingly systemd is what is (currently) responsible for turning on fq_codel by default. See:-

https://github.com/systemd/systemd/commit/e6c253e363dee77ef7e5c5f44c4ca55cded3fd47

Be nice to then get that suggested into upstream linux as a default and/or procps for 'non-systemd' booting. Also see #1773157 -- ECN really needs to be properly enabled to give the best benefit for congestion with TCP streams present.

Launchpad issue link didn't come out -- LP #1773157
https://bugs.launchpad.net/ubuntu/+source/procps/+bug/1773157

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.