Ubuntu 15.04: Multiple ACPI errors on Asus notebook

Bug #1435255 reported by aljosa on 2015-03-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

LiveUSB environment (daily-live 23-Mar-2015)
Asus optimus notebook X750JN-TY027H (Intel® Core™ i7-4710HQ; RAM 8GB; Nvidia GeForce GT 840M)

Hello,
I have received an expert's opinion that most probably they have nothing to do with the Elantech touchpad bug (https://bugzilla.kernel.org/show_bug.cgi?id=94981), so in order to contribute to quality improvement of the new Ubuntu 15.04, I'm reporting a problem I found in this "beta" version - related to mutliple ACPI warnings and errors. Here's an example:

[ 6.436162] ACPI Warning: \_SB_.PCI0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20141107/nsarguments-95)
[ 6.436200] ACPI Warning: \_SB_.PCI0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20141107/nsarguments-95)
[ 6.436267] i915 0000:00:02.0: optimus capabilities: enabled, status dynamic power,
[ 6.436282] ACPI Warning: \_SB_.PCI0.P0PA.VGA_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20141107/nsarguments-95)
[ 6.436311] ACPI Warning: \_SB_.PCI0.P0PA.VGA_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20141107/nsarguments-95)

[ 6.343478] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.343481] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343484] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS02._PLD] (Node ffff8802274c1a28), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343673] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.343675] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343678] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS04._PLD] (Node ffff8802274c1bb8), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343765] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.343767] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343769] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS05._PLD] (Node ffff8802274c1c80), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343856] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.343858] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343860] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS06._PLD] (Node ffff8802274c1d48), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343947] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.343949] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.343951] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS07._PLD] (Node ffff8802274c1e10), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344038] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.344039] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344042] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS08._PLD] (Node ffff8802274c1ed8), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344128] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.344130] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344132] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS09._PLD] (Node ffff8802274c1fa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344219] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.344221] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344224] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS10._PLD] (Node ffff8802274c2078), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344311] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.344313] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344315] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS11._PLD] (Node ffff8802274c2140), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344402] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.344404] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344406] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS12._PLD] (Node ffff8802274c2208), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344494] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.344496] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344498] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS13._PLD] (Node ffff8802274c22d0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344585] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20141107/exoparg2-420)
[ 6.344586] ACPI Error: Method parse/execution failed [\_SB_.XPLD] (Node ffff8802274c2aa0), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)
[ 6.344589] ACPI Error: Method parse/execution failed [\_SB_.PCI0.XHC_.RHUB.HS14._PLD] (Node ffff8802274c2398), AE_AML_PACKAGE_LIMIT (20141107/psparse-536)

[ 6.755465] ACPI Error: Field [CMDX] at 224 exceeds Buffer [SCBF] size 168 (bits) (20141107/dsopcode-236)
[ 6.755469] ACPI Error: Method parse/execution failed [\GTFB] (Node ffff8802274f0370), AE_AML_BUFFER_LIMIT (20141107/psparse-536)
[ 6.755472] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT4._GTF] (Node ffff8802274f0618), AE_AML_BUFFER_LIMIT (20141107/psparse-536)
[ 6.755474] ata5.00: _GTF evaluation failed (AE 0x300a)

[ 6.759537] ACPI Error: Field [CMDX] at 224 exceeds Buffer [SCBF] size 168 (bits) (20141107/dsopcode-236)
[ 6.759542] ACPI Error: Method parse/execution failed [\GTFB] (Node ffff8802274f0370), AE_AML_BUFFER_LIMIT (20141107/psparse-536)
[ 6.759545] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT4._GTF] (Node ffff8802274f0618), AE_AML_BUFFER_LIMIT (20141107/psparse-536)
[ 6.759547] ata5.00: _GTF evaluation failed (AE 0x300a)

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-3.19.0-9-generic 3.19.0-9.9
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3345 F.... pulseaudio
 /dev/snd/controlC1: ubuntu 3345 F.... pulseaudio
CasperVersion: 1.355
CurrentDesktop: Unity
Date: Mon Mar 23 10:09:10 2015
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150323)
MachineType: ASUSTeK COMPUTER INC. X750JN
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --- cdrom-detect/try-usb=true noprompt persistent
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-9-generic N/A
 linux-backports-modules-3.19.0-9-generic N/A
 linux-firmware 1.143
SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/06/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X750JN.205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X750JN
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX750JN.205:bd10/06/2014:svnASUSTeKCOMPUTERINC.:pnX750JN:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX750JN:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: X750JN
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

aljosa (aljosa-p) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.0 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-rc5-vivid/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
aljosa (aljosa-p) wrote :

Problem is present also in Ubuntu 14.04.2 and here you can find dmesg output with kernel 4.0-rc4:

http://paste.ubuntu.com/10614968

tags: added: kernel-bug-exists-upstream
aljosa (aljosa-p) on 2015-04-02
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers