[Realtek 0bda:b728] Bluetooth is useless after installed 14.04.2

Bug #1433987 reported by Gabriel Zhi Chen on 2015-03-19
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
HWE Next
High
Unassigned
linux (Ubuntu)
Low
Unassigned

Bug Description

CID : 201407-15368 Lenovo E450 (A+A) with 14.04.2 (utopic)
CID : 201408-15472 Lenovo E555 (A+A) with 14.04.2 (utopic)

Steps:
1. Install 14.04.2 on E450 or E555
2. Navigate to system Setting -> Bluetooth
3. Try to set up a new device.

Expected result:
When searching for devices, there are some BT device listed.

Actual result:
System keeping searching devices, but there is no BT device could be searched.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.16.0-30-generic 3.16.0-30.40~14.04.1 [modified: boot/vmlinuz-3.16.0-30-generic]
ProcVersionSignature: Ubuntu 3.16.0-30.40~14.04.1-generic 3.16.7-ckt3
Uname: Linux 3.16.0-30-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Mar 19 05:30:41 2015
InstallationDate: Installed on 2015-03-18 (1 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
SourcePackage: linux-lts-utopic
UpgradeStatus: No upgrade log present (probably fresh install)

Gabriel Zhi Chen (gabrielzchen) wrote :
description: updated
Po-Hsu Lin (cypressyew) on 2015-03-24
tags: added: blocks-hwcert
Keng-Yu Lin (lexical) wrote :

@Gabriel, will need /var/log/syslog, /var/log/kern.log, lsusb. The best all apport-collect against kernel package.

summary: - [Intel Corp. ID 8087:0a2a] Bluetooth is useless after installed 14.04.2
+ [Realtek 0bda:b728] Bluetooth is useless after installed 14.04.2
Gabriel Zhi Chen (gabrielzchen) wrote :
Gabriel Zhi Chen (gabrielzchen) wrote :
Gabriel Zhi Chen (gabrielzchen) wrote :
Gabriel Zhi Chen (gabrielzchen) wrote :

@Keng-Yu, please refer to logs in attachments. Thanks.

Keng-Yu Lin (lexical) wrote :

bluetooth Bus 004 Device 002: ID 0bda:b728 Realtek Semiconductor Corp.

Keng-Yu Lin (lexical) on 2015-04-07
Changed in hwe-next:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Liming Wang (wangliming)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-utopic (Ubuntu):
status: New → Confirmed
Liming Wang (wangliming) wrote :
Pilot6 (hanipouspilot) wrote :

I built a dkms module based on lwfinger. It it will install on new kernels.
Install it by

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtl8723au-bt-dkms

Yung Shen (kaxing) on 2015-09-16
Changed in linux-lts-vivid (Ubuntu):
status: New → Confirmed
no longer affects: linux-lts-vivid (Ubuntu)
Arman (arman-yazdani-10) wrote :

I tried
https://github.com/lwfinger/rtlwifi_new
and
https://github.com/lwfinger/rtl8723au_bt/tree/troy
Now the problem is solved
ubuntu 15.04
RTL8723BE

Fredrik Jacobsson (smask) wrote :

The device works here, but I get:

lappy2 kernel: [340105.430341] Bluetooth: hci0 ACL packet for unknown connection x (where x is one of 1 to 12)

And it takes a couple of minutes of clicking on the mouse until I get some response on the screen. I'm running Wily at the moment (kernel 4.2.0-11). When the mouse or the device goes to sleep kernel loses the connection and then notices that something is sending packages but it won't do anything about it.

Gabriel Zhi Chen, please execute the following command only once, as it will automatically gather debugging information, in a terminal:
apport-collect 1433987

affects: linux-lts-utopic (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marc 1761 F.... pulseaudio
 /dev/snd/controlC1: marc 1761 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 15.04
InstallationDate: Installed on 2015-04-22 (249 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
MachineType: LENOVO F0AU009MGE
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-25-generic.efi.signed root=UUID=c31f46ea-1fd7-40f2-82a4-80a675eef272 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.19.0-25.26-generic 3.19.8-ckt2
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-25-generic N/A
 linux-backports-modules-3.19.0-25-generic N/A
 linux-firmware 1.143.2
Tags: vivid
UdevLog: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/log/udev'
Uname: Linux 3.19.0-25-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm lpadmin sambashare sudo
_MarkForUpload: True
dmi.bios.date: 10/22/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: O0BKT18AUS
dmi.board.name: HASWELLREFRESHDT
dmi.board.vendor: LENOVO
dmi.board.version: 31900058 STD
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnLENOVO:bvrO0BKT18AUS:bd10/22/2014:svnLENOVO:pnF0AU009MGE:pvrLenovoB50-30:rvnLENOVO:rnHASWELLREFRESHDT:rvr31900058STD:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: F0AU009MGE
dmi.product.version: Lenovo B50-30
dmi.sys.vendor: LENOVO

tags: added: apport-collected vivid

Marc Nieper-Wißkirchen, it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please read https://wiki.ubuntu.com/ReportingBugs.

tags: added: trust
removed: apport-collected trusty vivid
Liming Wang (wangliming) on 2017-04-12
Changed in hwe-next:
assignee: Liming Wang (wangliming) → nobody
Changed in hwe-next:
status: Confirmed → Won't Fix
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers