xgene-enet: doesn't work at 100Mbit

Bug #1433290 reported by dann frazier on 2015-03-17
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
dann frazier
Craig Magina
Craig Magina
dann frazier

Bug Description

The onboard NICs on APM Mustang boards don't work when connected to a 100MBit switch.

[Test Case]
1) Connect onboard NIC of a Mustang to a 100Mbit switch. I reproduced with both a Linksys WRT54GL and an old unmanaged Netgear switch.
2) Try to use it (e.g. dhclient)

[Regression Risk]
The fix is restricted to the xgene_enet driver, which limits the regression exposure to APM X-Gene systems.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1433290

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.0 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-rc4-vivid/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
dann frazier (dannf) on 2015-06-20
Changed in linux (Ubuntu):
status: Expired → Confirmed
Andy Johnson (andy-johnson-m) wrote :

I have been going around and around trying to get Ubuntu on Mustang to connect to the network, and have been unable to do so.

I have configured the system to use DHCP, but it doesn’t get an IP address assigned.
I have configured the system with a static IP (the same one that I used to boot up OpenEmbedded, and to do the download and install of Ubuntu), but it is unable to see any other systems on the same subnet.
I have configured the system with a peer-to-peer connection with a desktop system, assigning IP addresses to the desktop, and to the Mustang board, but the two systems are unable to see each other. I have verified that another computer connected to the desktop with the same cable was able to ping the desktop, and that the desktop could ping the other computer.

I have also been corresponding with someone at Linaro Support, sending him log files, and he made this comment:
• The kernel is definitively seeing network traffic on the card (otherwise libpcap wouldnt be able to feed the data to tcpdump) so I dont think it is a problem with the drivers or hardware. It might be a configuration option that I am not aware of.

Does anyone have any clue why this system won’t connect to the network, or even acknowledge that there is a viable connection?

Andy Johnson (andy-johnson-m) wrote :

By moving the Mustang box into a lab that had a gigibit connection, it immediately connected with the network. It's surprising that the network worked just fine on a 100Kb connection when running tftpboot and when installing Ubuntu, but not when running Ubuntu. This looks like a limitation in the Ubuntu 14.04 driver for aarch64, not with the Mustang box itself. It's just too bad that this limitation isn't documented anywhere, other than this bug report.

Iyappan Subramanian (isubrama) wrote :

Fix posted and applied on the net tree. Can you please try the patch ?

On Sun, Nov 8, 2015 at 7:57 PM, Iyappan Subramanian
<email address hidden> wrote:
> Fix posted and applied on the net tree. Can you please try the patch ?
> http://www.spinics.net/lists/netdev/msg351594.html

I backported this to wily's 4.2 kernel, and verified that it does
resolve the issue.


description: updated
dann frazier (dannf) on 2015-11-10
Changed in linux (Ubuntu):
assignee: nobody → dann frazier (dannf)
dann frazier (dannf) on 2015-11-13
Changed in linux (Ubuntu Wily):
status: New → Fix Committed
assignee: nobody → dann frazier (dannf)
Changed in linux (Ubuntu Vivid):
assignee: nobody → Craig Magina (craig.magina)
Changed in linux (Ubuntu Trusty):
assignee: nobody → Craig Magina (craig.magina)
Changed in linux (Ubuntu Vivid):
status: New → Confirmed
Changed in linux (Ubuntu Trusty):
status: New → Confirmed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-wily' to 'verification-done-wily'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-wily
dann frazier (dannf) on 2015-12-09
tags: added: verification-done-wily
removed: verification-needed-wily
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.2.0-21.25

linux (4.2.0-21.25) wily; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1522108

  [ Upstream Kernel Changes ]

  * staging/dgnc: fix info leak in ioctl
    - LP: #1509565
    - CVE-2015-7885
  * [media] media/vivid-osd: fix info leak in ioctl
    - LP: #1509564
    - CVE-2015-7884
  * KEYS: Fix race between key destruction and finding a keyring by name
    - LP: #1508856
    - CVE-2015-7872
  * KEYS: Fix crash when attempt to garbage collect an uninstantiated
    - LP: #1508856
    - CVE-2015-7872
  * KEYS: Don't permit request_key() to construct a new keyring
    - LP: #1508856
    - CVE-2015-7872
  * isdn_ppp: Add checks for allocation failure in isdn_ppp_open()
    - LP: #1508329
    - CVE-2015-7799
  * ppp, slip: Validate VJ compression slot parameters completely
    - LP: #1508329
    - CVE-2015-7799

linux (4.2.0-20.24) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1521753

  [ Andy Whitcroft ]

  * [Tests] gcc-multilib does not exist on ppc64el
    - LP: #1515541

  [ Joseph Salisbury ]

  * SAUCE: scsi_sysfs: protect against double execution of
    - LP: #1509029

  [ Manoj Kumar ]

  * SAUCE: (noup) cxlflash: Fix to escalate LINK_RESET also on port 1
    - LP: #1513583

  [ Matthew R. Ochs ]

  * SAUCE: (noup) cxlflash: Fix to avoid virtual LUN failover failure
    - LP: #1513583

  [ Oren Givon ]

  * SAUCE: (noup) iwlwifi: Add new PCI IDs for the 8260 series
    - LP: #1517375

  [ Seth Forshee ]

    - LP: #1510405

  [ Upstream Kernel Changes ]

  * net/mlx5e: Disable VLAN filter in promiscuous mode
    - LP: #1514861
  * drivers: net: xgene: fix RGMII 10/100Mb mode
    - LP: #1433290
  * HID: rmi: Disable scanning if the device is not a wake source
    - LP: #1515503
  * HID: rmi: Set F01 interrupt enable register when not set
    - LP: #1515503
  * net/mlx5e: Ethtool link speed setting fixes
    - LP: #1517919
  * scsi_scan: don't dump trace when scsi_prep_async_scan() is called twice
    - LP: #1517942
  * x86/ioapic: Disable interrupts when re-routing legacy IRQs
    - LP: #1508593
  * xhci: Workaround to get Intel xHCI reset working more reliably
  * megaraid_sas: Do not use PAGE_SIZE for max_sectors
    - LP: #1475166
  * net: usb: cdc_ether: add Dell DW5580 as a mobile broadband adapter
    - LP: #1513847
  * KVM: svm: unconditionally intercept #DB
    - LP: #1520184
    - CVE-2015-8104

 -- Luis Henriques <email address hidden> Wed, 02 Dec 2015 17:30:58 +0000

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released

This bug was nominated against a series that is no longer supported, ie vivid. The bug task representing the vivid nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Vivid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers