ppc64el: Need fix for exported OPAL functions

Bug #1431196 reported by Benjamin Herrenschmidt
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Utopic
Medium
Chris J Arges

Bug Description

SRU Justification:

[Impact]
Using the i2c-opal backported driver with Ubuntu 3.16 will cause an oops.

[Test Case]
Use the i2c-opal module on 3.16 w/ i2c-opal backported patches. See bug 1419151.

[Fix]
19d36c2152aaf093c97431b5b4d13d29305a63a3

--

Please backport 19d36c2152aaf093c97431b5b4d13d29305a63a3 "powernv: Use _GLOBAL_TOC for opal wrappers"
to 3.16.x otherwise bad things happen when using the already backported i2c-opal kernel module due to a problem
with exporting OPAL kernel interfaces that this commit fixes.

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1431196

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Benjamin Herrenschmidt (benh-kernel) wrote :

Example of bad thing:

[ 95.307704] Oops: Exception in kernel mode, sig: 4 [#1]
[ 95.307869] SMP NR_CPUS=2048 NUMA PowerNV
[ 95.307923] Modules linked in: i2c_dev bnep rfcomm bluetooth 6lowpan_iphc joydev mac_hid ast ttm hid_generic drm_kms_helper usbhid drm hid syscopyarea at24 sysfillrect sysimgblt i2c_algo_bit uio_pdrv_genirq uio rtc_generic i2c_opal powernv_rng parport_pc ppdev lp parport mlx4_en vxlan uas usb_storage mlx4_core ahci libahci
[ 95.308294] CPU: 1 PID: 3017 Comm: test-i2c Not tainted 3.16.0-32-generic #42
[ 95.308346] task: c00000077fd35200 ti: c00000077fdbc000 task.ti: c00000077fdbc000
[ 95.308399] NIP: c0000007fe0b7c44 LR: 0000000000000000 CTR: c00000000006e86f
[ 95.308451] REGS: c00000077fdbf7a0 TRAP: 0e40 Not tainted (3.16.0-32-generic)
[ 95.308502] MSR: 9000000000081002 <SF,HV,ME,RI> CR: 28000022 XER: 00000000
[ 95.308599] CFAR: d00000000fcd08bc SOFTE: 1
GPR00: 000000000000006d c00000077fdbfa20 c0000007fe0c4948 0000000000000000
GPR04: 0000000000000001 c00000077fdbfb10 0000000000000000 0000000000000000
GPR08: 0000000000000000 0000000000000000 0000000000000000 c0000007fe0b7c38
GPR12: c0000007fe0b7c40 c00000000fb80900 0000000000000000 0000000000000000
GPR16: 0000000000000000 0000000000000000 0000000000000000 0000000000000000
GPR20: 0000000000000000 0000000000000000 0000000000000000 0000000000000000
GPR24: 0000000000000000 00000000ffff3819 0000000000000002 c000000784a20690
GPR28: c000000001422180 0000000000000001 0000000000000000 c00000077fdbfb10
[ 95.309272] NIP [c0000007fe0b7c44] 0xc0000007fe0b7c44
[ 95.309308] LR [0000000000000000] (null)
[ 95.309342] Call Trace:
[ 95.309364] [c00000077fdbfa20] [d00000000fcd00e0] i2c_opal_send_request+0x50/0x120 [i2c_opal] (unreliable)
[ 95.309435] [c00000077fdbfaf0] [d00000000fcd0500] i2c_opal_master_xfer+0xd0/0x1d0 [i2c_opal]
[ 95.309498] [c00000077fdbfb50] [c0000000007efd44] __i2c_transfer+0xb4/0x350
[ 95.309551] [c00000077fdbfbb0] [c0000000007f3b28] i2c_transfer+0xc8/0x160
[ 95.309604] [c00000077fdbfc30] [d0000000151906b0] i2cdev_ioctl_rdrw+0x180/0x340 [i2c_dev]
[ 95.309665] [c00000077fdbfcb0] [d000000015190dcc] i2cdev_ioctl+0x24c/0x370 [i2c_dev]
[ 95.309732] [c00000077fdbfd40] [c0000000002c9940] do_vfs_ioctl+0x470/0x780
[ 95.309786] [c00000077fdbfde0] [c0000000002c9d24] SyS_ioctl+0xd4/0xf0
[ 95.309839] [c00000077fdbfe30] [c00000000000a17c] syscall_exit+0x0/0x7c

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Chris J Arges (arges) wrote :

$ git describe --contains 19d36c2152aaf093c97431b5b4d13d29305a63a3
v3.18-rc3~35^2~7

Changed in linux (Ubuntu Utopic):
assignee: nobody → Chris J Arges (arges)
description: updated
Revision history for this message
Chris J Arges (arges) wrote :

Sent SRU for Utopic.

Revision history for this message
Andy Whitcroft (apw) wrote :

Confirmed this was applied to mainline in the versions in vivid.

Changed in linux (Ubuntu Utopic):
status: New → Fix Committed
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Utopic):
importance: Undecided → Medium
Changed in linux (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Andy Whitcroft (apw)
Revision history for this message
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-utopic' to 'verification-done-utopic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-utopic
Revision history for this message
Chris J Arges (arges) wrote :

Email from Benh verified this bug.

tags: added: verification-done-utopic
removed: verification-needed-utopic
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (15.4 KiB)

This bug was fixed in the package linux - 3.16.0-34.45

---------------
linux (3.16.0-34.45) utopic; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1435400

  [ Andy Whitcroft ]

  * [Packaging] generate live watchdog blacklists
    - LP: #1432837

  [ Chris J Arges ]

  * [Config] Add ibmvfc to d-i
    - LP: #1416001

  [ John Johansen ]

  * SAUCE: (no-up): apparmor: fix mediation of fs unix sockets
    - LP: #1408833

  [ Seth Forshee ]

  * [Config] updateconfigs - enable X86_UP_APIC_MSI

  [ Upstream Kernel Changes ]

  * cdc-acm: add sanity checks
    - LP: #1413992
  * x86: thinkpad_acpi.c: fixed spacing coding style issue
    - LP: #1417915
  * thinkpad_acpi: support new BIOS version string pattern
    - LP: #1417915
  * powernv: Use _GLOBAL_TOC for opal wrappers
    - LP: #1431196
  * Btrfs: clear compress-force when remounting with compress option
    - LP: #1434183
  * Btrfs: send, don't delay dir move if there's a new parent inode
    - LP: #1434223
  * [media] em28xx: fix em28xx-input removal
    - LP: #1434595
  * [media] em28xx: ensure "closing" messages terminate with a newline
    - LP: #1434595
  * [media] em28xx-input: fix missing newlines
    - LP: #1434595
  * [media] em28xx-core: fix missing newlines
    - LP: #1434595
  * [media] em28xx-audio: fix missing newlines
    - LP: #1434595
  * [media] em28xx-audio: fix missing newlines
    - LP: #1434595
  * [media] em28xx-dvb: fix missing newlines
    - LP: #1434595
  * [media] em28xx-video: fix missing newlines
    - LP: #1434595
  * ARM: pxa: add regulator_has_full_constraints to corgi board file
    - LP: #1434595
  * ARM: pxa: add regulator_has_full_constraints to poodle board file
    - LP: #1434595
  * ARM: pxa: add regulator_has_full_constraints to spitz board file
    - LP: #1434595
  * hx4700: regulator: declare full constraints
    - LP: #1434595
  * HID: input: fix confusion on conflicting mappings
    - LP: #1434595
  * HID: fixup the conflicting keyboard mappings quirk
    - LP: #1434595
  * ARM: dts: tegra20: fix GR3D, DSI unit and reg base addresses
    - LP: #1434595
  * megaraid_sas: disable interrupt_mask before enabling hardware
    interrupts
    - LP: #1434595
  * PCI: Generate uppercase hex for modalias var in uevent
    - LP: #1434595
  * usb: core: buffer: smallest buffer should start at ARCH_DMA_MINALIGN
    - LP: #1434595
  * tty/serial: at91: enable peripheral clock before accessing I/O
    registers
    - LP: #1434595
  * tty/serial: at91: fix error handling in atmel_serial_probe()
    - LP: #1434595
  * axonram: Fix bug in direct_access
    - LP: #1434595
  * btrfs: fix leak of path in btrfs_find_item
    - LP: #1434595
  * ksoftirqd: Enable IRQs and call cond_resched() before poking RCU
    - LP: #1434595
  * TPM: Add new TPMs to the tail of the list to prevent inadvertent change
    of dev
    - LP: #1434595
  * char: tpm: Add missing error check for devm_kzalloc
    - LP: #1434595
  * tpm_tis: verify interrupt during init
    - LP: #1434595
  * tpm: Fix NULL return in tpm_ibmvtpm_get_desired_dma
    - LP: #1434595
  * tpm/tpm_i2c_stm_st33: Fix potential bug in tpm_stm_i2c_send
    - LP: #1434595
  * tpm/tpm_i2c_stm_st33:...

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers