pci driver messages - BAR 13: no space for

Bug #1426216 reported by bugproxy on 2015-02-27
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

---Problem Description---
pci driver messages - BAR 13: no space for

---uname output---
3.18.0-12-generic

Machine Type = POWER8

---Steps to Reproduce---
Install Ubuntu 15.04 daily build running bare-metal
After the installation following messages are seen in dmesg.
Not sure if these indicate a problem. Can some one look at these and confirm if this is problem or can be ignored ?

Messages from dmesg log

[ 0.714476] pci_bus 0001:00: max bus depth: 3 pci_try_num: 4
[ 0.714519] pci 0001:04:00.0: reg 0x16c: [mem 0x00000000-0x0000ffff 64bit]
[ 0.714541] pci 0001:04:00.0: reg 0x174: [mem 0x00000000-0x0000ffff 64bit]
[ 0.714577] pci 0001:00:00.0: BAR 15: assigned [mem 0x3b1010000000-0x3b103fffffff 64bit pref]
[ 0.714579] pci 0001:00:00.0: BAR 14: assigned [mem 0x3fe080000000-0x3fe081ffffff]
[ 0.714581] pci 0001:00:00.0: BAR 13: no space for [io size 0x3000]
[ 0.714583] pci 0001:00:00.0: BAR 13: failed to assign [io size 0x3000]
[ 0.714586] pci 0001:01:00.0: BAR 15: assigned [mem 0x3b1010000000-0x3b103fffffff 64bit pref]
[ 0.714588] pci 0001:01:00.0: BAR 14: assigned [mem 0x3fe080000000-0x3fe0817fffff]
[ 0.714590] pci 0001:01:00.0: BAR 0: assigned [mem 0x3fe081800000-0x3fe08183ffff]
[ 0.714595] pci 0001:01:00.0: BAR 13: no space for [io size 0x3000]
[ 0.714597] pci 0001:01:00.0: BAR 13: failed to assign [io size 0x3000]
[ 0.714600] pci 0001:02:01.0: BAR 15: assigned [mem 0x3b1010000000-0x3b101fffffff 64bit pref]
[ 0.714602] pci 0001:02:08.0: BAR 15: assigned [mem 0x3b1020000000-0x3b102fffffff 64bit pref]
[ 0.714604] pci 0001:02:09.0: BAR 15: assigned [mem 0x3b1030000000-0x3b103fffffff 64bit pref]
[ 0.714606] pci 0001:02:01.0: BAR 14: assigned [mem 0x3fe080000000-0x3fe0807fffff]
[ 0.714608] pci 0001:02:08.0: BAR 14: assigned [mem 0x3fe080800000-0x3fe080ffffff]
[ 0.714609] pci 0001:02:09.0: BAR 14: assigned [mem 0x3fe081000000-0x3fe0817fffff]
[ 0.714611] pci 0001:02:01.0: BAR 13: no space for [io size 0x1000]
[ 0.714613] pci 0001:02:01.0: BAR 13: failed to assign [io size 0x1000]
[ 0.714614] pci 0001:02:08.0: BAR 13: no space for [io size 0x1000]
[ 0.714616] pci 0001:02:08.0: BAR 13: failed to assign [io size 0x1000]
[ 0.714618] pci 0001:02:09.0: BAR 13: no space for [io size 0x1000]
[ 0.714619] pci 0001:02:09.0: BAR 13: failed to assign [io size 0x1000]
[ 0.714622] pci 0001:03:00.0: BAR 6: assigned [mem 0x3fe080000000-0x3fe08003ffff pref]
[ 0.714624] pci 0001:03:00.1: BAR 6: assigned [mem 0x3fe080040000-0x3fe08007ffff pref]
[ 0.714627] pci 0001:03:00.0: BAR 2: assigned [mem 0x3fe080080000-0x3fe080083fff 64bit]
[ 0.714641] pci 0001:03:00.1: BAR 2: assigned [mem 0x3fe080084000-0x3fe080087fff 64bit]
[ 0.714656] pci 0001:03:00.0: BAR 0: assigned [mem 0x3fe080088000-0x3fe080088fff 64bit]
[ 0.714670] pci 0001:03:00.1: BAR 0: assigned [mem 0x3fe080089000-0x3fe080089fff 64bit]
[ 0.714685] pci 0001:03:00.0: BAR 4: no space for [io size 0x0100]
[ 0.714686] pci 0001:03:00.0: BAR 4: failed to assign [io size 0x0100]
[ 0.714688] pci 0001:03:00.1: BAR 4: no space for [io size 0x0100]
[ 0.714690] pci 0001:03:00.1: BAR 4: failed to assign [io size 0x0100]
[ 0.714691] pci 0001:02:01.0: PCI bridge to [bus 03]

# lspci
0000:00:00.0 PCI bridge: IBM Device 03dc
0001:00:00.0 PCI bridge: IBM Device 03dc
0001:01:00.0 PCI bridge: PLX Technology, Inc. PEX 8732 32-lane, 8-Port PCI Express Gen 3 (8.0 GT/s) Switch (rev ca)
0001:02:01.0 PCI bridge: PLX Technology, Inc. PEX 8732 32-lane, 8-Port PCI Express Gen 3 (8.0 GT/s) Switch (rev ca)
0001:02:08.0 PCI bridge: PLX Technology, Inc. PEX 8732 32-lane, 8-Port PCI Express Gen 3 (8.0 GT/s) Switch (rev ca)
0001:02:09.0 PCI bridge: PLX Technology, Inc. PEX 8732 32-lane, 8-Port PCI Express Gen 3 (8.0 GT/s) Switch (rev ca)
0001:03:00.0 Fibre Channel: Emulex Corporation Saturn-X: LightPulse Fibre Channel Host Adapter (rev 03)
0001:03:00.1 Fibre Channel: Emulex Corporation Saturn-X: LightPulse Fibre Channel Host Adapter (rev 03)
0001:04:00.0 RAID bus controller: IBM PCI-E IPR SAS Adapter (ASIC) (rev 01)
0002:00:00.0 PCI bridge: IBM Device 03dc
0003:00:00.0 PCI bridge: IBM Device 03dc
0003:01:00.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:01.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:08.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:09.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:10.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:11.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:03:00.0 USB controller: Texas Instruments TUSB73x0 SuperSpeed USB 3.0 xHCI Host Controller (rev 02)
0003:09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
0003:09:00.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
0003:09:00.2 Ethernet controller: Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
0003:09:00.3 Ethernet controller: Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
0004:00:00.0 PCI bridge: IBM Device 03dc
0005:00:00.0 PCI bridge: IBM Device 03dc
0006:00:00.0 PCI bridge: IBM Device 03dc

bugproxy (bugproxy) wrote : dmesg log

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-121422 severity-high targetmilestone-inin---

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1426216/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)
tags: added: kernel-da-key

This appears to have been originally reported against a 3.18 based kernel. We've since released 15.04 with a v3.19 based kernel. I'd be interested to know if this is still an issue. I'll ask one of my engineers with access to a Power8 system to see if they are able to reproduce with our 15.04 release kernel. Thanks.

bugproxy (bugproxy) wrote :

Default Comment by Bridge

bugproxy (bugproxy) wrote :

Default Comment by Bridge

tags: added: severity-low
removed: severity-high
Chris J Arges (arges) on 2015-05-14
Changed in linux (Ubuntu):
assignee: nobody → Chris J Arges (arges)
bugproxy (bugproxy) wrote :

Default Comment by Bridge

Chris J Arges (arges) wrote :

This issue also happens with a v4.1-rc3 kernel.

Code in drivers/pci/setup-res.c:

        /*
         * If we failed to assign anything, let's try the address
         * where firmware left it. That at least has a chance of
         * working, which is better than just leaving it disabled.
         */
        if (ret < 0) {
                dev_info(&dev->dev, "BAR %d: no space for %pR\n", resno, res);
                ret = pci_revert_fw_address(res, dev, resno, size);
        }

        if (ret < 0) {
                dev_info(&dev->dev, "BAR %d: failed to assign %pR\n", resno,
                         res);
                return ret;
        }

If we do the following we can see which PCI ids failed:

 for i in $(dmesg | grep 'BAR 13: failed' | awk '{print $4}' | uniq | sort | uniq); do lspci | grep ${i%%:}; done

0001:00:00.0 PCI bridge: IBM Device 03dc
0001:01:00.0 PCI bridge: PLX Technology, Inc. PEX 8732 32-lane, 8-Port PCI Express Gen 3 (8.0 GT/s) Switch (rev ca)
0001:02:01.0 PCI bridge: PLX Technology, Inc. PEX 8732 32-lane, 8-Port PCI Express Gen 3 (8.0 GT/s) Switch (rev ca)
0001:02:08.0 PCI bridge: PLX Technology, Inc. PEX 8732 32-lane, 8-Port PCI Express Gen 3 (8.0 GT/s) Switch (rev ca)
0001:02:09.0 PCI bridge: PLX Technology, Inc. PEX 8732 32-lane, 8-Port PCI Express Gen 3 (8.0 GT/s) Switch (rev ca)
0003:00:00.0 PCI bridge: IBM Device 03dc
0003:01:00.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:08.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:09.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:10.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)
0003:02:11.0 PCI bridge: PLX Technology, Inc. Device 8748 (rev ca)

However we see all other BAR #'s allocate with no issues. It only seems to be 13 that fails.

bugproxy (bugproxy) wrote :

Default Comment by Bridge

Chris J Arges (arges) on 2015-05-14
Changed in linux (Ubuntu):
assignee: Chris J Arges (arges) → nobody
bugproxy (bugproxy) wrote :

Default Comment by Bridge

------- Comment From <email address hidden> 2015-05-15 06:12 EDT-------
(In reply to comment #9)
> This appears to have been originally reported against a 3.18 based kernel.
> We've since released 15.04 with a v3.19 based kernel. I'd be interested to
> know if this is still an issue. I'll ask one of my engineers with access to
> a Power8 system to see if they are able to reproduce with our 15.04 release
> kernel. Thanks.

This can be recreated with 15.04 GA image as well.

Default Comment by Bridge

Chris J Arges (arges) on 2015-06-10
Changed in linux (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

------- Comment From <email address hidden> 2015-06-16 21:21 EDT-------
The PHB3 PCIe host bridge in Power8 does not support generating IO space transactions / cycles, so no IO window is assigned to the PCI bus and all IO space resources will be unassigned and must remain disabled in the pci command register. (Previous bridges in most PowerPC systems provided a memory mapped window that generates IO cycles but that function was not implemented in Power8.)

Chris J Arges (arges) wrote :

Should be marked Invalid?

bugproxy (bugproxy) on 2015-09-17
Changed in linux (Ubuntu):
assignee: nobody → Taco Screen team (taco-screen-team)
Luciano Chavez (lnx1138) wrote :

Doing cleanup and marking bug as Invalid as it was.

Changed in linux (Ubuntu):
status: Confirmed → Invalid

I have the same problem - on a 2018 Thinkpad with integrated Intel graphics.

jnns (jnns) wrote :

Same issue occurs to me on a Thinkpad X1 Carbon 2018 (6th Gen.)

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
tomdean (tomdean) wrote :
Download full text (3.2 KiB)

This happens on my system.

Meerkat> uname -a
Linux Meerkat 5.0.0-23-generic #24~18.04.1-Ubuntu SMP Mon Jul 29 16:12:28 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Meerkat> lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

BIOS is up-to-date

Meerkat> sudo dmidecode
<snip>
BIOS Information
 Vendor: Intel Corp.
 Version: BNKBL357.86A.0069.2018.0920.1250
 Release Date: 09/20/2018
<snip>

Meerkat> dmesg | tail -20
[ 117.574049] pcieport 0000:01:00.0: BAR 13: failed to assign [io size 0x3000]
[ 117.574050] pcieport 0000:01:00.0: BAR 13: no space for [io size 0x3000]
[ 117.574051] pcieport 0000:01:00.0: BAR 13: failed to assign [io size 0x3000]
[ 117.574055] pcieport 0000:02:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[ 117.574056] pcieport 0000:02:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[ 117.574057] pcieport 0000:02:01.0: BAR 13: no space for [io size 0x1000]
[ 117.574057] pcieport 0000:02:01.0: BAR 13: failed to assign [io size 0x1000]
[ 117.574058] pcieport 0000:02:02.0: BAR 13: no space for [io size 0x1000]
[ 117.574059] pcieport 0000:02:02.0: BAR 13: failed to assign [io size 0x1000]
[ 117.574061] pcieport 0000:02:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[ 117.574062] pcieport 0000:02:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[ 117.574063] pcieport 0000:02:02.0: BAR 13: no space for [io size 0x1000]
[ 117.574063] pcieport 0000:02:02.0: BAR 13: failed to assign [io size 0x1000]
[ 117.574064] pcieport 0000:02:01.0: BAR 13: no space for [io size 0x1000]
[ 117.574065] pcieport 0000:02:01.0: BAR 13: failed to assign [io size 0x1000]
[ 122.022075] pcieport 0000:02:00.0: Refused to change power state, currently in D3
[ 122.051009] pci_bus 0000:03: busn_res: [bus 03] is released
[ 122.051213] pci_bus 0000:04: busn_res: [bus 04-38] is released
[ 122.051378] pci_bus 0000:39: busn_res: [bus 39] is released
[ 122.051462] pci_bus 0000:02: busn_res: [bus 02-39] is released

Meerkat> sudo lspci -t
-[0000:00]-+-00.0
           +-02.0
           +-08.0
           +-14.0
           +-14.2
           +-16.0
           +-17.0
           +-1c.0-[01-39]--
           +-1c.5-[3a]----00.0
           +-1c.7-[3b]----00.0
           +-1d.0-[3c]----00.0
           +-1f.0
           +-1f.2
           +-1f.3
           +-1f.4
           \-1f.6

Meerkat> sudo lspci -v -nn -s 0000:001c.0
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 [8086:9d10] (rev f1) (prog-if 00 [Normal decode])
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Bus: primary=00, secondary=01, subordinate=39, sec-latency=0
 I/O behind bridge: 00002000-00002fff
 Memory behind bridge: c4000000-da0fffff
 Prefetchable memory behind bridge: 00000000a0000000-00000000c1ffffff
 Capabilities: [40] Express Root Port (Slot+), MSI 00
 Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [90] Subsystem: Intel Corporation Sunrise Point-LP PCI Express Root Port [8086:2068]
 Capabilities: [a0] Power Management version 3
 Capabilities: [100] Advanced Error Reporting
 Capa...

Read more...

tomdean (tomdean) on 2019-08-08
Changed in linux (Ubuntu):
status: Invalid → Confirmed
Andrew Cloke (andrew-cloke) wrote :

Removing currently assigned team, as this issue is now being seen with Intel systems.

Changed in linux (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → nobody
gst (g-starck) wrote :

Hi,

I am also impacted. 18.04 with 5.0 and 4.15 kernels.

My system also freezes from time to time.

```
[ 171.384150] pci_bus 0000:03: Allocating resources
[ 171.384173] pcieport 0000:03:01.0: bridge window [io 0x1000-0x0fff] to [bus 05-39] add_size 1000
[ 171.384181] pcieport 0000:03:02.0: bridge window [io 0x1000-0x0fff] to [bus 3a] add_size 1000
[ 171.384182] pcieport 0000:03:02.0: bridge window [mem 0x00100000-0x000fffff 64bit pref] to [bus 3a] add_size 200000 add_align 100000
[ 171.384190] pcieport 0000:02:00.0: bridge window [io 0x1000-0x0fff] to [bus 03-3a] add_size 3000
[ 171.384192] pcieport 0000:02:00.0: BAR 13: no space for [io size 0x3000]
[ 171.384193] pcieport 0000:02:00.0: BAR 13: failed to assign [io size 0x3000]
[ 171.384194] pcieport 0000:02:00.0: BAR 13: no space for [io size 0x3000]
[ 171.384194] pcieport 0000:02:00.0: BAR 13: failed to assign [io size 0x3000]
[ 171.384196] pcieport 0000:03:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[ 171.384197] pcieport 0000:03:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[ 171.384198] pcieport 0000:03:01.0: BAR 13: no space for [io size 0x1000]
[ 171.384198] pcieport 0000:03:01.0: BAR 13: failed to assign [io size 0x1000]
[ 171.384199] pcieport 0000:03:02.0: BAR 13: no space for [io size 0x1000]
[ 171.384200] pcieport 0000:03:02.0: BAR 13: failed to assign [io size 0x1000]
[ 171.384201] pcieport 0000:03:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[ 171.384201] pcieport 0000:03:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[ 171.384202] pcieport 0000:03:02.0: BAR 13: no space for [io size 0x1000]
[ 171.384203] pcieport 0000:03:02.0: BAR 13: failed to assign [io size 0x1000]
[ 171.384203] pcieport 0000:03:01.0: BAR 13: no space for [io size 0x1000]
[ 171.384204] pcieport 0000:03:01.0: BAR 13: failed to assign [io size 0x1000]
[ 176.033220] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=12148 end=12149) time 3562 us, min 1073, max 1079, scanline start 1071, end 192
[ 176.486807] pcieport 0000:03:00.0: Refused to change power state, currently in D3
[ 176.556903] pci_bus 0000:04: busn_res: [bus 04] is released
[ 176.556962] pci_bus 0000:05: busn_res: [bus 05-39] is released
[ 176.557053] pci_bus 0000:3a: busn_res: [bus 3a] is released
[ 176.557161] pci_bus 0000:03: busn_res: [bus 03-3a] is released
```

I have also quite lot of :

[drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=12148 end=12149) time 3562 us, min 1073, max 1079, scanline start 1071, end 192

Not sure if related. I can give more details if requested.

Michael (jakutenshi) wrote :

Also have a problem with instant freeze to hardreset with the same problems in dmesg and hardware thinkpad t480. Also there is xchi problem, but it seems as secondary.

The suddenly hardreset issue is a big problem. If I can help community to solve it, if I should give more information than dmesg log -- please notice me.

Kostanos (kostanos) wrote :

Same problem on Lenovo Ideapad 720S Touch-15IKB. Ubuntu 20.04, fresh install. Let me know how can I help with it.

Alex B (alexbe) wrote :

Same messages about BAR13 and BAR15 in dmesg with Razer Blade 2016, Ubuntu 20.04.1. Also available to help.

jz (syed-zaib) wrote :

I am also affected on ubuntu 18.04 on Lenovo T580 with Intel Corporation UHD Graphics 620 (rev 07

.....

[ 769.951164] pcieport 0000:07:00.0: BAR 13: no space for [io size 0x3000]
[ 769.951165] pcieport 0000:07:00.0: BAR 13: failed to assign [io size 0x3000]
[ 769.951167] pcieport 0000:07:00.0: BAR 13: no space for [io size 0x3000]
[ 769.951168] pcieport 0000:07:00.0: BAR 13: failed to assign [io size 0x3000]
[ 769.951171] pcieport 0000:08:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[ 769.951172] pcieport 0000:08:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]

....

Lucio Crusca (lucrus) wrote :

I'm on Debian sid with a T470 Thinkpad (Linux t470 5.8.0-1-amd64 #1 SMP Debian 5.8.7-1 (2020-09-05) x86_64 GNU/Linux) and this same bug affects me too. I know, my system is not Ubuntu, but I think it's important to let you know that this might be a problem with the upstream kernel code, as opposed to the Ubuntu or Debian packaged kernel. Maybe it's related to something Lenovo specific.

I have a Dell G7 7588

This is related to usb controllers post/resume

you can buy a hub, in my case typec model, so the error has gone

mouse and keyboard connected to the hub

one thing is that pen drive works without problem

Thanks

it is related to usb controllers

i have a dell g7 7588 model and i brought a typec hud and plugged into my thunderbolt port

to the hub i connected mouse|keyboard and rebooted machine

this error has gone

my usb port is 3.1, and bios is latest

with pendrive noerror

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers