[Acer Extensa 5620Z] Supend/Resume fail (reboots)

Bug #1420839 reported by Joan CiberSheep on 2015-02-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have observed that
 - From terminal: pm-suspend, pressed space bar, resumes (no lock screen)
 - From GUI: supend, pressed space bar, resumes (lock screen)
Resumed several times.

Open non maximed window
From terminal or GUI: power button lights, screen stil black and computer reboots.

Same result with live usb from http://cdimage.ubuntu.com/daily-live/current/

WORKAROUND: Use hibernate.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-45-lowlatency 3.13.0-45.74
ProcVersionSignature: Ubuntu 3.13.0-45.74-lowlatency 3.13.11-ckt13
Uname: Linux 3.13.0-45-lowlatency x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cibersheep 3526 F.... pulseaudio
 /dev/snd/pcmC0D0p: cibersheep 3526 F...m pulseaudio
CurrentDesktop: Unity
Date: Wed Feb 11 15:49:44 2015
HibernationDevice: RESUME=UUID=bb3a9a00-984d-4934-9f85-bae95a4d7c40
InstallationDate: Installed on 2014-05-06 (281 days ago)
InstallationMedia: Ubuntu-Studio 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.3)
MachineType: Acer Extensa 5620
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-45-lowlatency root=UUID=4cb2e1b9-df42-4558-9ae6-45e120748cb6 ro splash quiet vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-45-lowlatency N/A
 linux-backports-modules-3.13.0-45-lowlatency N/A
 linux-firmware 1.127.11
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/03/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.35
dmi.board.name: Columbia
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.asset.tag: None
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.35:bd07/03/2008:svnAcer:pnExtensa5620:pvr0100:rvnAcer:rnColumbia:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Extensa 5620
dmi.product.version: 0100
dmi.sys.vendor: Acer

Joan CiberSheep (cibersheep) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.19 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.19-vivid/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Joan CiberSheep (cibersheep) wrote :

I have installed kernel 3.19 as requested.

Testing pm-suspend and GUI suspend gives a similar result but I couldn't see a pattern: sometimes reboots at first atempt to awake, sometimes resumes fine a couple of times.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joan CiberSheep (cibersheep) wrote :

What I have observed is that at boot comes up a message: "ACPI PCC probre failed"

tags: added: bios-outdated-1.35
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Joan CiberSheep (cibersheep) wrote :

Thank you for your comment, Christopher.

I confirm that I have had updated the BIOS before the behaviour of this report was observed therefore I change the status to confirmed as suggested.

Thanks you.

PS: the result of sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date is,
V1.35
07/03/2008

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: bios-outdated-1.35

Joan CiberSheep, could you please test for this with the latest mainline kernel 4.0-rc1 and advise to the results?

tags: added: latest-bios-1.35
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Joan CiberSheep (cibersheep) wrote :

These are the results:
 - kernel 4.0-rc1 doesn't boot
 - kernel 4.0-rc2 I have tried all the possibilities I could think of to suspend and resume. It works just great (good job).

Yes!

tags: added: kernel-fixed-upstream
removed: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Joan CiberSheep, the next step is to fully reverse commit bisect from kernel 3.19 to 4.0-rc2 in order to identify the last bad commit, followed immediately by the first good one. Once this commit has been identified, then it may be reviewed as a candidate for backporting into your release. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: kernel-fixed-upstream-4.0-rc2 needs-reverse-bisect
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Joan CiberSheep (cibersheep) wrote :

Ok. I see this step is going to take me a bit of reading first.
I'll do it as soon as I have a moment.

Thank you so much.

Joan CiberSheep (cibersheep) wrote :

Hello again, Christopher.

This is the result of the reverse bisect:
44d84d7272e5848878a96029b8a8b6e86854f146 is the first bad commit

I attach the bisect log

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Joan CiberSheep, as a potential WORKAROUND, does hibernate work?

tags: added: reverse-bisect-done
removed: needs-reverse-bisect
tags: added: cherry-pick
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Joan CiberSheep (cibersheep) wrote :

Hi, Christopher.
I didn't test hibernate (I didn't think of it). I have test now with my actual kernel and with the two mainline kernels. Here are the results of pm-hibernate:

Current 3.13.0-46-lowlatency:
    - it works perfectly. No strange behaviour observed. So it can be used as a Workaround.

Mainline v3.19-vivid and Mainline v4.0-rc2: observed same behaviour:
    - When hibernates, screen goes black, screen goes on, harddisc work, screen goes black but power light shines on orange (normal colour is green) and flashes (exactly the same as if it would be suspended).
    - Pressing space bar or Power button gets no reactoin
    - Hold down Power button to switch off. Power on. Booting again restores back hibernated state normally (no crash message).
    - Halt and Shut down from menu works normal

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers