powerpc: backport AST graphic driver updates for OpenPower

Bug #1420627 reported by Benjamin Herrenschmidt on 2015-02-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Utopic
Medium
Joseph Salisbury

Bug Description

The OpenPower machines such as the Tyan dev board use the ASpeed BMC which has a built
in graphic controller. The driver for this doesn't work properly on PowerPC at the moment,
this series of patches is a backport from upstream to fix that. It would be nice to have this
in utopic kernel.

Each patch in this archive is a cherry-pick and identifies the original upstream commit.

All except patch 1 cherry-pick cleanly. Patch 1 needed some hand applying due to some
unrelated changes that went upstream since 3.16 but the fixup is trivial.

CVE References

Brad Figg (brad-figg) on 2015-02-11
affects: linux-meta (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1420627

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Can you attach the set of patches to this bug report or email them to the Ubuntu kernel team mailing list:

<email address hidden>

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key utopic
tags: added: patch
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Hrm, I though I had attached the archive, but I can't see it either now, I'll do it again

Changed in linux (Ubuntu Utopic):
status: New → Triaged
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux (Ubuntu Utopic):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

I applied these 8 patches to a Utopic tree and built a test kernel. The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1420627/

Is it possible for you to test this kernel?

On Thu, 2015-03-05 at 18:59 +0000, Joseph Salisbury wrote:
> I applied these 8 patches to a Utopic tree and built a test kernel. The test kernel can be downloaded from:
> http://kernel.ubuntu.com/~jsalisbury/lp1420627/
>
> Is it possible for you to test this kernel?

Sure, will do, thanks.

Cheers,
Ben.

On Thu, 2015-03-05 at 20:51 +0000, Benjamin Herrenschmidt wrote:
> On Thu, 2015-03-05 at 18:59 +0000, Joseph Salisbury wrote:
> > I applied these 8 patches to a Utopic tree and built a test kernel. The test kernel can be downloaded from:
> > http://kernel.ubuntu.com/~jsalisbury/lp1420627/
> >
> > Is it possible for you to test this kernel?
>
> Sure, will do, thanks.

You seem to only have the big endian kernels in there... Open Power is
essentially LE (and in fact that AST graphic chips doesn't have
functional endian swappers which means you'll get wrong colors on a
BE system but we don't "support" BE OSes on it anyway).

Any chance you can spin the ppc64el packages as well ?

Cheers,
Ben.

Joseph Salisbury (jsalisbury) wrote :

Hi Ben,

Sorry about that. I built a ppc64el kernel and posted it to:

http://kernel.ubuntu.com/~jsalisbury/lp1420627/ppc64el

On Fri, 2015-03-06 at 18:00 +0000, Joseph Salisbury wrote:
> Hi Ben,
>
> Sorry about that. I built a ppc64el kernel and posted it to:
>
> http://kernel.ubuntu.com/~jsalisbury/lp1420627/ppc64el

They work fine, thanks !

Do you mean leaving those packages there for a bit longer so I can point
our BMC FW vendor to them ? Their remote VGA interface has a bug and I
want them to try

Cheers,
Ben.

Joseph Salisbury (jsalisbury) wrote :

Thanks for testing! I'll leave those packages there as long as needed.

Andy Whitcroft (apw) wrote :

All of the requested commits are in v3.18 so calling this Fix Released for vivid.

Changed in linux (Ubuntu Utopic):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Fix Released
Andy Whitcroft (apw) on 2015-04-01
Changed in linux (Ubuntu Utopic):
status: Triaged → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-utopic' to 'verification-done-utopic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-utopic

Tested 3.16.0-36-generic #48-Ubuntu successfully on a Tyan board

tags: added: verification-done-utopic
removed: verification-needed-utopic
Launchpad Janitor (janitor) wrote :
Download full text (15.5 KiB)

This bug was fixed in the package linux - 3.16.0-36.48

---------------
linux (3.16.0-36.48) utopic; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1443946
  * Merged back Ubuntu-3.16.0-34.47 security release

linux (3.16.0-35.46) utopic; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1442324

  [ Andy Whitcroft ]

  * [Config] CONFIG_DEFAULT_MMAP_MIN_ADDR needs to match on armhf and arm64
    - LP: #1418140

  [ Chris J Arges ]

  * [Config] CONFIG_PCIEASPM_DEBUG=y
    - LP: #1398544

  [ dann frazier ]

  * [Config] CONFIG_RTC_DRV_EFI=y on arm64
    - LP: #1441291

  [ Upstream Kernel Changes ]

  * Revert "USB: serial: make bulk_out_size a lower limit"
    - LP: #1441317
  * Revert "i2c: core: Dispose OF IRQ mapping at client removal time"
    - LP: #1441317
  * Revert "net: cx82310_eth: use common match macro"
    - LP: #1441317
  * KEYS: request_key() should reget expired keys rather than give
    EKEYEXPIRED
    - LP: #1124250
  * drm/i915/bdw: 3D_CHICKEN3 has write mask bits
    - LP: #1374389
  * drm/i915: call lpt_init_clock_gating on BDW too
    - LP: #1374389
  * drm/i915/bdw: Apply workarounds in render ring init function
    - LP: #1374389
  * drm/i915/bdw: Cleanup pre prod workarounds
    - LP: #1374389
  * drm/i915: Refactor Broadwell PIPE_CONTROL emission into a helper.
    - LP: #1374389
  * drm/i915: Add the WaCsStallBeforeStateCacheInvalidate:bdw workaround.
    - LP: #1374389
  * drm/i915/bdw: Remove BDW preproduction W/As until C stepping.
    - LP: #1374389
  * drm/i915: Rework GPU reset sequence to match driver load & thaw
    - LP: #1384469
  * drm/ast: switch to using CACHED by default for sysram
    - LP: #1420627
  * drm/ast: Add missing entry to dclk_table[]
    - LP: #1420627
  * drm/ast: Add reduced blanking modes for wide screen mode
    - LP: #1420627
  * drm/ast: Try to use MMIO registers when PIO isn't supported
    - LP: #1420627
  * drm/ast: POST chip at probe time if VGA not enabled
    - LP: #1420627
  * drm/ast: Properly initialize P2A base before using it in
    ast_init_3rdtx()
    - LP: #1420627
  * drm/ast: Don't assume DVO enabled means SIL164 on uninitialized chips
    - LP: #1420627
  * drm/ast: Cleanup analog init code path
    - LP: #1420627
  * audit: correctly record file names with different path name types
    - LP: #1439441
  * of: Create of_console_check() for selecting a console specified in
    /chosen
    - LP: #1438585
  * of: Enable console on serial ports specified by /chosen/stdout-path
    - LP: #1438585
  * of: correct of_console_check()'s return value
    - LP: #1438585
  * of: Add bindings for chosen node, stdout-path
    - LP: #1438585
  * of: add optional options parameter to of_find_node_by_path()
    - LP: #1438585
  * of: support passing console options with stdout-path
    - LP: #1438585
  * netfilter: nf_tables: disable preemption when restoring chain counters
    - LP: #1441317
  * netfilter: nf_tables: fix leaks in error path of nf_tables_newchain()
    - LP: #1441317
  * ipvs: rerouting to local clients is not needed anymore
    - LP: #1441317
  * netfilter: nft_compat: fix module refcount underflow
    - LP: #1441317
  * netf...

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments