package linux-cloud-tools-common 3.16.0-29.39 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1410278 reported by Kevin Cole on 2015-01-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

$ cat /proc/version_signature
Ubuntu 3.16.0-28.38-generic 3.16.7-ckt1

$ lsb_release -rd
Description: Ubuntu 14.10
Release: 14.10

$ apt-cache policy linux-cloud-tools-common
linux-cloud-tools-common:
  Installed: 3.16.0-29.39
  Candidate: 3.16.0-29.39
  Version table:
 *** 3.16.0-29.39 0
        500 http://archive.ubuntu.com/ubuntu/ utopic-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ utopic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     3.16.0-28.38 0
        500 http://archive.ubuntu.com/ubuntu/ utopic-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ utopic-security/main amd64 Packages
     3.16.0-26.35 0
        500 http://archive.ubuntu.com/ubuntu/ utopic-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ utopic-security/main amd64 Packages
     3.16.0-25.33 0
        500 http://archive.ubuntu.com/ubuntu/ utopic-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ utopic-security/main amd64 Packages
     3.16.0-24.32 0
        500 http://archive.ubuntu.com/ubuntu/ utopic-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ utopic-security/main amd64 Packages
     3.16.0-23.31 0
        500 http://archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages

ProblemType: Package
DistroRelease: Ubuntu 14.10
Package: linux-cloud-tools-common 3.16.0-29.39
ProcVersionSignature: Ubuntu 3.16.0-28.38-generic 3.16.7-ckt1
Uname: Linux 3.16.0-28-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: kjcole 5009 F.... pulseaudio
 /dev/snd/controlC0: kjcole 5009 F.... pulseaudio
 /dev/snd/seq: timidity 2477 F.... timidity
Date: Tue Jan 13 09:00:21 2015
Dependencies: lsb-base 4.1+Debian11ubuntu8
DuplicateSignature: package:linux-cloud-tools-common:3.16.0-29.39:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
HibernationDevice: RESUME=UUID=76e8643f-7435-425c-b483-fef4e2fa1918
InstallationDate: Installed on 2011-10-25 (1175 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: System76, Inc. Bonobo Professional
PackageArchitecture: all
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-28-generic root=UUID=94f7fc1e-fa27-4b24-99f3-4b461665a4a4 ro quiet splash
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 2.02~beta2-15
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Title: package linux-cloud-tools-common 3.16.0-29.39 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to utopic on 2014-11-03 (71 days ago)
dmi.bios.date: 08/09/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.4
dmi.board.asset.tag: Not Applicable
dmi.board.name: Bonobo Professional
dmi.board.vendor: System76, Inc.
dmi.board.version: bonp5
dmi.chassis.asset.tag: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: System76, Inc.
dmi.chassis.version: bonp5
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.4:bd08/09/2011:svnSystem76,Inc.:pnBonoboProfessional:pvrbonp5:rvnSystem76,Inc.:rnBonoboProfessional:rvrbonp5:cvnSystem76,Inc.:ct10:cvrbonp5:
dmi.product.name: Bonobo Professional
dmi.product.version: bonp5
dmi.sys.vendor: System76, Inc.

Kevin Cole (kjcole) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check
Kevin Cole (kjcole) wrote :
Download full text (4.0 KiB)

It appears that the apt-get dist-upgrade munged linux-cloud-tools-generic and didn't upgrade linux-cloud-tools-3.16-28 and linux-cloud-tools-3.16-28-generic to linux-cloud-tools-3.16-29 and linux-cloud-tools-3.16-29-generic. But trying to fix that led to:

invoke-rc.d: initscript hv-kvp-daemon, action "start" failed.
dpkg: error processing package linux-cloud-tools-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of linux-cloud-tools-3.16.0-29:
 linux-cloud-tools-3.16.0-29 depends on linux-cloud-tools-common; however:
  Package linux-cloud-tools-common is not configured yet.

dpkg: error processing package linux-cloud-tools-3.16.0-29 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-cloud-tools-3.16.0-29-generic:
 linux-cloud-tools-3.16.0-29-generic depends on linux-cloud-tools-3.16.0-29; however:
  Package linux-cloud-tools-3.16.0-29 is not configured yet.

dpkg: error processing package linux-cloud-tools-3.16.0-29-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-cloud-tools-generic:
 linux-cloud-tools-generic depends on linux-cloud-tools-3.16.0-29-generic; however:
  Package linux-cloud-tools-3.16.0-29-generic is not configured yet.

dpkg: error processing package linux-cloud-tools-generic (--configure):
 dependenNo apport report written because the error message indicates its a followup error from a previous failure.
                                   No apport report written because MaxReports is reached already
                 No apport report written because MaxReports is reached already
                                                                               cy problems - leaving unconfigured
Errors were encountered while processing:
 cgmanager
 linux-cloud-tools-common
 linux-cloud-tools-3.16.0-29
 linux-cloud-tools-3.16.0-29-generic
 linux-cloud-tools-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up cgmanager (0.32-4ubuntu1.1) ...
Failed to get D-Bus connection: No connection to service manager.
Failed to get D-Bus connection: No connection to service manager.
invoke-rc.d: initscript cgmanager, action "start" failed.
dpkg: error processing package cgmanager (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up linux-cloud-tools-common (3.16.0-29.39) ...
Failed to get D-Bus connection: No connection to service manager.
Failed to get D-Bus connection: No connection to service manager.
invoke-rc.d: initscript hv-kvp-daemon, action "start" failed.
dpkg: error processing package linux-cloud-tools-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of linux-cloud-tools-3.16.0-29:
 linux-cloud-tools-3.16.0-29 depends on linux-cloud-tools-common; however:
  Package linux-cloud-tools-common is not configured yet.

dpkg: error processing package linux-cloud-tools-3.16.0-29 (--configure):
 d...

Read more...

Joseph Salisbury (jsalisbury) wrote :

You may need to run the following:

sudo apt-get install -f
sudo apt-get clean
sudo apt-get update

Then re-install the package.

If that does not resolve your issue, please mark the bug as "Confirmed"

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Kevin Cole (kjcole) wrote :

I not only did as you suggested (which had no effect), I then purged all the linux-cloud-* and dependencies, then did the install -f, clean and update cycle and re-installed. Same problem. Now marked as confirmed as per your instructions.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Frederik Bosch (f-bosch) wrote :

I had the same issue when I wanted to upgrade to newer kernel. So I first added ppa:canonical-kernel-team/ppa, upgrade my kernel and then installed the new tools and cloud tools. Then got the issue.

I solved it by removing the ppa. This allowed me to remove the newer tools and cloud tools, then removing the tools and cloud tools from my older kernel. Now with no cloud tools and tools installed, I added the ppa again and install the tools and cloud tools successfully.

Anders Sandblad (arune) wrote :

I had something similar to this. I could not install the linux-cloud-tools packages because of this error (and then followed a lot of dependency problems)
  invoke-rc.d: initscript hv-kvp-daemon, action "start" failed.

However, I found that there was no file /usr/sbin/hv_kvp_daemon and I tried installing linux-cloud-tools-common, which should contain this file, manually:
arune@SEGOTVSL002:~$ dpkg --contents /var/cache/apt/archives/linux-cloud-tools-common_3.13.0-74.118_all.deb
...
-rwxr-xr-x root/root 1622 2015-12-18 01:07 ./usr/sbin/hv_kvp_daemon
...
But just the hv_kvp_daemon was not installed installed, I have not found the root cause of this!

But I found a file /usr/sbin/hv_kvp_daemon.hv-kvp-daemon-init which was the missing hv_kvp_daemon and I renamed it to /usr/sbin/hv_kvp_daemon and then I could install the packages.

usefree (usefreeit) wrote :

But I found a file /usr/sbin/hv_kvp_daemon.hv-kvp-daemon-init which was the missing hv_kvp_daemon and I renamed it to /usr/sbin/hv_kvp_daemon and then I could install the packages.

Thanks Andreas. I can confirm it fixes the bug. Ubuntu 14.04 x86_64, 3.13.0-74-generic kernel, linux-cloud-tools-3.13.0-73

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers