devel: DTBs have moved into vendor specific directories on arm64

Bug #1408004 reported by Andy Whitcroft on 2015-01-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Adam Conrad
Trusty
Undecided
Adam Conrad
flash-kernel (Ubuntu)
Medium
Adam Conrad
Trusty
Undecided
Adam Conrad
linux (Ubuntu)
Medium
Andy Whitcroft
Trusty
Undecided
Unassigned

Bug Description

[ SRU Justification ]
For trusty, the lts-vivid debian-installer builds install the lts-vivid kernel, which has the DTBs in the new location. As such, both d-i and f-k need fixing to look for the correct locations.

[ Test Case ]
For d-i, the test case is to build d-i and ensure it's picking up the right DTBs for both old and new location builds.

For f-k, the test case is to do an installation of both lts-utopic and lts-vivid on arm64 and ensure that flash-kernel is operating on the DTBs without error in both cases.

[ Regression Potential ]
The d-i change has already been tested in a PPA and is known-good, while the f-k change is a straight cherry-pick from vivid, where it was known to work, so both should be minimally scary.

[ Original Report ]
The installed DTBs have moved into vendor specific directories. We need to 1) make sure we are hoovering them up right, and 2) that the consumers thereof (d-i etc) are consuming them in the new locations.

NOTE: this actually is only _installed_ into those new directories on arm64.

Andy Whitcroft (apw) on 2015-01-06
Changed in linux (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Andy Whitcroft (apw)
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu):
milestone: none → ubuntu-15.01
Changed in debian-installer (Ubuntu):
milestone: none → ubuntu-15.01
Andy Whitcroft (apw) on 2015-01-12
summary: - devel: DTBs have moved into vendor specific directories
+ devel: DTBs have moved into vendor specific directories on arm64
description: updated
Andy Whitcroft (apw) wrote :

As this only affects arm64, and we do not yet currently use any dtbs in the installer on that arch, we are safe to ignore this.

Changed in debian-installer (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Andy Whitcroft (apw) on 2015-01-29
Changed in linux (Ubuntu):
milestone: ubuntu-15.01 → ubuntu-15.02
Changed in debian-installer (Ubuntu):
milestone: ubuntu-15.01 → none
Andy Whitcroft (apw) on 2015-02-27
Changed in debian-installer (Ubuntu):
status: Invalid → Confirmed
assignee: nobody → Adam Conrad (adconrad)
Adam Conrad (adconrad) on 2015-02-27
Changed in flash-kernel (Ubuntu):
status: New → Confirmed
assignee: nobody → Adam Conrad (adconrad)
Andy Whitcroft (apw) on 2015-02-27
Changed in flash-kernel (Ubuntu):
importance: Undecided → Medium
Adam Conrad (adconrad) wrote :

This will need fixing in trusty's flash-kernel and trusty's lts-v (and beyond) d-i builds as well.

Changed in debian-installer (Ubuntu Trusty):
assignee: nobody → Adam Conrad (adconrad)
status: New → In Progress
Changed in flash-kernel (Ubuntu Trusty):
assignee: nobody → Adam Conrad (adconrad)
status: New → In Progress
Changed in linux (Ubuntu Trusty):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.0~rc.4ubuntu54

---------------
flash-kernel (3.0~rc.4ubuntu54) vivid; urgency=medium

  * Allow us to find DTBs in both the old flat layout and the new vendor
    subdirectory layout, so we keep backward compatibility (LP: #1408004)
 -- Adam Conrad <email address hidden> Fri, 27 Feb 2015 03:46:28 -0700

Changed in flash-kernel (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.19.0-7.7

---------------
linux (3.19.0-7.7) vivid; urgency=low

  [ Andy Whitcroft ]

  * Release Tracking Bug
    - LP: #1426013

  [ Upstream Kernel Changes ]

  * x86/irq: Fix regression caused by commit b568b8601f05
  * cxl: Fix leaking interrupts if attach process fails
    - LP: #1415102
  * cxl: Early return from cxl_handle_fault for a shut down context
    - LP: #1415102
  * cxl: Disable AFU debug flag
    - LP: #1415102
  * cxl: Disable SPAP register when freeing SPA
    - LP: #1415102
  * cxl: remove redundant increment of hwirq
    - LP: #1415102
  * cxl: Add tracepoints
    - LP: #1415102
  * cxl: Update CXL ABI documentation
    - LP: #1415102
  * cxl: Use image state defaults for reloading FPGA
    - LP: #1415102
  * cxl: Add image control to sysfs
    - LP: #1415102
  * cxl: Enable CAPP recovery
    - LP: #1415102
  * cxl: Add ability to reset the card
    - LP: #1415102
  * cxl: Fix device_node reference counting
    - LP: #1415102
  * cxl: Export optional AFU configuration record in sysfs
    - LP: #1415102
  * cxl: Fail AFU initialisation if an invalid configuration record is
    found
    - LP: #1415102
  * cxl: Add missing return statement after handling AFU errror
    - LP: #1415102
  * powerpc/eeh: Introduce flag EEH_PE_REMOVED
    - LP: #1415102
  * powerpc/eeh: Allow to set maximal frozen times
    - LP: #1415102
  * HID: i2c-hid: Limit reads to wMaxInputLength bytes for input events
 -- Andy Whitcroft <email address hidden> Thu, 26 Feb 2015 16:00:18 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu366

---------------
debian-installer (20101020ubuntu366) vivid; urgency=medium

  * Copy apm-mustang.dtb from its new location (LP: #1408004)
 -- Adam Conrad <email address hidden> Fri, 27 Feb 2015 03:57:40 -0700

Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Released
Adam Conrad (adconrad) on 2015-06-02
description: updated

Hello Andy, or anyone else affected,

Accepted flash-kernel into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/flash-kernel/3.0~rc.4ubuntu49.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in flash-kernel (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello Andy, or anyone else affected,

Accepted debian-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu318.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Trusty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.0~rc.4ubuntu49.5

---------------
flash-kernel (3.0~rc.4ubuntu49.5) trusty; urgency=medium

  * Allow us to find DTBs in both the old flat layout and the new vendor
    subdirectory layout, so we keep backward compatibility (LP: #1408004)

 -- Adam Conrad <email address hidden> Tue, 02 Jun 2015 14:57:54 -0600

Changed in flash-kernel (Ubuntu Trusty):
status: Fix Committed → Fix Released
Adam Conrad (adconrad) wrote :

Verified for both flash-kernel and debian-installer.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu318.18

---------------
debian-installer (20101020ubuntu318.18) trusty; urgency=medium

  * Switch to '---' as option separator for all kernels (LP: #1427252)
  * Add lts-vivid variants for all targets except for e500, for which
    support was dropped in the utopic/lts-utopic kernel (LP: #1459779)
  * Conditionally use apm-mustang.dtb from new location (LP: #1408004)

 -- Adam Conrad <email address hidden> Tue, 02 Jun 2015 11:07:49 -0600

Changed in debian-installer (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for debian-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers