Trusty update to v3.13.11.11 stable release

Bug #1393477 reported by Luis Henriques on 2014-11-17
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The v3.13.11.11 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the v3.13.11.11 stable release:

netlink: reset network header before passing to taps
rtnetlink: fix VF info size
myri10ge: check for DMA mapping errors
tcp: don't use timestamp from repaired skb-s to calculate RTT (v2)
sit: Fix ipip6_tunnel_lookup device matching criteria
tcp: fix tcp_release_cb() to dispatch via address family for mtu_reduced()
tcp: fix ssthresh and undo for consecutive short FRTO episodes
packet: handle too big packets for PACKET_V3
openvswitch: fix panic with multiple vlan headers
vxlan: fix incorrect initializer in union vxlan_addr
l2tp: fix race while getting PMTU on PPP pseudo-wire
bonding: fix div by zero while enslaving and transmitting
bridge: Check if vlan filtering is enabled only once.
bridge: Fix br_should_learn to check vlan_enabled
net: allow macvlans to move to net namespace
tg3: Work around HW/FW limitations with vlan encapsulated frames
tg3: Allow for recieve of full-size 8021AD frames
xfrm: Generate blackhole routes only from route lookup functions
xfrm: Generate queueing routes only from route lookup functions
macvtap: Fix race between device delete and open.
Revert "net/macb: add pinctrl consumer support"
gro: fix aggregation for skb using frag_list
hyperv: Fix a bug in netvsc_start_xmit()
ip6_gre: fix flowi6_proto value in xmit path
team: avoid race condition in scheduling delayed work
sctp: handle association restarts when the socket is closed.
tcp: fixing TLP's FIN recovery
sparc64: Do not disable interrupts in nmi_cpu_busy()
sparc64: Fix pcr_ops initialization and usage bugs.
sparc32: dma_alloc_coherent must honour gfp flags
sparc64: sun4v TLB error power off events
sparc64: Fix corrupted thread fault code.
sparc64: find_node adjustment
sparc64: Move request_irq() from ldc_bind() to ldc_alloc()
sparc: Let memset return the address argument
sparc64: Fix reversed start/end in flush_tlb_kernel_range()
sparc64: Fix lockdep warnings on reboot on Ultra-5
sparc64: Fix FPU register corruption with AES crypto offload.
sparc64: Do not define thread fpregs save area as zero-length array.
sparc64: Fix hibernation code refrence to PAGE_OFFSET.
sparc64: correctly recognise M6 and M7 cpu type
sparc64: support M6 and M7 for building CPU distribution map
sparc64: cpu hardware caps support for sparc M6 and M7
sparc64: T5 PMU
sparc64: Switch to 4-level page tables.
sparc64: Define VA hole at run time, rather than at compile time.
sparc64: Adjust KTSB assembler to support larger physical addresses.
sparc64: Fix physical memory management regressions with large max_phys_bits.
sparc64: Use kernel page tables for vmemmap.
sparc64: Increase MAX_PHYS_ADDRESS_BITS to 53.
sparc64: Adjust vmalloc region size based upon available virtual address bits.
sparc64: sparse irq
sparc64: Kill unnecessary tables and increase MAX_BANKS.
sparc64: Increase size of boot string to 1024 bytes
sparc64: Fix register corruption in top-most kernel stack frame during boot.
sparc64: Implement __get_user_pages_fast().
ext4: check EA value offset when loading
jbd2: free bh when descriptor block checksum fails
ext4: don't check quota format when there are no quota files
target: Fix queue full status NULL pointer for SCF_TRANSPORT_TASK_SENSE
vfs: fix data corruption when blocksize < pagesize for mmaped data
ext4: fix mmap data corruption when blocksize < pagesize
ext4: grab missed write_count for EXT4_IOC_SWAP_BOOT
qla_target: don't delete changed nacls
target: Fix APTPL metadata handling for dynamic MappedLUNs
iser-target: Disable TX completion interrupt coalescing
ext4: don't orphan or truncate the boot loader inode
ext4: add ext4_iget_normal() which is to be used for dir tree lookups
ext4: fix reservation overflow in ext4_da_write_begin
ext4: Replace open coded mdata csum feature to helper function
ext4: move error report out of atomic context in ext4_init_block_bitmap()
ARC: [nsimosci] Allow "headless" models to boot
ARC: Update order of registers in KGDB to match GDB 7.5
ext4: check s_chksum_driver when looking for bg csum presence
drm/radeon: fix speaker allocation setup
drm/radeon: use gart memory for DMA ring tests
compiler: define OPTIMIZER_HIDE_VAR() macro
random: add and use memzero_explicit() for clearing data
ALSA: pcm: use the same dma mmap codepath both for arm and arm64
ALSA: ALC283 codec - Avoid pop noise on headphones during suspend/resume
ALSA: usb-audio: Add support for Steinberg UR22 USB interface
ALSA: hda - hdmi: Fix missing ELD change event on plug/unplug
arm64: compat: fix compat types affecting struct compat_elf_prpsinfo
freezer: Do not freeze tasks killed by OOM killer
OOM, PM: OOM killed task shouldn't escape PM suspend
qxl: don't create too large primary surface
MIPS: tlbex: Properly fix HUGE TLB Refill exception handler
drm/cirrus: bind also to qemu-xen-traditional
cpufreq: intel_pstate: Fix setting max_perf_pct in performance policy
cpufreq: expose scaling_cur_freq sysfs file for set_policy() drivers
cpufreq: intel_pstate: Reflect current no_turbo state correctly
intel_pstate: Don't lose sysfs settings during cpu offline
intel_pstate: Fix BYT frequency reporting
intel_pstate: Correct BYT VID values.
MIPS: ftrace: Fix a microMIPS build problem
kvm: x86: don't kill guest on unknown exit reason
kvm: fix excessive pages un-pinning in kvm_iommu_map error path.
KVM: x86: use new CS.RPL as CPL during task switch
KVM: x86: Handle errors when RIP is set during far jumps
KVM: x86: Fix far-jump to non-canonical check
staging:iio:ad5933: Fix NULL pointer deref when enabling buffer
staging:iio:ad5933: Drop "raw" from channel names
iio: st_sensors: Fix buffer copy
iio: mxs-lradc: Propagate the real error code on platform_get_irq() failure
iio: adc: mxs-lradc: Disable the clock on probe failure
spi: pl022: Fix incorrect dma_unmap_sg
mac80211: fix typo in starting baserate for rts_cts_rate_idx
usb: dwc3: gadget: fix set_halt() bug with pending transfers
usb: gadget: function: acm: make f_acm pass USB20CV Chapter9
ext3: Don't check quota format when there are no quota files
quota: Properly return errors from dquot_writeback_dquots()
USB: serial: cp210x: add Silicon Labs 358x VID and PID
usb: serial: ftdi_sio: add Awinda Station and Dongle products
usb: option: add support for Telit LE910
USB: option: add Haier CE81B CDMA modem
x86, apic: Handle a bad TSC more gracefully
i3200_edac: Report CE events properly
i82860_edac: Report CE events properly
cpc925_edac: Report UE events properly
e7xxx_edac: Report CE events properly
scsi: Fix error handling in SCSI_IOCTL_SEND_COMMAND
usb: serial: ftdi_sio: add "bricked" FTDI device PID
usb: musb: cppi41: restart hrtimer only if not yet done
usb: gadget: udc: core: fix kernel oops with soft-connect
nfsd4: fix crash on unknown operation number
iwlwifi: configure the LTR
mac80211: add vif to flush call
iwlwifi: dvm: drop non VO frames when flushing
Revert "iwlwifi: mvm: treat EAPOLs like mgmt frames wrt rate"
usb: dwc3: gadget: Properly initialize LINK TRB
Input: i8042 - quirks for Fujitsu Lifebook A544 and Lifebook AH544
posix-timers: Fix stack info leak in timer_create()
futex: Fix a race condition between REQUEUE_PI and task death
PM / Sleep: fix recovery during resuming from hibernation
ALSA: pcm: Zero-clear reserved fields of PCM status ioctl in compat mode
ima: check xattr value length and type in the ima_inode_setxattr()
evm: check xattr value length and type in evm_inode_setxattr()
drm/radeon/dpm: disable ulv support on SI
drm/radeon: dpm fixes for asrock systems
drm/radeon: remove invalid pci id
x86, pageattr: Prevent overflow in slow_virt_to_phys() for X86_PAE
cgroup/kmemleak: add kmemleak_free() for cgroup deallocations.
mm: free compound page with correct order
mm, thp: fix collapsing of hugepages on madvise
lib/bitmap.c: fix undefined shift in __bitmap_shift_{left|right}()
ext4: fix overflow when updating superblock backups after resize
ext4: fix oops when loading block bitmap failed
ext4: enable journal checksum when metadata checksum feature enabled
ext4: bail out from make_indexed_dir() on first error
PCI: Rename sysfs 'enabled' file back to 'enable'
wireless: rt2x00: add new rt2800usb device
fs: allow open(dir, O_TMPFILE|..., 0) with mode 0
tracing/syscalls: Ignore numbers outside NR_syscalls' range
x86_64, entry: Fix out of bounds read on sysenter
ACPI / EC: Add support to disallow QR_EC to be issued when SCI_EVT isn't set
ACPI / EC: Fix regression due to conflicting firmware behavior between Samsung and Acer.
net: sctp: fix skb_over_panic when receiving malformed ASCONF chunks
net: sctp: fix panic on duplicate ASCONF chunks
net: sctp: fix remote memory pressure from excessive queueing
Linux 3.13.11.11

The following commits from 3.13.11.11 were already applied to the Trusty kernel:

KVM: x86: Check non-canonical addresses upon WRMSR
KVM: x86: Prevent host from panicking on shared MSR writes.
KVM: x86: Improve thread safety in pit
KVM: x86: Fix wrong masking on relative jump/call
KVM: x86: Emulator fixes for eip canonical checks on near branches
kvm: vmx: handle invvpid vm exit gracefully

NOTE: although the following commit:

KVM: x86: Handle errors when RIP is set during far jumps

was already applied to the Trusty kernel, it was reverted and the one in stable 3.13.11.11 was applied as it was slightly different.

Luis Henriques (henrix) on 2014-11-17
tags: added: kernel-stable-tracking-bug
Luis Henriques (henrix) on 2014-11-17
description: updated
Changed in linux (Ubuntu Trusty):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (14.0 KiB)

This bug was fixed in the package linux - 3.13.0-41.70

---------------
linux (3.13.0-41.70) trusty; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1396112

  [ Chris J Arges ]

  * [Config] CONFIG_SCOM_DEBUGFS=y for powerpc/powerpc64-smp
    ppc64el/generic
    - LP: #1395855

  [ Upstream Kernel Changes ]

  * Revert "KVM: x86: Handle errors when RIP is set during far jumps"
    - LP: #1393477
  * Revert "net/macb: add pinctrl consumer support"
    - LP: #1393477
  * Revert "iwlwifi: mvm: treat EAPOLs like mgmt frames wrt rate"
    - LP: #1393477
  * Revert "ipmi: simplify locking"
    - LP: #1383921
  * ACPI / blacklist: add Win8 OSI quirks for some Dell laptop models
    - LP: #1339456
  * ACPI / battery: Accelerate battery resume callback
    - LP: #838543
  * tools: cpu-hotplug fix unexpected operator error
  * netlink: reset network header before passing to taps
    - LP: #1393477
  * rtnetlink: fix VF info size
    - LP: #1393477
  * myri10ge: check for DMA mapping errors
    - LP: #1393477
  * tcp: don't use timestamp from repaired skb-s to calculate RTT (v2)
    - LP: #1393477
  * sit: Fix ipip6_tunnel_lookup device matching criteria
    - LP: #1393477
  * tcp: fix tcp_release_cb() to dispatch via address family for
    mtu_reduced()
    - LP: #1393477
  * tcp: fix ssthresh and undo for consecutive short FRTO episodes
    - LP: #1393477
  * packet: handle too big packets for PACKET_V3
    - LP: #1393477
  * openvswitch: fix panic with multiple vlan headers
    - LP: #1393477
  * vxlan: fix incorrect initializer in union vxlan_addr
    - LP: #1393477
  * l2tp: fix race while getting PMTU on PPP pseudo-wire
    - LP: #1393477
  * bonding: fix div by zero while enslaving and transmitting
    - LP: #1393477
  * bridge: Check if vlan filtering is enabled only once.
    - LP: #1393477
  * bridge: Fix br_should_learn to check vlan_enabled
    - LP: #1393477
  * net: allow macvlans to move to net namespace
    - LP: #1393477
  * tg3: Work around HW/FW limitations with vlan encapsulated frames
    - LP: #1393477
  * tg3: Allow for recieve of full-size 8021AD frames
    - LP: #1393477
  * xfrm: Generate blackhole routes only from route lookup functions
    - LP: #1393477
  * xfrm: Generate queueing routes only from route lookup functions
    - LP: #1393477
  * macvtap: Fix race between device delete and open.
    - LP: #1393477
  * gro: fix aggregation for skb using frag_list
    - LP: #1393477
  * hyperv: Fix a bug in netvsc_start_xmit()
    - LP: #1393477
  * ip6_gre: fix flowi6_proto value in xmit path
    - LP: #1393477
  * team: avoid race condition in scheduling delayed work
    - LP: #1393477
  * sctp: handle association restarts when the socket is closed.
    - LP: #1393477
  * tcp: fixing TLP's FIN recovery
    - LP: #1393477
  * sparc64: Do not disable interrupts in nmi_cpu_busy()
    - LP: #1393477
  * sparc64: Fix pcr_ops initialization and usage bugs.
    - LP: #1393477
  * sparc32: dma_alloc_coherent must honour gfp flags
    - LP: #1393477
  * sparc64: sun4v TLB error power off events
    - LP: #1393477
  * sparc64: Fix corrupted thread fault code.
    - LP: #1393477
  * sparc64: find_node adjustment
   ...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released

Probably there is a problem with the "ext4: enable journal checksum when metadata checksum feature enabled" patch.

Tytso wrote in bug LP: #1365874 that with Linux kernel 3.18 the metadata checksum feature got some format changes.
Is this patch compatible with these changes?

Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers