[Asus X553MA] Touchpad multi-touch features doesn't work

Bug #1383097 reported by ajithmemana on 2014-10-20
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hi,
I am using an Asus X553MA laptop. My touch pad works well. But the features like multitouch, scrolling etc doesn't seem to work.
I tried the below command and it didn't return any output.

cat /proc/bus/input/devices > ~/devices
 xinput --list > ~/xinput

And the below code returns all hardware info but not my touchpad

ajith@ajith-X553MA:~$ cat /proc/bus/input/devices

But i noticed a field as Mouse instead of my touchpad.

I: Bus=0011 Vendor=0002 Product=0001 Version=0063
N: Name="PS/2 Logitech Wheel Mouse"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input12
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I have used a mouse earlier with the laptop. But it was not a Logitech one. It was an HP one.

Please help
---
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ajith 1832 F.... pulseaudio
CurrentDesktop: XFCE
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=f212c208-4c4f-4381-adf5-be331f2e13c9
InstallationDate: Installed on 2014-10-12 (11 days ago)
InstallationMedia: Xubuntu 14.04.1 LTS "Trusty Tahr" - Release i386 (20140723)
Lsusb:
 Bus 001 Device 004: ID 04ca:3010 Lite-On Technology Corp.
 Bus 001 Device 003: ID 04f2:b424 Chicony Electronics Co., Ltd
 Bus 001 Device 002: ID 8087:07e6 Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. X553MA
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic root=UUID=088c9965-8b1b-46ad-9074-0a1f82a18a4e ro quiet splash acpi_osi=Linux acpi_backlight=vendor quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-37-generic N/A
 linux-backports-modules-3.13.0-37-generic N/A
 linux-firmware 1.127.7
Tags: trusty
Uname: Linux 3.13.0-37-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 05/16/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X553MA.205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X553MA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX553MA.205:bd05/16/2014:svnASUSTeKCOMPUTERINC.:pnX553MA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX553MA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: X553MA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1383097

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

This is actually an issue with a missing driver.

 I have run the command to list inputs and returns following.
xinput --list

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Logitech Wheel Mouse id=14 [slave pointer (2)]
⎜ ↳ USB Optical Mouse id=10 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=12 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]
    ↳ USB2.0 HD UVC WebCam id=11 [slave keyboard (3)]

The touchpad is working fine. But the mutitouch features like scrolling is not working

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.18 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18-rc1-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
ajithmemana (ajithmemana) wrote :

Installed linux image and headers(generic i386) and tried. That didn't resolve the issue.
Noticed the following things in addition:
# Brightness controls on keyboard not working,but volume controls work.
# Microphone doesn't work.
# Bluetooth not working

Not yet checked camera.

kernel-bug-exists-upstream

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

apport information

tags: added: bios-outdated-208
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
ajithmemana (ajithmemana) wrote :

Bios update didnot resolve issue.
Bios updated to version 208

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
ajithmemana (ajithmemana) wrote :

Here's the output

X553MA.208
07/09/2014

Things not working
- Touchpad features
- Bluetooth
- Brightness controls
- Microphone
- On board graphics(i doubt)
- Keyboard shortcuts - Sleep/ Flight/birghtness/touchpad disable/

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

ajithmemana, this bug report is only scoped to the touchpad multi-touch issue. All the others you mentioned would need to be filed as a separate report, one per issue mentioned.

Despite this, could you please test 3.18-rc2 and advise if this is reproducible?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - Touch pad multi touch features doesn't work
+ [Asus X553MA] Touchpad multi-touch features doesn't work

I tried the 3.18-rc2 and my X553MA didn't even boot with it.

And I just built and installed vanilla 3.17.2 and with it the touchpad functionality stays same as with 3.13.0-39-generic.

(But now with 3.17.2 screen brightness control does work...)

Janne Heikkinen, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Using 3.18.0-031800rc1-generic I get the following from /proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 FocalTech FocalTech Touchpad in mouse emulation mode"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=1
B: EV=7
B: KEY=30000 0 0 0 0
B: REL=3

With 3.17.2 it was still "PS/2 Logitech Wheel Mouse".

That seems to come from commit 3ace3686f198e656624d7ca2984d053e65f6e09d:

Input: psmouse - add support for detecting FocalTech PS/2 touchpads

The Asus X450 and X550 laptops use a PS/2 touchpad from a new
manufacturer called FocalTech:

https://bugzilla.kernel.org/show_bug.cgi?id=77391
https://bugzilla.redhat.com/show_bug.cgi?id=1110011

The protocol for these devices is not known at this time, but even
without knowing the protocol they need some special handling. They get
upset by some of our other PS/2 device probing, and once upset generate
random mouse events making things unusable even with an external mouse.

This patch adds detection of these devices based on their pnp ids, and
when they are detected, treats them as a bare ps/2 mouse. Doing things
this way they at least work in their ps/2 mouse emulation mode.

Signed-off-by: Hans de Goede <email address hidden>
Signed-off-by: Dmitry Torokhov <email address hidden>

ajithmemana (ajithmemana) wrote :

I have tested the 3.18.0-031800rc4-generic kernel.

Issue is still reproducible.

The /proc/bus/input/devices file contains the following as Jane has mentioned

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 FocalTech FocalTech Touchpad in mouse emulation mode"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input12
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=1
B: EV=7
B: KEY=30000 0 0 0 0 0 0 0 0
B: REL=3

But the xinput --list command still returns the same output as reported above.

N: Name="PS/2 Logitech Wheel Mouse"

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream-3.18-rc4 latest-bios-208
removed: bios-outdated-208
tags: added: kernel-bug-exists-upstream
ajithmemana (ajithmemana) wrote :

@penalvch I am sorry Christopher, but am new to Linux that i could't test compiling and running the patch. Is there an easier way to do this ?
Meanwhile, i have replaced Xubuntu 13.04 with 13.10 (3.16.0-24-generic ), and still the issue is not resolved. The brightness controls are now working with the stock OS.

tags: added: utopic

ajithmemana, would you be able to test if stable kernel 3.17.4 from here works for you:

http://www.helsinki.fi/~jmoheikk/focaltech/

ajithmemana (ajithmemana) wrote :

Hey Janne,
I will check and let you know. I am running Xubuntu X86, but the Kernel in the folder seems to be x64.

ajithmemana, sorry I forgot to build i386 image for the 3.17.4 version but now I just added it into that directory.

snake (max-nedelchev) wrote :

Hi,

Facing the same issue, but I'm owner of ASUS n550jk. Came accross on http://mariusmonton.com/?p=489. Tried that solution it didn't work, but I guess it's good point to start tracking down the issue. THanks

ps:

my dmesg log

[ 0.593154] psmouse: module verification failed: signature and/or required key missing - tainting kernel

N550JK has also FocalTech (not Elantech) touchpad but different from X553MA. N550JK has touchpad that has pnp id FLT0101 whereas X553MA has touchpad with pnp id FLT0102. The same driver should handle both though but I don't know if FLT0101 works at the moment.

snake, thank you for your comment. Unfortunately, this bug report is not scoped to you, your hardware, or your problem. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in linux (Ubuntu):
status: Incomplete → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

ajithmemana, could you please test the latest mainline kernel (4.0-rc7) and advise to the results?

tags: added: needs-upstream-testing
removed: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Support for the FocalTech touchpad has been in the mainline kernel since 3.19 so with 4.0-rc7 it should work.

ajithmemana (ajithmemana) wrote :

@Christopher, @Jane I have tried the 4.0 rc5 & rc7 Kernels. My laptop wont boot with either of these Kernels.
So i updated the 3.18 Kernel to 3.19 rc4. Still the multi touch features like double finger scrolling etc doesn't seem to work.

System info: Xubuntu 14.04
Linux ajith-X553MA 3.19.4-031904-generic #201504131440 SMP Mon Apr 13 14:50:01 UTC 2015 i686 i686 i686 GNU/Linux

ajithmemana (ajithmemana) wrote :

Also i see the following message while installing kernels.

 Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169

And here is the line where booting freezes with 4.0 kernels
[5.872093] hidraw: raw HID events driver(c) Jiri Kosina
[5.895810] sdphcp: Standard Hot Plug PCI Controller Driver Version:0.4

I waited for around 10 minutes before restarting the laptop.

3.19rc4 should contain the FocalTech support code. Check that it has been built with CONFIG_MOUSE_PS2_FOCALTECH.

Also you could check "OS selection" BIOS setting. If it's set to "Windows 8" change it to "Windows 7" and see if 4.0 boots
with that.

ajithmemana (ajithmemana) wrote :

@Jane I have changed the OS Selection in BIOS and now all my kernels are booting fine. It was set to Windows 8. I never knew that was why my kernels weren't booting up. I have checked the issue with 4.0 rc 7 kernel. My touch pad is now working fine as expected. I have tried changing the touchpad acceleration, accuracy etc, Everything seems to work fine. I believe the issue is resolved. Thank you for the help.

tags: added: kernel-fixed-upstream kernel-fixed-upstream-4.0-rc7
removed: needs-upstream-testing
ajithmemana (ajithmemana) wrote :

I believe the issue is resolved. Can i mark this issue as "Fix Released"?

ajithmemana, Fix Released would be more appropriate if there was a specific, identified commit applied to a supported repository, as outlined in https://wiki.ubuntu.com/Bugs/Status .

Despite this, are you advising this is resolved in the default kernel (not mainline)? If so, please feel free to mark this Invalid.

ajithmemana (ajithmemana) wrote :

Update: OS upgraded to Xubuntu 15.04, 32 bit(Fresh installation). Issue still exists in Default kernel.

System Info:
ajithmemana-X553MA 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:01 UTC 2015 i686 i686 i686 GNU/Linux

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: issue-exists-stock-kernel
tags: added: vivid
removed: issue-exists-stock-kernel
tags: added: bios-outdated-211
removed: latest-bios-208

ajithmemana, just to advise, all tags may be found at https://wiki.ubuntu.com/Bugs/Tags .

Despite this, as per https://www.asus.com/Notebooks_Ultrabooks/X553MA/HelpDesk_Download/ an update to your computer's buggy and outdated BIOS is available (211). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful. As well, you don't have to create a new bug report.

Once the BIOS is updated, and the information above is provided, then please mark this report Status Confirmed.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Rishu Kumar (rishu-dce) wrote :

Hi, I am also using ASUS X553MA and the touchpad multi touch and scroll are not working. I have tried to install various drivers but none seems to work. I am using elementary OS 0.3.1 Freya 64 bit built on Ubuntu 14.04.

Rishu Kumar (rishu-dce) wrote :

hi..anyone looking into this bug?

Rishu Kumar, typically if the Status of a report is Incomplete (like this one) the answer is probably not, as it doesn't have all the information a developer needs to address the issue. For more on this, please see https://wiki.ubuntu.com/Bugs/Status .

However, it will help immensely if you filed a new report via Ubuntu (not Elementary OS) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.