[Asus TP300LA] no wifi with Intel AC 7260 Ubuntu 14.04

Bug #1369701 reported by Andreas on 2014-09-15
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Notebook: Asus TP300 LA-C 4023H
Network controller: Intel Corporation Wireless 7260 [8086:08b1]

Wifi doesn't work.

Upstream fix:
https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/iwlwifi-next.git/commit/?h=for-john&id=bfc8f5a4060ecf099aca71de271b17a64079585c

ifconfig -a
eth0 Link encap:Ethernet HWaddr 64:d1:a3:2d:cd:92
          inet addr:192.168.178.42 Bcast:192.168.178.255 Mask:255.255.255.0
          inet6 addr: fe80::66d1:a3ff:fe2d:cd92/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:17726 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15998 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14856501 (14.8 MB) TX bytes:2530795 (2.5 MB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:65536 Metric:1
          RX packets:2150 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2150 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:198684 (198.6 KB) TX bytes:198684 (198.6 KB)

iwconfig
eth0 no wireless extensions.
lo no wireless extensions.

rfkill list
1: asus-wlan: Wireless LAN
 Soft blocked: no
 Hard blocked: no
2: asus-bluetooth: Bluetooth
 Soft blocked: yes
 Hard blocked: no

iwlist chan
eth0 no frequency information.
lo no frequency information.

sudo iwlist scan
eth0 Interface doesn't support scanning.
lo Interface doesn't support scanning.

grep iwl /etc/modprobe.d/*
/etc/modprobe.d/iwlmvm.conf:options iwlmvm power_scheme=1
/etc/modprobe.d/iwlwifi.conf:# /etc/modprobe.d/iwlwifi.conf
/etc/modprobe.d/iwlwifi.conf:# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
/etc/modprobe.d/iwlwifi.conf:# microcode file installed on the system. When removing iwlwifi, first
/etc/modprobe.d/iwlwifi.conf:# remove the iwl?vm module and then iwlwifi.
/etc/modprobe.d/iwlwifi.conf:remove iwlwifi \
/etc/modprobe.d/iwlwifi.conf:(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \

I can load the driver manual with sudo modprobe -v iwlwifi but the dosnt works and iwconfig shows the same like before.

---
ApportVersion: 2.14.1-0ubuntu3.4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: caligula 7490 F.... pulseaudio
 /dev/snd/controlC1: caligula 7490 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=df34710f-830a-4017-ad5c-bd01794fa80d
InstallationDate: Installed on 2014-09-09 (8 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: ASUSTeK COMPUTER INC. TP300LA
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-35-generic.efi.signed root=UUID=b8ae4448-19f8-4b9c-a6ee-ab08efda35fe ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-35.62-generic 3.13.11.6
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-35-generic N/A
 linux-backports-modules-3.13.0-35-generic N/A
 linux-firmware 1.127.5
Tags: trusty
Uname: Linux 3.13.0-35-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip disk lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 05/14/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: TP300LA.202
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: TP300LA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrTP300LA.202:bd05/14/2014:svnASUSTeKCOMPUTERINC.:pnTP300LA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnTP300LA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: TP300LA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1369701/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1369701

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty

apport information

tags: added: apport-collected
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.17 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.17-rc5-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Andreas (andreas-mrosek) wrote :

have installed the new kernel, but wifi dosnt works

tags: kernel-bug-exists-upstream

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

apport information

description: updated
description: updated

shut i work with the Mainline Kernel 3.17 or shut i remove in and use the 3.16?

Andres, could you please perform the apport-collect while booted into the Ubuntu kernel (not the mainline one)?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated
tags: added: latest-bios-202
tags: added: kernel-bug-exists-upstream-3.17-rc5
summary: - no wifi on Asus TP300 with Intel AC 7260 Ubuntu 14.04
+ [Asus TP300LA] no wifi with Intel AC 7260 Ubuntu 14.04

Andreas, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel ?

Please provide a direct URL to your e-mail to the mailing list once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
description: updated
tags: added: cherry-pick
description: updated
Andreas (andreas-mrosek) wrote :

Thank you verry much, problem is solved

Andreas, could you please explain how this is solved precisely?

Mikel (mikel-oiarbideu) wrote :

Dear all,

I got my new Asus Tp300LA but I can not find this file that you are referring to. Can anyone show the directory or give more instructions to solve wifi problems?

Many thanks,

Mikel

PD: by the way, is your keyboard locked when using it in "tablet" mode??

Mikel, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions