4k laptop eDP display not working on newer laptops

Bug #1369633 reported by Robert Hooker on 2014-09-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Robert Hooker

Bug Description

Impact: Some new laptops with 4k screens are starting to use dp 1.2 only feature of supporting 5.4ghz link rates over displayport which was not turned on until 3.15 even though the plumbing for it was (mostly) there. This should only make more devices work since it has to advertise support for the feature in the dpcd. previously dp 1.2 screens which needed 5.4ghz link rates were forced to use 2.7ghz instead, which would not provide enough bandwidth for some high resolution/high bandwidth screens. It only affects haswell for trusty, broadwell is handled through i915_bdw module which already as this fix and the fix was upstream in 3.15-rc1 so utopic is unaffected.

Fix: Allow the 5.4ghz link rate over displayport.

This has been tested on an affected OEM laptop with a 4K display that requires 5.4ghz link rate to light up (without it the display never turns on) as well as 2 other haswell machines to be sure it doesn't regress.

 [ 5.297037] [drm:intel_modeset_stage_output_state] [CONNECTOR:16:eDP-1] to [CRTC:5]
 [ 5.297038] [drm:intel_modeset_affected_pipes] set mode pipe masks: modeset: 1, prepare: 1, disable: 0
 [ 5.297040] [drm:connected_sink_compute_bpp] [CONNECTOR:16:eDP-1] checking for sink bpp constrains
 [ 5.297042] [drm:intel_dp_compute_config] DP link computation with max lane count 4 max bw 14 pixel clock 533250KHz
 [ 5.297045] [drm:intel_dp_compute_config] DP link bw 14 lane count 4 clock 540000 bpp 24
 [ 5.297046] [drm:intel_dp_compute_config] DP link bw required 1279800 available 1728000
 [ 5.297047] [drm:intel_modeset_pipe_config] plane bpp: 24, pipe bpp: 24, dithering: 0

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1369633

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Tim Gardner (timg-tpi) on 2014-09-15
Changed in linux (Ubuntu Trusty):
status: New → Fix Committed
assignee: nobody → Robert Hooker (sarvatt)
Changed in linux (Ubuntu):
status: Incomplete → Fix Released

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Robert Hooker (sarvatt) on 2014-09-30
summary: - 4k laptop eDP display not working on a dell precision m3800
+ 4k laptop eDP display not working on newer laptops
Shih-Yuan Lee (fourdollars) wrote :

I have verified kernel 3.13.0-37.64 from trusty-proposed and it does fix the problem.

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (22.1 KiB)

This bug was fixed in the package linux - 3.13.0-37.64

---------------
linux (3.13.0-37.64) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1372576

  [ dann frazier ]

  * [Config] CONFIG_HW_RANDOM_XGENE=m on arm64

  [ Edward Lin ]

  * SAUCE: Add use_native_backlight quirk for Dell Inspiron 5721/3521
    - LP: #1354253, #1354313

  [ Tim Gardner ]

  * SAUCE: Fix nfs oops stable regression
    - LP: #1348670
  * [Config] Add mpt3sas to d-i
    - LP: #1368907
  * [Config] CONFIG_X86_16BIT=y
    - LP: #1371601

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to v3.15.8
    - LP: #1359213

  [ Upstream Kernel Changes ]

  * Revert "x86-64, modify_ldt: Make support for 16-bit segments a runtime
    option"
    - LP: #1371601
  * mmc: rtsx: add R1-no-CRC mmc command type handle
    - LP: #1365378
  * rpc_pipe: remove the clntXX dir if creating the pipe fails
    - LP: #1365869
  * sunrpc: add an "info" file for the dummy gssd pipe
    - LP: #1365869
  * rpc_pipe: fix cleanup of dummy gssd directory when notification fails
    - LP: #1365869
  * hwrng: xgene - add support for APM X-Gene SoC RNG support
    - LP: #1365593
  * Documentation: rng: Add X-Gene SoC RNG driver documentation
    - LP: #1365593
  * arm64: dts: add random number generator dts node to APM X-Gene
    platform.
    - LP: #1365593
  * xen/balloon: cancel ballooning if adding new memory failed
    - LP: #1304001
  * x86/xen: resume timer irqs early
    - LP: #1368724
  * xen/manage: Always freeze/thaw processes when suspend/resuming
    - LP: #1368724
  * scsi_transport_sas: move bsg destructor into sas_rphy_remove
    - LP: #1368991
  * drm/i915: Enable 5.4Ghz (HBR2) link rate for Displayport 1.2-capable
    devices
    - LP: #1369633
  * bnx2x: Fix link for KR with swapped polarity lane
    - LP: #1370716
  * drm: add DRM_CAPs for cursor size
    - LP: #1359213
  * drm/dp: Add AUX channel infrastructure
    - LP: #1359213
  * drm/dp: Add drm_dp_dpcd_read_link_status()
    - LP: #1359213
  * drm/dp: Add DisplayPort link helpers
    - LP: #1359213
  * drm/dp: Allow registering AUX channels as I2C busses
    - LP: #1359213
  * drm/dp: let drivers specify the name of the I2C-over-AUX adapter
    - LP: #1359213
  * drm/dp: make aux retries less chatty
    - LP: #1359213
  * Bluetooth: Enable Atheros 0cf3:311e for firmware upload
    - LP: #1371477
  * bnx2x: fix crash during TSO tunneling
    - LP: #1371601
  * inetpeer: get rid of ip_id_count
    - LP: #1371601
  * ip: make IP identifiers less predictable
    - LP: #1371601
  * tcp: Fix integer-overflows in TCP veno
    - LP: #1371601
  * tcp: Fix integer-overflow in TCP vegas
    - LP: #1371601
  * macvlan: Initialize vlan_features to turn on offload support.
    - LP: #1371601
  * net: Correctly set segment mac_len in skb_segment().
    - LP: #1371601
  * iovec: make sure the caller actually wants anything in
    memcpy_fromiovecend
    - LP: #1371601
  * batman-adv: Fix out-of-order fragmentation support
    - LP: #1371601
  * sctp: fix possible seqlock seadlock in sctp_packet_transmit()
    - LP: #1371601
  * sparc64: Fix argument sign extension for compat_sys_futex().
    - LP: #1371601
  ...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in hwe-next:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers