scsi_transport_sas: move bsg destructor into sas_rphy_remove

Bug #1368991 reported by andrew bezella on 2014-09-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Trusty
Medium
Tim Gardner
Utopic
Medium
Unassigned

Bug Description

hello -

we had a freshly installed 14.04.1 server run into disk access issues after swapping out a hard drive. on further investigation, whenever a drive is pulled (on both the mptsas and mpt2sas systems i can test) the included warning is logged.

the message is reproducible simply by pulling a drive, but i have not seen a recurrence of the issue where other drives become unresponsive.

the attached upstream patch ( https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=6aa6caff30f5dcb9e55b03b9710c30b83750cae5 ) has been applied to both 3.12.23 and 3.14.7. when i applied it locally to the packaged linux-source the resulting kernel does not log these warnings.

as it is a fairly trivial patch that has already been applied to other kernel versions upstream, i'm hopeful that it could be included as an SRU.

thank you for your time and effort!

andy

kern :warn : [Thu Sep 11 14:50:08 2014] ------------[ cut here ]------------
kern :warn : [Thu Sep 11 14:50:08 2014] WARNING: CPU: 0 PID: 27756 at /build/buildd/linux-3.13.0/fs/sysfs/group.c:214 sysfs_remove_group+0xc6/0xd0()
kern :warn : [Thu Sep 11 14:50:08 2014] sysfs group ffffffff81cabde0 not found for kobject 'end_device-6:1:23'
kern :warn : [Thu Sep 11 14:50:08 2014] Modules linked in: drbd lru_cache libcrc32c 8021q garp mrp autofs4 ib_iser rdma_cm iw_cm ib_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi nfsv3 sch_sfq nfsd auth_rpcgss nfs_acl nfs lockd sunrpc fscache bridge stp llc bonding gpio_ich joydev intel_powerclamp dm_multipath coretemp scsi_dh kvm_intel kvm i7core_edac lpc_ich vhost_net edac_core ioatdma serio_raw vhost macvtap macvlan mac_hid ipmi_si ipmi_devintf usbkbd ses enclosure raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor async_tx xor hid_generic usbhid hid raid6_pq raid1 igb raid0 mptsas i2c_algo_bit mptscsih ahci multipath dca ptp mptbase libahci psmouse linear scsi_transport_sas pps_core
kern :warn : [Thu Sep 11 14:50:08 2014] CPU: 0 PID: 27756 Comm: kworker/u49:6 Not tainted 3.13.0-35-generic #62-Ubuntu
kern :warn : [Thu Sep 11 14:50:08 2014] Hardware name: Supermicro X8DT3/X8DT3, BIOS 2.0a 09/14/2010
kern :warn : [Thu Sep 11 14:50:08 2014] Workqueue: mpt/0 mptsas_firmware_event_work [mptsas]
kern :warn : [Thu Sep 11 14:50:08 2014] 0000000000000009 ffff880126a01ac8 ffffffff8171e320 ffff880126a01b10
kern :warn : [Thu Sep 11 14:50:08 2014] ffff880126a01b00 ffffffff8106775d 0000000000000000 ffffffff81cabde0
kern :warn : [Thu Sep 11 14:50:08 2014] ffff880bf9410c10 ffff880bf986e400 5003048000d2e6da ffff880126a01b60
kern :warn : [Thu Sep 11 14:50:08 2014] Call Trace:
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8171e320>] dump_stack+0x45/0x56
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8106775d>] warn_slowpath_common+0x7d/0xa0
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff810677cc>] warn_slowpath_fmt+0x4c/0x50
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff81234b3e>] ? sysfs_get_dirent_ns+0x4e/0x70
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff81235e26>] sysfs_remove_group+0xc6/0xd0
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8149bb23>] dpm_sysfs_remove+0x43/0x50
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff81491525>] device_del+0x45/0x1c0
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff814916be>] device_unregister+0x1e/0x60
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff813507de>] bsg_unregister_queue+0x5e/0xa0
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffffa001516c>] sas_rphy_free+0xac/0xe0 [scsi_transport_sas]
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffffa0017085>] sas_port_delete+0x35/0x170 [scsi_transport_sas]
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff81235033>] ? sysfs_remove_link+0x23/0x30
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffffa009e745>] mptsas_del_end_device+0x185/0x270 [mptsas]
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffffa00a45d4>] mptsas_hotplug_work+0x1f4/0x9b0 [mptsas]
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffffa00a56c1>] mptsas_firmware_event_work+0x3e1/0xf4c [mptsas]
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8101b763>] ? native_sched_clock+0x13/0x80
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8101b7d9>] ? sched_clock+0x9/0x10
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8109d415>] ? sched_clock_cpu+0xb5/0x100
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff810125c6>] ? __switch_to+0x126/0x4c0
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff810839d2>] process_one_work+0x182/0x450
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff810847c1>] worker_thread+0x121/0x410
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff810846a0>] ? rescuer_thread+0x430/0x430
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8108b4a2>] kthread+0xd2/0xf0
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8108b3d0>] ? kthread_create_on_node+0x1c0/0x1c0
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8172ecbc>] ret_from_fork+0x7c/0xb0
kern :warn : [Thu Sep 11 14:50:08 2014] [<ffffffff8108b3d0>] ? kthread_create_on_node+0x1c0/0x1c0
kern :warn : [Thu Sep 11 14:50:08 2014] ---[ end trace ad4ab1f037505d41 ]---

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-35-generic 3.13.0-35.62
ProcVersionSignature: Ubuntu 3.13.0-35.62-generic 3.13.11.6
Uname: Linux 3.13.0-35-generic x86_64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Sep 10 10:02 seq
 crw-rw---- 1 root audio 116, 33 Sep 10 10:02 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Date: Fri Sep 12 15:35:25 2014
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
MachineType: Supermicro X8DT6
PciMultimedia:

ProcEnviron:
 TERM=rxvt-unicode-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/zsh
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-35-generic root=/dev/md0 ro consoleblank=0 console=tty0 console=ttyS2,115200n8 nomdmonddf nomdmonisw bootdegraded=true
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-35-generic N/A
 linux-backports-modules-3.13.0-35-generic N/A
 linux-firmware 1.127.5
RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/15/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2.0c
dmi.board.asset.tag: 1234567890
dmi.board.name: X8DT6
dmi.board.vendor: Supermicro
dmi.board.version: 1234567890
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 17
dmi.chassis.vendor: Supermicro
dmi.chassis.version: 1234567890
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2.0c:bd05/15/2012:svnSupermicro:pnX8DT6:pvr1234567890:rvnSupermicro:rnX8DT6:rvr1234567890:cvnSupermicro:ct17:cvr1234567890:
dmi.product.name: X8DT6
dmi.product.version: 1234567890
dmi.sys.vendor: Supermicro

andrew bezella (abezella) wrote :
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: patch
Tim Gardner (timg-tpi) on 2014-09-15
Changed in linux (Ubuntu Utopic):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi) on 2014-09-15
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Trusty):
importance: Undecided → Medium
Changed in linux (Ubuntu Utopic):
importance: Undecided → Medium
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
andrew bezella (abezella) wrote :

the kernel from linux-image-3.13.0-37-generic does indeed eliminate that error. thank you!

tag updated to: verification-done-trusty

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (22.1 KiB)

This bug was fixed in the package linux - 3.13.0-37.64

---------------
linux (3.13.0-37.64) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1372576

  [ dann frazier ]

  * [Config] CONFIG_HW_RANDOM_XGENE=m on arm64

  [ Edward Lin ]

  * SAUCE: Add use_native_backlight quirk for Dell Inspiron 5721/3521
    - LP: #1354253, #1354313

  [ Tim Gardner ]

  * SAUCE: Fix nfs oops stable regression
    - LP: #1348670
  * [Config] Add mpt3sas to d-i
    - LP: #1368907
  * [Config] CONFIG_X86_16BIT=y
    - LP: #1371601

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to v3.15.8
    - LP: #1359213

  [ Upstream Kernel Changes ]

  * Revert "x86-64, modify_ldt: Make support for 16-bit segments a runtime
    option"
    - LP: #1371601
  * mmc: rtsx: add R1-no-CRC mmc command type handle
    - LP: #1365378
  * rpc_pipe: remove the clntXX dir if creating the pipe fails
    - LP: #1365869
  * sunrpc: add an "info" file for the dummy gssd pipe
    - LP: #1365869
  * rpc_pipe: fix cleanup of dummy gssd directory when notification fails
    - LP: #1365869
  * hwrng: xgene - add support for APM X-Gene SoC RNG support
    - LP: #1365593
  * Documentation: rng: Add X-Gene SoC RNG driver documentation
    - LP: #1365593
  * arm64: dts: add random number generator dts node to APM X-Gene
    platform.
    - LP: #1365593
  * xen/balloon: cancel ballooning if adding new memory failed
    - LP: #1304001
  * x86/xen: resume timer irqs early
    - LP: #1368724
  * xen/manage: Always freeze/thaw processes when suspend/resuming
    - LP: #1368724
  * scsi_transport_sas: move bsg destructor into sas_rphy_remove
    - LP: #1368991
  * drm/i915: Enable 5.4Ghz (HBR2) link rate for Displayport 1.2-capable
    devices
    - LP: #1369633
  * bnx2x: Fix link for KR with swapped polarity lane
    - LP: #1370716
  * drm: add DRM_CAPs for cursor size
    - LP: #1359213
  * drm/dp: Add AUX channel infrastructure
    - LP: #1359213
  * drm/dp: Add drm_dp_dpcd_read_link_status()
    - LP: #1359213
  * drm/dp: Add DisplayPort link helpers
    - LP: #1359213
  * drm/dp: Allow registering AUX channels as I2C busses
    - LP: #1359213
  * drm/dp: let drivers specify the name of the I2C-over-AUX adapter
    - LP: #1359213
  * drm/dp: make aux retries less chatty
    - LP: #1359213
  * Bluetooth: Enable Atheros 0cf3:311e for firmware upload
    - LP: #1371477
  * bnx2x: fix crash during TSO tunneling
    - LP: #1371601
  * inetpeer: get rid of ip_id_count
    - LP: #1371601
  * ip: make IP identifiers less predictable
    - LP: #1371601
  * tcp: Fix integer-overflows in TCP veno
    - LP: #1371601
  * tcp: Fix integer-overflow in TCP vegas
    - LP: #1371601
  * macvlan: Initialize vlan_features to turn on offload support.
    - LP: #1371601
  * net: Correctly set segment mac_len in skb_segment().
    - LP: #1371601
  * iovec: make sure the caller actually wants anything in
    memcpy_fromiovecend
    - LP: #1371601
  * batman-adv: Fix out-of-order fragmentation support
    - LP: #1371601
  * sctp: fix possible seqlock seadlock in sctp_packet_transmit()
    - LP: #1371601
  * sparc64: Fix argument sign extension for compat_sys_futex().
    - LP: #1371601
  ...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers