[Hyper-V] reloading LIS Hyper-V modules can result in a kernel panic on Ubuntu 14.10

Bug #1366120 reported by Chris Valean on 2014-09-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Andy Whitcroft
Trusty
Critical
Unassigned
Utopic
Critical
Andy Whitcroft
Vivid
Critical
Andy Whitcroft
linux-lts-utopic (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

Reloading the Hyper-V LIS modules can sometime result in a kernel panic.
Technical details: a hypercall can return “invalid alignment” error if the input parameter spans a page boundary. Updated LIS code handles properly the error without returning bug().

We've triaged this issue internally and the following 2 patches have been created.
Please include them in 14.10 (Utopic Unicorn) daily builds and let us know when we can test.

https://lkml.org/lkml/2014/8/27/725
https://lkml.org/lkml/2014/8/28/649

===
break-fix: - 45d727cee9e200f5b351528b9fb063b69cf702c8
break-fix: - b29ef3546aecb253a5552b198cef23750d56e1e4

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1366120

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Chris Valean (chvale) wrote :

Logs not required

Changed in linux (Ubuntu):
status: Incomplete → New
Tim Gardner (timg-tpi) wrote :

Chris - please email these patches on <email address hidden> when they have been merged to Linus' repo.

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: New → In Progress
tags: added: kernel-da-key kernel-hyper-v
Changed in linux (Ubuntu):
importance: Undecided → Critical
Changed in linux-lts-utopic (Ubuntu):
importance: Undecided → Critical
Andy Whitcroft (apw) on 2014-12-16
Changed in linux-lts-utopic (Ubuntu):
status: New → Confirmed
description: updated
tags: added: kernel-bug-break-fix
Andy Whitcroft (apw) on 2014-12-16
Changed in linux (Ubuntu Utopic):
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Critical
Changed in linux-lts-utopic (Ubuntu Utopic):
status: New → Confirmed
Changed in linux-lts-utopic (Ubuntu Vivid):
importance: Critical → Undecided
Changed in linux-lts-utopic (Ubuntu):
status: Confirmed → Invalid
Changed in linux-lts-utopic (Ubuntu Utopic):
status: Confirmed → Invalid
Changed in linux-lts-utopic (Ubuntu Trusty):
status: New → Confirmed
Changed in linux (Ubuntu Utopic):
status: New → In Progress
Andy Whitcroft (apw) wrote :

These were pulled in via stable updates, and are already released.

Changed in linux (Ubuntu Trusty):
status: New → Fix Released
Changed in linux (Ubuntu Utopic):
status: In Progress → Fix Released
Changed in linux-lts-utopic (Ubuntu Trusty):
status: Confirmed → Invalid
Changed in linux (Ubuntu Vivid):
status: In Progress → Fix Released
tags: removed: kernel-bug-break-fix
Changed in linux (Ubuntu Trusty):
importance: Undecided → Critical
Chris Valean (cvalean) wrote :

This has been re-tested and the bug is no longer present, please close the thread.
Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers