ISST-KVM: R2-0: xmon disabled in Ubuntu

Bug #1365655 reported by bugproxy on 2014-09-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Utopic
Undecided
Tim Gardner

Bug Description

---Problem Description---
The Ubuntu kernels currently have xmon disabled. xmon is a standard debugging interface on power platforms and is expected to be compiled in to enable for debugging. Please enable CONFIG_XMON.

---uname output---
Linux actg1 3.13.0-34-generic #60-Ubuntu SMP Wed Aug 13 15:45:54 UTC 2014 ppc64le ppc64le ppc64le GNU/Linux

Machine Type = 8247-22L

---Steps to Reproduce---
Run the following command:
echo 1 > /proc/sys/kernel/sysrq
Try to invoke xmon by inputting ctrl + o, x
System should drop into xmon, but the following message is printed instead: "[229073.090037] SysRq : This sysrq operation is disabled."

14.10 is also the same:

root@hatg5:~# grep XMON /boot/config-3.16.0-8-generic
# CONFIG_XMON is not set
root@hatg5:~# uname -a
Linux hatg5 3.16.0-8-generic #13-Ubuntu SMP Wed Aug 13 17:11:23 UTC 2014 ppc64le ppc64le ppc64le GNU/Linux

bugproxy (bugproxy) on 2014-09-04
tags: added: architecture-ppc64le bugnameltc-115415 severity-critical targetmilestone-inin1404
Luciano Chavez (lnx1138) on 2014-09-04
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1365655

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty
Luciano Chavez (lnx1138) on 2014-09-05
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Tim Gardner (timg-tpi) wrote :

UBUNTU: [Config] CONFIG_XMON=y

debian.master/config/config.common.ubuntu:CONFIG_XMON=y
debian.master/config/config.common.ubuntu:# CONFIG_XMON_DEFAULT is not set
debian.master/config/config.common.ubuntu:CONFIG_XMON_DISASSEMBLY=y

Changed in linux (Ubuntu Utopic):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-14.20

---------------
linux (3.16.0-14.20) utopic; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1366431

  [ dann frazier ]

  * [Config] CONFIG_HW_RANDOM_XGENE=m on arm64

  [ Manish Chopra ]

  * SAUCE: bnx2x: Configure device endianity on driver load and reset
    endianity on removal.
    - LP: #1356948

  [ Tim Gardner ]

  * [Config] CONFIG_XMON=y
    - LP: #1365655
  * [Config] CONFIG_KVM_BOOK3S_64=m for ppc64el
    - LP: #1362514
  * [Config] CONFIG_KVM_BOOK3S_64_HV=m
    - LP: #1362514

  [ Upstream Kernel Changes ]

  * hwrng: xgene - add support for APM X-Gene SoC RNG support
    - LP: #1365593
  * Documentation: rng: Add X-Gene SoC RNG driver documentation
    - LP: #1365593
  * arm64: dts: add random number generator dts node to APM X-Gene
    platform.
  * KVM: PPC: Book3S: Move vcore definition to end of kvm_arch struct
    - LP: #1362514
  * KVM: Move more code under CONFIG_HAVE_KVM_IRQFD
    - LP: #1362514

  [ Upstream Kernel Changes ]

  * rebase to v3.16.2
    - LP: #1358116
    - LP: #1334950
    - LP: #1350148
 -- Tim Gardner <email address hidden> Sat, 06 Sep 2014 07:52:15 -0700

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers