No card reader support for Realtek RTL8402 [ff00:5286]

Bug #1361086 reported by Adam Lee on 2014-08-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Medium
Unassigned
Trusty
Medium
Adam Lee
linux (Ubuntu)
Medium
Adam Lee
Trusty
Medium
Adam Lee
Utopic
Medium
Adam Lee

Bug Description

SRU Justification:

Impact: Realtek RTL8402 [ff00:5286], which is widely used by PC vendors, won't work without this fix.
Fix: two patches below coming from upstream, clean cherry-picks.
Testcase: we already tested and delivered the fix by dkms in OEM projects, works well.

commit 56cb3cc1872923b69fdeeb00362b7da4d6cf5590
Author: Micky Ching <email address hidden>
Date: Wed Dec 18 10:03:13 2013 +0800

    mfd: rtsx: Add support for card reader rtl8402

    rtl8402 is much like rtl8411, so just add it to rtl8411.c

    Signed-off-by: Micky Ching <email address hidden>
    Reviewed-by: Dan Carpenter <email address hidden>
    Signed-off-by: Lee Jones <email address hidden>

commit 0da14eeba216932db2e4b8805ab58dae72e44a45
Author: Micky Ching <email address hidden>
Date: Wed Dec 18 10:03:12 2013 +0800

    mfd: rtsx: Add set pull control macro and simplify rtl8411

    Add set pull control macro to reduce code for setting pull control, and
    use a common init function to reduce code for rtl8411.c. So this patch
    is used to just simplify code.

    Signed-off-by: Micky Ching <email address hidden>
    Reviewed-by: Dan Carpenter <email address hidden>
    Signed-off-by: Lee Jones <email address hidden>

Adam Lee (adam8157) on 2014-08-25
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in hwe-next:
assignee: nobody → Adam Lee (adam8157)
importance: Undecided → Medium
Adam Lee (adam8157) on 2014-08-25
Changed in hwe-next:
status: New → In Progress
Changed in hwe-next:
status: In Progress → Fix Released
assignee: Adam Lee (adam8157) → nobody
Adam Lee (adam8157) on 2014-08-25
description: updated
Adam Lee (adam8157) wrote :

patches have been submitted to kernel-team@

Chris J Arges (arges) on 2014-08-26
Changed in linux (Ubuntu Trusty):
assignee: nobody → Adam Lee (adam8157)
Changed in linux (Ubuntu Utopic):
status: In Progress → Fix Released
Adam Lee (adam8157) on 2014-08-27
Changed in linux (Ubuntu Trusty):
importance: Undecided → Medium
status: New → In Progress
Adam Lee (adam8157) on 2014-08-27
description: updated
Tim Gardner (timg-tpi) on 2014-08-27
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Keng-Yu Lin (lexical) wrote :

I tested on an HP AIO suffering from the bug. With linux package 3.13.0-36.63 from the -proposed, the card reader works.

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package linux - 3.13.0-36.63

---------------
linux (3.13.0-36.63) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1365052

  [ Feng Kan ]

  * SAUCE: (no-up) irqchip:gic: change access of gicc_ctrl register to read
    modify write.
    - LP: #1357527
  * SAUCE: (no-up) arm64: optimized copy_to_user and copy_from_user
    assembly code
    - LP: #1358949

  [ Ming Lei ]

  * SAUCE: (no-up) Drop APM X-Gene SoC Ethernet driver
    - LP: #1360140
  * [Config] Drop XGENE entries
    - LP: #1360140
  * [Config] CONFIG_NET_XGENE=m for arm64
    - LP: #1360140

  [ Stefan Bader ]

  * SAUCE: Add compat macro for skb_get_hash
    - LP: #1358162
  * SAUCE: bcache: prevent crash on changing writeback_running
    - LP: #1357295

  [ Suman Tripathi ]

  * SAUCE: (no-up) arm64: Fix the csr-mask for APM X-Gene SoC AHCI SATA PHY
    clock DTS node.
    - LP: #1359489
  * SAUCE: (no-up) ahci_xgene: Skip the PHY and clock initialization if
    already configured by the firmware.
    - LP: #1359501
  * SAUCE: (no-up) ahci_xgene: Fix the link down in first attempt for the
    APM X-Gene SoC AHCI SATA host controller driver.
    - LP: #1359507

  [ Tuan Phan ]

  * SAUCE: (no-up) pci-xgene-msi: fixed deadlock in irq_set_affinity
    - LP: #1359514

  [ Upstream Kernel Changes ]

  * iwlwifi: mvm: Add a missed beacons threshold
    - LP: #1349572
  * mac80211: reset probe_send_count also in HW_CONNECTION_MONITOR case
    - LP: #1349572
  * genirq: Add an accessor for IRQ_PER_CPU flag
    - LP: #1357527
  * arm64: perf: add support for percpu pmu interrupt
    - LP: #1357527
  * cifs: sanity check length of data to send before sending
    - LP: #1283101
  * KVM: nVMX: Pass vmexit parameters to nested_vmx_vmexit
    - LP: #1329434
  * KVM: nVMX: Rework interception of IRQs and NMIs
    - LP: #1329434
  * KVM: vmx: disable APIC virtualization in nested guests
    - LP: #1329434
  * HID: Add transport-driver functions to the USB HID interface.
    - LP: #1353021
  * ahci_xgene: Removing NCQ support from the APM X-Gene SoC AHCI SATA Host
    Controller driver.
    - LP: #1358498
  * fold d_kill() and d_free()
    - LP: #1354234
  * fold try_prune_one_dentry()
    - LP: #1354234
  * new helper: dentry_free()
    - LP: #1354234
  * expand the call of dentry_lru_del() in dentry_kill()
    - LP: #1354234
  * dentry_kill(): don't try to remove from shrink list
    - LP: #1354234
  * don't remove from shrink list in select_collect()
    - LP: #1354234
  * more graceful recovery in umount_collect()
    - LP: #1354234
  * dcache: don't need rcu in shrink_dentry_list()
    - LP: #1354234
  * lift the "already marked killed" case into shrink_dentry_list()
  * split dentry_kill()
    - LP: #1354234
  * expand dentry_kill(dentry, 0) in shrink_dentry_list()
    - LP: #1354234
  * shrink_dentry_list(): take parent's ->d_lock earlier
    - LP: #1354234
  * dealing with the rest of shrink_dentry_list() livelock
    - LP: #1354234
  * dentry_kill() doesn't need the second argument now
    - LP: #1354234
  * dcache: add missing lockdep annotation
    - LP: #1354234
  * fs: convert use of typedef ctl_table to struct ctl_table
 ...

Read more...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers