Support for HMI (Hypervisor Maintenance Interrupt) handling in ubuntu 14.10

Bug #1357108 reported by bugproxy on 2014-08-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Utopic
Undecided
Tim Gardner

Bug Description

---Problem Description---
There is no HMI feature support present in ubuntu distro currently. Upstream kernel now has support for HMI handling in Linux. We want push this support into ubuntu 14.10. The related upstream commit are listed below:

db97eff powerpc/book3s: Fix endianess issue for HMI handling on napping cpus.
bbdb760 powerpc/book3s: handle HMIs for cpus in nap mode.
0ef95b4 powerpc/powernv: Invoke opal call to handle hmi.
0869b6f powerpc/book3s: Add basic infrastructure to handle HMI in Linux.

Please include these commits in ubuntu 14.10

Canonical, the patches (cherry-picked) should apply fine over kernel 3.16

bugproxy (bugproxy) on 2014-08-14
tags: added: architecture-ppc64le bugnameltc-114672 severity-high targetmilestone-inin1410

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1357108/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1357108

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

------- Comment From <email address hidden> 2014-08-18 07:52 EDT-------
(In reply to comment #6)
> Thank you for taking the time to report this bug and helping to make Ubuntu
> better. It seems that your bug report is not filed about a specific source
> package though, rather it is just filed against Ubuntu in general. It is
> important that bug reports be filed about source packages so that people
> interested in the package can find the bugs about it. You can find some
> hints about determining what package your bug might be about at
> https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help
> in the #ubuntu-bugs irc channel on Freenode.

The proposed change is for Ubuntu kernel component and I see that the package selected is "linux" which I guess as per the guideline at https://wiki.ubuntu.com/Bugs/FindRightPackage

---------https://wiki.ubuntu.com/Bugs/FindRightPackage-----------
Kernel

The correct package for bugs about the kernel is linux.
---------https://wiki.ubuntu.com/Bugs/FindRightPackage-----------

Am I missing anything here ?

>
> To change the source package that this bug is filed about visit
> https://bugs.launchpad.net/ubuntu/+bug/1357108/+editstatus and add the
> package name in the text box next to the word Package.
>
> [This is an automated message. I apologize if it reached you
> inappropriately; please just reply to this message indicating so.]

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2014-08-18 08:01 EDT-------
(In reply to comment #7)
> This bug is missing log files that will aid in diagnosing the problem. From
> a terminal window please run:
>
> apport-collect 1357108
>
> and then change the status of the bug to 'Confirmed'.
>
> If, due to the nature of the issue you have encountered, you are unable to
> run this command, please add a comment stating that fact and change the bug
> status to 'Confirmed'.

Th proposed changes adds support for HMI handling in Linux to recover from some of the HMI errors. Without this support system crashes and unable to run above command.

>
> This change has been made by an automated script, maintained by the Ubuntu
> Kernel Team.

Tim Gardner (timg-tpi) on 2014-08-18
Changed in linux (Ubuntu Utopic):
assignee: nobody → Tim Gardner (timg-tpi)
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-10.15

---------------
linux (3.16.0-10.15) utopic; urgency=low

  [ dann frazier ]

  * [debian] Fix regression with ABI subversions and backport

  [ Feng Kan ]

  * SAUCE: (no-up) irqchip:gic: change access of gicc_ctrl register to read
    modify write.
    - LP: #1357527
  * SAUCE: (no-up) arm64: optimized copy_to_user and copy_from_user
    assembly code
    - LP: #1358949

  [ Stefan Bader ]

  * SAUCE: bcache: prevent crash on changing writeback_running
    - LP: #1357295

  [ Tim Gardner ]

  * [Config] CONFIG_XFRM_STATISTICS=y
  * [Config] CONFIG_SECURITY_NETWORK_XFRM=y
  * [Config] CONFIG_SENSORS_IBMPOWERNV=m
    - LP: #1353005
  * Release Tracking Bug
    - LP: #1359783

  [ Upstream Kernel Changes ]

  * intel_idle: Broadwell support
    - LP: #1256170
  * powerpc/book3s: Add basic infrastructure to handle HMI in Linux.
    - LP: #1357108
  * powerpc/powernv: Invoke opal call to handle hmi.
    - LP: #1357108
  * powerpc/book3s: handle HMIs for cpus in nap mode.
    - LP: #1357108
  * powerpc/book3s: Fix endianess issue for HMI handling on napping cpus.
    - LP: #1357108
  * powerpc: Add smp_mb() to arch_spin_is_locked()
    - LP: #1358569
  * powerpc: Add smp_mb()s to arch_spin_unlock_wait()
    - LP: #1358569
  * hwmon: (powerpc/powernv) hwmon driver for power, fan rpm, voltage and
    temperature
    - LP: #1353005
  * tools/testing/selftests/ptrace/peeksiginfo.c: add PAGE_SIZE definition
    - LP: #1358855
  * printk: Add function to return log buffer address and size
    - LP: #1359423
  * powerpc/powernv: Interface to register/unregister opal dump region
    - LP: #1359423
  * bcache: fix crash on shutdown in passthrough mode
    - LP: #1357295
  * bcache: fix uninterruptible sleep in writeback thread
    - LP: #1357295

  [ Vinayak Kale ]

  * SAUCE: (no-up) dt-bindings: Add Potenza PMU binding
    - LP: #1357527
  * SAUCE: (no-up) arm64: dts: Add PMU node for APM X-Gene Storm SOC
    - LP: #1357527
 -- Tim Gardner <email address hidden> Fri, 15 Aug 2014 12:34:33 -0600

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
bugproxy (bugproxy) on 2014-12-12
tags: added: targetmilestone-inin1504
removed: targetmilestone-inin1410
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers