bnx2x crashes on bxn2x_tpa_start

Bug #1353105 reported by bugproxy on 2014-08-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Trusty
Medium
Andy Whitcroft
Utopic
Medium
Andy Whitcroft

Bug Description

[Impact]

Random crashes when using the bnx2x driver on power 8

[Test Case]

heavy use of the bnx2x driver on power 8

[Regression Potential]

introduces a simple memory barrier and is therefore very low risk, any such risk would normally affect performanc e not function.

===

---Problem Description---
bnx2x may cause crashes or stop working because of a missing memory barrier.

Messages like the following appear on the log:

bnx2x: [bnx2x_tpa_start:392(eth7)]start of bin not in stop [0]

---uname output---
Linux ubuntu 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:50:31 UTC 2014 ppc64le ppc64le ppc64le GNU/Linux

---Additional Hardware Info---
0001:00:03.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM57800 1/10 Gigabit Ethernet (rev 10)
0001:00:03.1 Ethernet controller: Broadcom Corporation NetXtreme II BCM57800 1/10 Gigabit Ethernet (rev 10)
0001:00:03.2 Ethernet controller: Broadcom Corporation NetXtreme II BCM57800 1/10 Gigabit Ethernet (rev 10)
0001:00:03.3 Ethernet controller: Broadcom Corporation NetXtreme II BCM57800 1/10 Gigabit Ethernet (rev 10)

Machine Type = model : IBM pSeries (emulated by qemu)

---Steps to Reproduce---
 Send lots of traffic on a busy workload.

Fix for reported issue upstream commit 9aaae044abe95de182d09004cc3fa181bf22e6e0
Fix for EEH related issue upstream commit 0c0e63410a393aae4b615849625f539db775d586

We would like to get those applied to both Ubuntu 14.04 updates and Ubuntu 14.10, please.

Cascardo.

Default Comment by Bridge

tags: added: architecture-ppc64 bugnameltc-114217 severity-high targetmilestone-inin1404

Default Comment by Bridge

Luciano Chavez (lnx1138) on 2014-08-05
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: ppc64el
Andy Whitcroft (apw) on 2014-08-21
Changed in linux (Ubuntu Trusty):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Andy Whitcroft (apw)
Changed in linux (Ubuntu Utopic):
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Both of these patches are in v3.16-rc1 and therefore in Utopic already.

Changed in linux (Ubuntu Utopic):
status: Confirmed → Fix Released
Andy Whitcroft (apw) wrote :

Proposing these patches for SRU to trusty.

Changed in linux (Ubuntu Trusty):
status: Confirmed → In Progress
Andy Whitcroft (apw) on 2014-08-21
description: updated
Andy Whitcroft (apw) on 2014-08-21
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: architecture-ppc64le
removed: architecture-ppc64
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package linux - 3.13.0-36.63

---------------
linux (3.13.0-36.63) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1365052

  [ Feng Kan ]

  * SAUCE: (no-up) irqchip:gic: change access of gicc_ctrl register to read
    modify write.
    - LP: #1357527
  * SAUCE: (no-up) arm64: optimized copy_to_user and copy_from_user
    assembly code
    - LP: #1358949

  [ Ming Lei ]

  * SAUCE: (no-up) Drop APM X-Gene SoC Ethernet driver
    - LP: #1360140
  * [Config] Drop XGENE entries
    - LP: #1360140
  * [Config] CONFIG_NET_XGENE=m for arm64
    - LP: #1360140

  [ Stefan Bader ]

  * SAUCE: Add compat macro for skb_get_hash
    - LP: #1358162
  * SAUCE: bcache: prevent crash on changing writeback_running
    - LP: #1357295

  [ Suman Tripathi ]

  * SAUCE: (no-up) arm64: Fix the csr-mask for APM X-Gene SoC AHCI SATA PHY
    clock DTS node.
    - LP: #1359489
  * SAUCE: (no-up) ahci_xgene: Skip the PHY and clock initialization if
    already configured by the firmware.
    - LP: #1359501
  * SAUCE: (no-up) ahci_xgene: Fix the link down in first attempt for the
    APM X-Gene SoC AHCI SATA host controller driver.
    - LP: #1359507

  [ Tuan Phan ]

  * SAUCE: (no-up) pci-xgene-msi: fixed deadlock in irq_set_affinity
    - LP: #1359514

  [ Upstream Kernel Changes ]

  * iwlwifi: mvm: Add a missed beacons threshold
    - LP: #1349572
  * mac80211: reset probe_send_count also in HW_CONNECTION_MONITOR case
    - LP: #1349572
  * genirq: Add an accessor for IRQ_PER_CPU flag
    - LP: #1357527
  * arm64: perf: add support for percpu pmu interrupt
    - LP: #1357527
  * cifs: sanity check length of data to send before sending
    - LP: #1283101
  * KVM: nVMX: Pass vmexit parameters to nested_vmx_vmexit
    - LP: #1329434
  * KVM: nVMX: Rework interception of IRQs and NMIs
    - LP: #1329434
  * KVM: vmx: disable APIC virtualization in nested guests
    - LP: #1329434
  * HID: Add transport-driver functions to the USB HID interface.
    - LP: #1353021
  * ahci_xgene: Removing NCQ support from the APM X-Gene SoC AHCI SATA Host
    Controller driver.
    - LP: #1358498
  * fold d_kill() and d_free()
    - LP: #1354234
  * fold try_prune_one_dentry()
    - LP: #1354234
  * new helper: dentry_free()
    - LP: #1354234
  * expand the call of dentry_lru_del() in dentry_kill()
    - LP: #1354234
  * dentry_kill(): don't try to remove from shrink list
    - LP: #1354234
  * don't remove from shrink list in select_collect()
    - LP: #1354234
  * more graceful recovery in umount_collect()
    - LP: #1354234
  * dcache: don't need rcu in shrink_dentry_list()
    - LP: #1354234
  * lift the "already marked killed" case into shrink_dentry_list()
  * split dentry_kill()
    - LP: #1354234
  * expand dentry_kill(dentry, 0) in shrink_dentry_list()
    - LP: #1354234
  * shrink_dentry_list(): take parent's ->d_lock earlier
    - LP: #1354234
  * dealing with the rest of shrink_dentry_list() livelock
    - LP: #1354234
  * dentry_kill() doesn't need the second argument now
    - LP: #1354234
  * dcache: add missing lockdep annotation
    - LP: #1354234
  * fs: convert use of typedef ctl_table to struct ctl_table
 ...

Read more...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) on 2014-09-29
tags: added: verification-done-trusty
removed: verification-needed-trusty
bugproxy (bugproxy) on 2014-12-15
tags: added: targetmilestone-inin14041
removed: targetmilestone-inin1404
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers