sensors command is not getting executed in Ubuntu 14.10 Non Virtualised environment

Bug #1353005 reported by bugproxy on 2014-08-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Utopic
Medium
Tim Gardner

Bug Description

---Problem Description---
sensors command is not getting executed in Ubuntu 14.10

---uname output---
Linux lep8d 3.16.0-6-generic #11-Ubuntu SMP Mon Jul 28 02:00:45 UTC 2014 ppc64le ppc64le ppc64le GNU/Linux

Machine Type = P8

---Steps to Reproduce---
Install Ubuntu 14.10 iso on local hard disk of P8 machine in Non Virtualised environment.
Install the lm-sensors ppc64le package on the same.

root@lep8d:~# sensors
No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.
root@lep8d:~# echo $?
1

root@lep8d:~# sensors-detect
# sensors-detect revision 6170 (2013-05-20 21:25:22 +0200)
# DMI data unavailable, please consider installing dmidecode 2.7
# or later for better results.

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no): YES
modprobe: FATAL: Module cpuid not found.
Failed to load module cpuid.
Silicon Integrated Systems SIS5595... No
VIA VT82C686 Integrated Sensors... No
VIA VT8231 Integrated Sensors... No
AMD K8 thermal sensors... No
AMD Family 10h thermal sensors... No
AMD Family 11h thermal sensors... No
AMD Family 12h and 14h thermal sensors... No
AMD Family 15h thermal sensors... No
AMD Family 15h power sensors... No
AMD Family 16h power sensors... No
Intel digital thermal sensor... No
Intel AMB FB-DIMM thermal sensor... No
VIA C7 thermal sensor... No
VIA Nano thermal sensor... No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): YES
Sorry, no supported PCI bus adapters found.
Module i2c-dev loaded successfully.

Sorry, no sensors were detected.
Either your system has no sensors, or they are not supported, or
they are connected to an I2C or SMBus adapter that is not
supported. If you find out what chips are on your board, check
http://www.lm-sensors.org/wiki/Devices for driver status.

After a big more digging I see: in Ubuntu where it is failing, there is:

$ cat /boot/config-3.16.0-6-generic | grep -i sensor | grep -i ibm
CONFIG_SENSORS_IBMAEM=m
CONFIG_SENSORS_IBMPEX=m

And in PowerKVM where it is working, there is:

$ cat /boot/config-3.10.42-2004.pkvm2_1_1.8.ppc64 | grep -i sensors | grep -i ibm
CONFIG_SENSORS_IBMAEM=m
CONFIG_SENSORS_IBMPEX=m
CONFIG_SENSORS_IBMPOWERNV=y

So now I think problem is: Ubuntu is missing "ibmpowernv", i.e. the powernv hwmon driver for sensors, as described here:

http://lists.lm-sensors.org/pipermail/lm-sensors/2014-May/041867.html

Adding to copy: Neelesh Gupta, who is author of this module.

Neelesh: Am I correct that this is the missing module in Ubuntu? Is there a kernel patch Ubuntu needs to pick up, or perhaps they already have the patch but just need to fix their kernel config? Thx -DaveH.

Yes, 'ibmpowernv' module is missing from Ubuntu 14.10.
It's already been applied to the -next tree and should be available to mainline soon.

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-114041 severity-high targetmilestone-inin1410
Luciano Chavez (lnx1138) on 2014-08-05
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1353005

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Luciano Chavez (lnx1138) on 2014-08-05
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

------- Comment From <email address hidden> 2014-08-06 14:10 EDT-------
Here is a more recent reference to the required patch: Thx.

https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/?id=c8caf266ad76e596c8bda8e52ece769547a98cac

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: ppc64el
Anton Blanchard (anton-samba) wrote :

It is now upstream, commit:

24c1aa858792 (hwmon: (powerpc/powernv) hwmon driver for power, fan rpm, voltage and temperature)

Tim Gardner (timg-tpi) on 2014-08-19
Changed in linux (Ubuntu Utopic):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-10.15

---------------
linux (3.16.0-10.15) utopic; urgency=low

  [ dann frazier ]

  * [debian] Fix regression with ABI subversions and backport

  [ Feng Kan ]

  * SAUCE: (no-up) irqchip:gic: change access of gicc_ctrl register to read
    modify write.
    - LP: #1357527
  * SAUCE: (no-up) arm64: optimized copy_to_user and copy_from_user
    assembly code
    - LP: #1358949

  [ Stefan Bader ]

  * SAUCE: bcache: prevent crash on changing writeback_running
    - LP: #1357295

  [ Tim Gardner ]

  * [Config] CONFIG_XFRM_STATISTICS=y
  * [Config] CONFIG_SECURITY_NETWORK_XFRM=y
  * [Config] CONFIG_SENSORS_IBMPOWERNV=m
    - LP: #1353005
  * Release Tracking Bug
    - LP: #1359783

  [ Upstream Kernel Changes ]

  * intel_idle: Broadwell support
    - LP: #1256170
  * powerpc/book3s: Add basic infrastructure to handle HMI in Linux.
    - LP: #1357108
  * powerpc/powernv: Invoke opal call to handle hmi.
    - LP: #1357108
  * powerpc/book3s: handle HMIs for cpus in nap mode.
    - LP: #1357108
  * powerpc/book3s: Fix endianess issue for HMI handling on napping cpus.
    - LP: #1357108
  * powerpc: Add smp_mb() to arch_spin_is_locked()
    - LP: #1358569
  * powerpc: Add smp_mb()s to arch_spin_unlock_wait()
    - LP: #1358569
  * hwmon: (powerpc/powernv) hwmon driver for power, fan rpm, voltage and
    temperature
    - LP: #1353005
  * tools/testing/selftests/ptrace/peeksiginfo.c: add PAGE_SIZE definition
    - LP: #1358855
  * printk: Add function to return log buffer address and size
    - LP: #1359423
  * powerpc/powernv: Interface to register/unregister opal dump region
    - LP: #1359423
  * bcache: fix crash on shutdown in passthrough mode
    - LP: #1357295
  * bcache: fix uninterruptible sleep in writeback thread
    - LP: #1357295

  [ Vinayak Kale ]

  * SAUCE: (no-up) dt-bindings: Add Potenza PMU binding
    - LP: #1357527
  * SAUCE: (no-up) arm64: dts: Add PMU node for APM X-Gene Storm SOC
    - LP: #1357527
 -- Tim Gardner <email address hidden> Fri, 15 Aug 2014 12:34:33 -0600

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers