0489:e078 - Qualcom Atheros - Ubuntu 14.04 bluetooth not working

Bug #1352821 reported by bala
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Precise
Medium
Joseph Salisbury
Trusty
Medium
Joseph Salisbury
Utopic
Medium
Joseph Salisbury
Vivid
Medium
Joseph Salisbury

Bug Description

Hi,

Nature of peoblem : Bluetooth not wotrking under Ubuntu 14.04 but wifi working fine. pls help to provide the solution

Vendor ID : 0489:e078
Make of Wifi BT combo : Qualcom Atheros QCA9565 /AR9565

Regds,
Bala S

===
break-fix: - 4b552bc9edfdc947862af225a0e2521edb5d37a0

Revision history for this message
bala (balamurugans123) wrote :

Hi,

LSPCI and LSUSB details attached .

Regds,
Bala S

Martin Pitt (pitti)
affects: udisks2 (Ubuntu) → bluez (Ubuntu)
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "lcpsi.jpg" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Revision history for this message
darryn.smith (darryn-smith) wrote :

On my system - 14.04 - kernel 3.13.0-24-generic:

Bluetooth adapter is detected:

hciconfig shows hci0 Type: BR/EDR Bus: USB
with a BD Address, and MTU
Up Running

rfkill list shows:

0: hci0: Bluetooth
Soft Block: no
Hard Block: no

hcitool scan
Scanning ...

Does not discover any bluetooth devices.

Revision history for this message
bala (balamurugans123) wrote :

Dear All,

Pls help me to provide the solution for BT issue.

Wifi is working but bluetooth not working.

Regds,
Bala S

Revision history for this message
bala (balamurugans123) wrote :

Hi,

My wifi information attached .

Regds,
Bala S

Revision history for this message
bala (balamurugans123) wrote :

Dear All,

Pls help to provide the solution for the Bluetooth issue .

Regds,
Bala S

Revision history for this message
Liam Jack (cuonic) wrote :

The issue is still not fixed, using Ubuntu 14.10 with 3.16.0-24-generic kernel.

I've tried changing the DeviceID in /etc/bluetooth/main.conf with no success, the system seems to think everything is running correctly.

Here is some data I collected : http://pastebin.com/E0Q05x0D

Revision history for this message
Valentine A. (antteor) wrote :

I have the same problem in xubuntu 14.04 - 3.13.0-43-generic on Acer ES1-511 with Qualcom Atheros QCA9565 /AR9565

Revision history for this message
Galambos Máté (matega) wrote :

I have the same probem on Ubuntu Gnome x64 14.10 3.16.0-28-generic on Acer E3-111, also with Atheros QCA9565/AR9565. Please let me know if I can be of any help to diagnose and repair this issue.

Galambos Máté (matega)
tags: removed: patch
Revision history for this message
Galambos Máté (matega) wrote :

Hey people, I (with a lot of help from a very helpful askubuntu user, user300665) managed to get Bluetooth working. It is relatively simple, you just have to add the USB vendor ID into the btusb and ath3k modules. I'm submitting a patch here in a few moments.

Revision history for this message
Galambos Máté (matega) wrote :

Kernel modules ath3k and btusb are missing the necessary device descriptions

affects: bluez (Ubuntu) → linux (Ubuntu)
Revision history for this message
Galambos Máté (matega) wrote :
Revision history for this message
Galambos Máté (matega) wrote :

I have attached a patch which fixes the issue for me. Please notify me if I did anything wrong, I am quite new at this. Also, please contact me if I can be of any help in integrating this into the official kernel.

Revision history for this message
Galambos Máté (matega) wrote :

Sadly, after a reboot this no longer works and I have no idea why.

Revision history for this message
Galambos Máté (matega) wrote :

This time I got it right. The USB vendor:product description needs to be in the blacklist section of the btusb file; it only worked by chance the first time I tried; now it works after a reboot. (We have to prevent btusb from managing this before its firmware is loaded or whatever, see ath3k on wireless.kernel.org)

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.19 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.19-rc2-vivid/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: trusty
tags: added: kernel-key
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-da-key
removed: kernel-key
Galambos Máté (matega)
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Incomplete
Revision history for this message
Galambos Máté (matega) wrote :

Hi,
Sorry for taking this long to respond. I've tested both the kernel you suggested and the one after it (3.19-rc3-vivid), and Bluetooth worked in both. Also Bluetooth worked in my current kernel (3.16.0-28) with the original modules moved back and also the older kernel present on my system (3.16.0-23). In the meantime a couple of packages were updated, including linux-firmware, which may have something to do with it. I'll try downgrading that and see if it re-introduces the bug.

Revision history for this message
Galambos Máté (matega) wrote :

Update: I was wrong. While testing the issue I only restarted my machine which did not power cycle the Bluetooth radio, so it probably retained its firmware between reboots and it worked regardless of the kernel I used. It turns out a proper shutdown and restart re-introduces the bug on 3.16.* (unpatched), but Bluetooth is indeed working on 3.19-*. Also, the version of linux-firmware has nothing to do with it. I'll now tag this bug report accordingly; that is, add the 'confirmed' and 'kernel-fixed-upstream' tags.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-fixed-upstream utopic
Revision history for this message
jamie (jgwild) wrote :

This affects me on a HP6715b laptop. The Bluetooth that worked in 12.04 is not detected in 14.04
My wifi works but is shown as a Broadcom BCM4311 so I'm not sure about the "Integrated Module" below.

 usb_device.vendor_id = 1008 (0x3f0)
  usb_device.product_id = 5917 (0x171d)
  usb_device.vendor = 'Hewlett-Packard'
  info.vendor = 'Hewlett-Packard'
  usb_device.device_revision_bcd = 256 (0x100)
  usb_device.max_power = 0 (0x0)
  usb_device.product = 'Wireless (Bluetooth + WLAN) Interface [Integrated Module]'

I started a thread on the Ubuntu forum which has a few more details.
http://ubuntuforums.org/showthread.php?t=2260024&p=13205814#post13205814

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Can you see if this issue also occurs with the latest 3.13 upstream version? It can be downloaded from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13.11-ckt13-trusty/

If the bug does still exist, we can perform a reverse bisect to identify the commit that fixes this in 3.19.

Revision history for this message
Galambos Máté (matega) wrote :

I've since upgraded to the 3.16.0-29 kernel. Bluetooth still doesn't work with it, but my patch still fixes it. Upon a power cycle, ath3k did not load automatically, but with a modprobe it loaded and worked. Running depmod fixed that too. I also tried the 3.13.11-ckt13-trusty kernel you posted. The bug exists in it.

Jamie (jgwild), your Bluetooth chip has a different USB V/PID, different Bluetooth chip manufacturer, and the problem causes entirely different symptoms (detected, but non-functional / not even detected). Although I'm no authority on this, I think your problem will not be fixed by this bug report as it seems to be entirely unrelated; I think you will get better results by opening a new one.

Revision history for this message
Jeremy (wa113y3s) wrote :
Revision history for this message
Galambos Máté (matega) wrote :

Yes, that must be it, it matches my patch. http://git.kernel.org/cgit/linux/kernel/git/bluetooth/bluetooth-next.git/commit/?id=4b552bc9edfdc947862af225a0e2521edb5d37a0 shows both files, not just ath3k.c - I was confused at first when I opened the link above.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Jukka Niiranen (jukka-niiranen-fi) wrote :

I'm having the same issue with:
Acer Aspire V3-371 running Ubuntu 14.10 kernel: 3.16.0-29-generic

lspci -nnk printout includes this:
02:00.0 Network controller [0280]: Qualcomm Atheros AR9462 Wireless Network Adapter [168c:0034] (rev 01)
 Subsystem: Foxconn International, Inc. Device [105b:e07d]
 Kernel driver in use: ath9k

and lsusb printout includes this:
Bus 002 Device 002: ID 0489:e076 Foxconn / Hon Hai

Problem: WiFi works perfectly and Bluetooth seems to work, but doesn't see any Bluetooth devices like mouse or phone.

Revision history for this message
Cosmin Giurgiu (cosmingiurgiu) wrote :

WIFI working BT cannot find any device. Details :

dmidecode -t system
# dmidecode 2.12
# SMBIOS entry point at 0x000f04c0
SMBIOS 2.7 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
 Manufacturer: ASUSTeK COMPUTER INC.
 Product Name: G56JK
 Version: 1.0
 SKU Number: ASUS-NotebookSKU
 Family: G

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.10
Release: 14.10
Codename: utopic

uname -a
Linux cosming-G56JK 3.16.0-30-generic #40-Ubuntu SMP Mon Jan 12 22:06:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

lspci -nnk | grep -A 2 Atheros
03:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
 Subsystem: Lite-On Communications Inc Device [11ad:0652]
 Kernel driver in use: ath9k

Changed in linux (Ubuntu Trusty):
status: New → Triaged
Changed in linux (Ubuntu Utopic):
status: New → Triaged
Changed in linux (Ubuntu Trusty):
importance: Undecided → Medium
Changed in linux (Ubuntu Utopic):
importance: Undecided → Medium
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Commit 4b552bc9edfdc947862af225a0e2521edb5d37a0 is in mainline as of 3.19-rc1. Vivid will pick up this fix and it gets rebased to 3.19.

However, the patch was no cc'd to stable, so we need to submit and SRU request for Utopic and Trusty. A request should also be sent to stable for inclusion in the stable kernels.

I built a Utopic test kernel with a cherry-pick of 4b552bc. Can folks affected by this bug test this kernel and post back? It can be downloaded from:

http://kernel.ubuntu.com/~jsalisbury/lp1352821/

If it fixes this bug, I'll submit the SRU requests and request for inclusion in upstream stable kernels.

Note that you will need to install both the linux-image and linux-image-extra .deb packages.

Revision history for this message
Jukka Niiranen (jukka-niiranen-fi) wrote :

Followed Joseph's advice and installed both linux-image and linux-image-extra packages from ...~jsalisbury...

NOW:
~$ uname -a
Linux Cake 3.16.0-31-generic #41~lp1352821v1 SMP Fri Feb 20 20:52:34 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

But unfortunately this had no effect on Bluetooth's ability to find any devices. Situation is still the same as in my post above. Everything seems to work ok, WiFi actually works, Bluetooth doesn't see any devices. I've tried to connect mouse and phone, no luck. Same devices connect correctly to another Ubuntu laptop.

Environment:
------------------------------------------------------------
Acer Aspire V3-371, Ubuntu 14.10.

lspci -nnk printout includes this:
02:00.0 Network controller [0280]: Qualcomm Atheros AR9462 Wireless Network Adapter [168c:0034] (rev 01)
 Subsystem: Foxconn International, Inc. Device [105b:e07d]
 Kernel driver in use: ath9k

and lsusb printout includes this:
Bus 002 Device 002: ID 0489:e076 Foxconn / Hon H

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

@Jukka, the test kernel was specifically for the 0489:e078 device. However, looking at your output, you seem to have 0489:e076. Can you open a separate bug, and I'll create a patch.

@bala, does the test kernel get bluetooth working for you?

Revision history for this message
Jukka Niiranen (jukka-niiranen-fi) wrote :

@Joseph, thanks for the advice.

I've now opened a separate bug about the same issue with 0489:e076 here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1425252

Changed in linux (Ubuntu):
status: Triaged → In Progress
Changed in linux (Ubuntu Trusty):
status: Triaged → In Progress
Changed in linux (Ubuntu Utopic):
status: Triaged → In Progress
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Trusty):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Utopic):
assignee: nobody → Joseph Salisbury (jsalisbury)
Revision history for this message
Galambos Máté (matega) wrote :

Sorry for taking this long. @jsailsbury , I've just tried the kernel you've uploaded. It fixes Bluetooth for me.

Changed in linux (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Vivid):
status: In Progress → Fix Released
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

A request has been sent upstream for inclusion in all the stable kernels.

Revision history for this message
elichai2 (elichai2) wrote :

So? Is there a quick fix? Thanks!

Revision history for this message
elichai2 (elichai2) wrote :

Does your fix is already in the vivid kernel? (I can install the vivid kernel if needed)
(Now I run Utopic 3.16.0-31-generic)

Revision history for this message
elichai2 (elichai2) wrote :

Sorry for the comments flood, I just can't edit them.
I just wanted to say my device is:
Bus 003 Device 003: ID 0cf3:3004 Atheros Communications, Inc.
  bDeviceClass 224 Wireless
  bDeviceSubClass 1 Radio Frequency
  bDeviceProtocol 1 Bluetooth
  idVendor 0x0cf3 Atheros Communications, Inc.
  idProduct 0x3004

Thanks!

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

@elichai2, the test kernel and patch were specifically created for the 0489:e078 device. However, looking at your comment, you seem to have 0cf3:3004. Your device seems to have been added in an early kernel by commit d9f51b51d.

It would probably be best for you to open a new bug, so we can investigate further.

Revision history for this message
elichai2 (elichai2) wrote :
Andy Whitcroft (apw)
description: updated
tags: added: kernel-bug-break-fix
Andy Whitcroft (apw)
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Trusty):
status: In Progress → Confirmed
Changed in linux (Ubuntu Utopic):
status: In Progress → Fix Committed
Andy Whitcroft (apw)
Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Trusty):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
Andy Whitcroft (apw)
Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
tags: removed: kernel-bug-break-fix
Revision history for this message
thiru (ansumarasu) wrote :

hi every one,

i want to know briefly about bluetooth not working issue on ubuntu.

pls help

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

@thiru, I would suggest opening a new bug if you are having bluetooth issues.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers