Extessive timeout warning on some machines with i915_bdw

Bug #1351014 reported by Robert Hooker on 2014-07-31
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Robert Hooker
linux (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Unassigned

Bug Description

SRU Justification:

Impact: Kernel warning every boot making it seem like the system is faulty but it is harmless. This only applies to i915_bdw on trusty, and is impacting certification on some prerelease machines.
Fix: Upstream increased the timeout required to hit it so it will not affect the machines we have anymore in 3.14, and also demoted it from a warning to DRM_INFO_ONCE.
Testcase: Boot trusty on an affected broadwell machine, check dmesg for warning

[Results]
Expected: There should be no WARNING messages for i915_bdw.
Actual: This warning is displayed

[ 13.157688] ------------[ cut here ]------------
[ 13.157726] WARNING: CPU: 3 PID: 395 at /build/buildd/linux-3.13.0/ubuntu/i915/intel_opregion.c:266 swsci+0x2ec/0x300 [i915_bdw]()
[ 13.157729] excessive driver sleep timeout (DSPL) 1000
[ 13.157732] Modules linked in: crct10dif_pclmul(+) lib80211_crypt_tkip crc32_pclmul ghash_clmulni_intel aesni_intel snd_hda_intel(OF+) snd_hda_controller(OF) aes_x86_64 snd_hda_codec(OF) snd_hwdep lrw gf128mul snd_pcm glue_helper ablk_helper cryptd wl(POF+) lib80211 snd_seq_midi snd_seq_midi_event cfg80211 snd_rawmidi serio_raw i915_bdw(+) snd_seq snd_page_alloc snd_seq_device snd_timer lpc_ich mei_me mei snd soundcore drm_kms_helper drm i2c_algo_bit parport_pc ppdev mac_hid acpi_pad lp parport btrfs xor raid6_pq libcrc32c dm_mirror dm_region_hash dm_log usbhid hid ahci libahci wmi video
[ 13.157779] CPU: 3 PID: 395 Comm: systemd-udevd Tainted: PF O 3.13.0-32-generic #57-Ubuntu
[ 13.157783] Hardware name: Dell Inc. FOOBAR, BIOS R21 07/17/2014
[ 13.157785] 0000000000000009 ffff880156921818 ffffffff8171bcb4 ffff880156921860
[ 13.157790] ffff880156921850 ffffffff810676cd ffffc900106a0218 ffff88003598d800
[ 13.157794] 00000000000001f4 0000000000000008 ffff880156921928 ffff8801569218b0
[ 13.157799] Call Trace:
[ 13.157807] [<ffffffff8171bcb4>] dump_stack+0x45/0x56
[ 13.157812] [<ffffffff810676cd>] warn_slowpath_common+0x7d/0xa0
[ 13.157815] [<ffffffff8106773c>] warn_slowpath_fmt+0x4c/0x50
[ 13.157847] [<ffffffffa02bc21c>] swsci+0x2ec/0x300 [i915_bdw]
[ 13.157870] [<ffffffffa02bd044>] intel_opregion_setup+0x204/0x3f0 [i915_bdw]
[ 13.157903] [<ffffffffa02e2c7f>] i915_driver_load+0x5cf/0xf90 [i915_bdw]
[ 13.157927] [<ffffffffa01a2ce2>] drm_dev_register+0xa2/0x1e0 [drm]
[ 13.157943] [<ffffffffa01a4be2>] drm_get_pci_dev+0x92/0x140 [drm]
[ 13.157966] [<ffffffffa02636eb>] i915_pci_probe+0x3b/0x60 [i915_bdw]
[ 13.157972] [<ffffffff813a61e5>] local_pci_probe+0x45/0xa0
[ 13.157976] [<ffffffff813a7485>] ? pci_match_device+0xc5/0xd0
[ 13.157981] [<ffffffff813a75a9>] pci_device_probe+0xd9/0x130
[ 13.157987] [<ffffffff8149355d>] driver_probe_device+0x12d/0x3e0
[ 13.157991] [<ffffffff814938e3>] __driver_attach+0x93/0xa0
[ 13.157995] [<ffffffff81493850>] ? __device_attach+0x40/0x40
[ 13.158000] [<ffffffff814914c3>] bus_for_each_dev+0x63/0xa0
[ 13.158004] [<ffffffff81492f0e>] driver_attach+0x1e/0x20
[ 13.158007] [<ffffffff81492af0>] bus_add_driver+0x180/0x250
[ 13.158013] [<ffffffffa032f000>] ? 0xffffffffa032efff
[ 13.158017] [<ffffffff81493f64>] driver_register+0x64/0xf0
[ 13.158021] [<ffffffffa032f000>] ? 0xffffffffa032efff
[ 13.158026] [<ffffffff813a5b7c>] __pci_register_driver+0x4c/0x50
[ 13.158039] [<ffffffffa01a4daa>] drm_pci_init+0x11a/0x130 [drm]
[ 13.158044] [<ffffffffa032f000>] ? 0xffffffffa032efff
[ 13.158066] [<ffffffffa032f06a>] i915_init+0x6a/0x6c [i915_bdw]
[ 13.158070] [<ffffffff8100214a>] do_one_initcall+0xfa/0x1b0
[ 13.158076] [<ffffffff810598d3>] ? set_memory_nx+0x43/0x50
[ 13.158082] [<ffffffff810e1f8d>] load_module+0x12dd/0x1b40
[ 13.158087] [<ffffffff810dda30>] ? store_uevent+0x40/0x40
[ 13.158093] [<ffffffff810e2966>] SyS_finit_module+0x86/0xb0
[ 13.158098] [<ffffffff8172c87f>] tracesys+0xe1/0xe6
[ 13.158101] ---[ end trace 5b57c64d53011e99 ]---

[Additional Information]
Base Image: somerville-trusty-amd64-iso-20140620-0.iso
Kernel Version: 3.13.0-32-generic
CPU: Genuine Intel(R) CPU 0000 @ 1.60GHz
GPU: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 06)

Robert Hooker (sarvatt) wrote :
tags: added: trusty

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1351014

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Robert Hooker (sarvatt) on 2014-07-31
description: updated
Brad Figg (brad-figg) on 2014-07-31
Changed in linux (Ubuntu):
status: New → Incomplete
Chris J Arges (arges) on 2014-07-31
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Medium
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Robert Hooker (sarvatt) wrote :

This was verified in 3.13.0-35.62 from trusty-proposed/main by Shih-Yuan Lee. Thanks!

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Released
Changed in hwe-next:
status: New → Fix Released
assignee: nobody → Robert Hooker (sarvatt)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments