Please cherry-pick tc rule fix for userns

Bug #1344049 reported by Stéphane Graber on 2014-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Tim Gardner
Utopic
Undecided
Unassigned

Bug Description

Hello,

I pushed a fix to the mainline kernel which I believe will first be released in 3.16.
This change is required to make setting tc rules inside an unprivileged lxc container (assuming the userns owns a netns).

Commit id is: 4e8bbb819d1594a01f91b1de83321f68d3e6e245

Can we please have this cherry-picked in all post-3.12 actively maintained kernels (so, that's at least the distro trusty and utopic kernels)?

Thanks

tags: added: bot-stop-nagging

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1344049

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Tim Gardner (timg-tpi) on 2014-07-18
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Utopic):
status: Incomplete → Fix Released

Im sorry i am linux toddler how do i perform this action?

On Fri, Jul 18, 2014 at 10:14 AM, Tim Gardner <email address hidden>
wrote:

> ** Also affects: linux (Ubuntu Trusty)
> Importance: Undecided
> Status: New
>
> ** Also affects: linux (Ubuntu Utopic)
> Importance: Undecided
> Status: Incomplete
>
> ** Changed in: linux (Ubuntu Trusty)
> Status: New => In Progress
>
> ** Changed in: linux (Ubuntu Trusty)
> Assignee: (unassigned) => Tim Gardner (timg-tpi)
>
> ** Changed in: linux (Ubuntu Utopic)
> Status: Incomplete => Fix Released
>
> --
> You received this bug notification because you are subscribed to Utopic.
> Matching subscriptions: corrupted low memory
> https://bugs.launchpad.net/bugs/1344049
>
> Title:
> Please cherry-pick tc rule fix for userns
>
> Status in “linux” package in Ubuntu:
> Fix Released
> Status in “linux” source package in Trusty:
> In Progress
> Status in “linux” source package in Utopic:
> Fix Released
>
> Bug description:
> Hello,
>
> I pushed a fix to the mainline kernel which I believe will first be
> released in 3.16.
> This change is required to make setting tc rules inside an unprivileged
> lxc container (assuming the userns owns a netns).
>
> Commit id is: 4e8bbb819d1594a01f91b1de83321f68d3e6e245
>
> Can we please have this cherry-picked in all post-3.12 actively
> maintained kernels (so, that's at least the distro trusty and utopic
> kernels)?
>
> Thanks
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1344049/+subscriptions
>

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Tim Gardner (timg-tpi) on 2014-08-21
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Stéphane Graber (stgraber) wrote :

root@qdisc:~# tc qdisc add dev eth0 root netem delay 50ms
root@qdisc:~# ping 10.0.3.1
PING 10.0.3.1 (10.0.3.1) 56(84) bytes of data.
64 bytes from 10.0.3.1: icmp_seq=1 ttl=64 time=50.3 ms
64 bytes from 10.0.3.1: icmp_seq=2 ttl=64 time=50.3 ms
^C
--- 10.0.3.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 50.360/50.363/50.367/0.224 ms
root@qdisc:~#

So confirmed to work as expected, thanks!

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers