Ubuntu14.10: CONFIG_SCSI_IPr_TRACE and CONFIG_SCSI_IPR_DUMP are not set in config file

Bug #1343109 reported by bugproxy on 2014-07-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Trusty
Undecided
Tim Gardner
Utopic
Medium
Tim Gardner

Bug Description

Problem Description
---------------------------------------
CONFIG_SCSI_IPR_TRACE and CONFIG_SCSI_IPR_DUMP are not set in config file in Ubuntu14.10

---uname output---
ubuntu 14.10

Machine Type = P8

Steps to Reproduce
------------------------------------
 In config file,

# CONFIG_SCSI_IPR_TRACE is not set
# CONFIG_SCSI_IPR_DUMP is not set

They are not set. Ipr device driver couldn't generate dump and trace files for debugging.

bugproxy (bugproxy) on 2014-07-17
tags: added: architecture-ppc64le bugnameltc-113326 severity-high targetmilestone-inin---

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1343109/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

------- Comment From <email address hidden> 2014-07-23 15:48 EDT-------
We saw some errors in error log:

root@lep8d:/boot# iprdump
iprdump[6095]: 0001:04:00.0: Failed to enable dump. rc=-5. No such file or directory
iprdump[6095]: 0001:04:00.0: Failed to enable dump. rc=-5. No such file or directory

root@lep8d:/boot# dmesg
[34079.684233] iprdump[4826]: unhandled signal 11 at 0000000000000000 nip 00003fff9cc6b81c lr 0000000010020210 code 30001
[34681.679150] iprdump[6095]: unhandled signal 11 at 0000000000000000 nip 00003fff8f90b81c lr 0000000010020210 code 30001

Wendy Xiong (wenxiong) wrote :

I tried to put "linux-image-3.16.0-0-generic" in "Package" filed but launchpad doesn't me do it.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2014-07-24 04:52 EDT-------
*** Bug 113705 has been marked as a duplicate of this bug. ***

Luciano Chavez (lnx1138) on 2014-07-24
affects: ubuntu → linux-meta (Ubuntu)
Brad Figg (brad-figg) on 2014-07-24
affects: linux-meta (Ubuntu) → linux (Ubuntu)
bugproxy (bugproxy) on 2014-07-24
tags: added: targetmilestone-inin1410
removed: targetmilestone-inin---

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1343109

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Jul 24 14:05 seq
 crw-rw---- 1 root audio 116, 33 Jul 24 14:05 timer
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 2.14.4-0ubuntu2
Architecture: ppc64el
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 14.10
HibernationDevice: RESUME=UUID=1477d0a1-a2cb-4c05-b7e4-5463af1ce455
InstallationDate: Installed on 2014-07-23 (1 days ago)
InstallationMedia: Ubuntu-Server 14.10 "Utopic Unicorn" - Alpha ppc64el (20140718)
IwConfig: Error: [Errno 2] No such file or directory
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Package: linux (not installed)
PciMultimedia:

ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: root=UUID=6c354e14-fa77-4e99-899b-dd21a3627c62 ro splash quiet
ProcVersionSignature: Ubuntu 3.16.0-5.10-generic 3.16.0-rc6
RelatedPackageVersions:
 linux-restricted-modules-3.16.0-5-generic N/A
 linux-backports-modules-3.16.0-5-generic N/A
 linux-firmware 1.132
RfKill: Error: [Errno 2] No such file or directory
Tags: utopic
Uname: Linux 3.16.0-5-generic ppc64le
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

WifiSyslog:
 Jul 24 21:20:38 lep8d kernel: [26142.017382] create_dump_obj: New platform dump. ID = 0x3a000000 Size 7256717
 Jul 24 21:20:38 lep8d kernel: [26142.038146] dump_read_data: Extract dump failed for ID 0x3
 Jul 24 21:20:39 lep8d kernel: [26143.041011] dump_attr_read: Platform dump partially read.ID = 0x3a000000
 Jul 24 21:20:39 lep8d kernel: [26143.041230] dump_read_data: Extract dump failed for ID 0x3a000000
_MarkForUpload: True

tags: added: apport-collected utopic

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Confirmed these are not set in utopic:

~/src/ubuntu-utopic-official/debian.master/config$ grep -R CONFIG_SCSI_IPR_TRACE *
annotations:CONFIG_SCSI_IPR_TRACE n
config.common.ubuntu:# CONFIG_SCSI_IPR_TRACE is not set

~/src/ubuntu-utopic-official/debian.master/config$ grep -R CONFIG_SCSI_IPR_DUMP
annotations:CONFIG_SCSI_IPR_DUMP n
config.common.ubuntu:# CONFIG_SCSI_IPR_DUMP is not set

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: kernel-da-key
Tim Gardner (timg-tpi) on 2014-07-24
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Utopic):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → Fix Committed
Tim Gardner (timg-tpi) on 2014-07-24
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-6.11

---------------
linux (3.16.0-6.11) utopic; urgency=low

  [ Paolo Pisati ]

  * [Config] armhf: MXS_DMA=y && MTD_NAND_GPMI_NAND=m
  * [Config] armhf: KEYBOARD_IMX=m
  * [Config] armhf: build cubox & imx6 DTBs
  * [Config] armhf: RTC_DRV_PCF8523=y

  [ Tim Gardner ]

  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * Release Tracking Bug
    - LP: #1349196

  [ Upstream Kernel Changes ]

  * rebase to v3.16-rc7
 -- Tim Gardner <email address hidden> Thu, 24 Jul 2014 09:08:55 -0400

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released

------- Comment From <email address hidden> 2014-08-04 14:03 EDT-------
*** Bug 114168 has been marked as a duplicate of this bug. ***

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Tim Gardner (timg-tpi) wrote :

Setting verification-done-trusty

debian.master/config/config.common.ubuntu:CONFIG_SCSI_IPR=m
debian.master/config/config.common.ubuntu:CONFIG_SCSI_IPR_DUMP=y
debian.master/config/config.common.ubuntu:CONFIG_SCSI_IPR_TRACE=y

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2014-10-10 09:09 EDT-------
Can we close that bug since trusty-proposed is level 3.13.0-37.64 so it will include the fix ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers