Enable CONFIG_GPIO_SYSFS option in the Kernel

Bug #1342153 reported by Kent Baxley on 2014-07-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Trusty
Medium
Kent Baxley
Utopic
Medium
Tim Gardner

Bug Description

It appears we don't set the CONFIG_GPIO_SYSFS on Trusty (or Utopic?) for x86.

By enabled, I mean:

CONFIG_GPIO_SYSFS=y

This option (along with a few gpio devices) is needed to enable programming of such things as the I2C Mux through via the CPLDs on some OEM 'whitebox' switches that will leverage Software Defined Networking.

This option can, of course, be set and users can build their own kernels, but, if at all possible they'd like to keep this as stock as they can.

config GPIO_SYSFS
        bool "/sys/class/gpio/... (sysfs interface)"
        depends on SYSFS
        help
          Say Y here to add a sysfs interface for GPIOs.

          This is mostly useful to work around omissions in a system's
          kernel support. Those are common in custom and semicustom
          hardware assembled using standard kernels with a minimum of
          custom patches. In those cases, userspace code may import
          a given GPIO from the kernel, if no kernel driver requested it.

          Kernel drivers may also request that a particular GPIO be
          exported to userspace; this can be useful when debugging.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1342153

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Kent Baxley (kentb) wrote :

Request to turn on a kernel config option. No logs required.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Tim Gardner (timg-tpi) on 2014-07-16
Changed in linux (Ubuntu Trusty):
assignee: nobody → Kent Baxley (kentb)
status: New → In Progress
Changed in linux (Ubuntu Utopic):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Tim Gardner (timg-tpi) on 2014-07-16
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Utopic):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Trusty):
importance: Undecided → Medium
Changed in linux (Ubuntu Utopic):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-5.10

---------------
linux (3.16.0-5.10) utopic; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1346298
  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * rebase to v3.16-rc6

  [ Paolo Pisati ]

  * [Config] enable ARCH_MVEBU*
  * [Config] AHCI_MVEBU=m
  * [Config] ARMADA_THERMAL=y
  * [Config] ARM_ARMADA_370_XP_CPUIDLE=y
  * [Config] CRYPTO_DEV_MV_CESA=m
  * [Config] I2C_MV64XXX=m
  * [Config] MMC_MVSDIO=m
  * [Config] MMC_SDHCI_DOVE=m
  * [Config] MTD_NAND_ORION=m
  * [Config] MTD_NAND_PXA3xx=m
  * [Config] MVNETA=m
  * [Config] MV_XOR=y
  * [Config] ORION_WATCHDOG=m
  * [Config] PCI_MVEBU=y
  * [Config] RTC_DRV_MV=y
  * [Config] SND_KIRKWOOD_SOC*=m
  * [Config] SPI_ORION=m
  * [Config] USB_XHCI_MVEBU=m
  * [Config] armhf: build all Armada and Dove DTBs
  * [Config] armhf: SERIAL_8250_DW=y

  [ Upstream Kernel Changes ]

  * rebase to v3.16-rc6
 -- Tim Gardner <email address hidden> Tue, 15 Jul 2014 07:49:42 -0400

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Tim Gardner (timg-tpi) wrote :

Setting verification-done-trusty

debian.master/config/config.common.ubuntu:CONFIG_GPIO_SYSFS=y

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers