Intel Corporation Centrino Advanced-N 6235 wifi is slow

Bug #1341068 reported by orlexy on 2014-07-12
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
orlexy

Bug Description

Intel Corporation Centrino Advanced-N 6235 wifi is slow

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-30-generic 3.13.0-30.55
ProcVersionSignature: Ubuntu 3.13.0-30.55-generic 3.13.11.2
Uname: Linux 3.13.0-30-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: orlexy 2126 F.... pulseaudio
CurrentDesktop: Unity
Date: Sat Jul 12 10:37:18 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-06-27 (14 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: LENOVO 20042
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-30-generic root=UUID=70e21e10-256e-4d84-b19a-6fb393f2b46d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-30-generic N/A
 linux-backports-modules-3.13.0-30-generic N/A
 linux-firmware 1.127.4
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/28/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 29CN38WW(V2.15)
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: LENOVO
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnLENOVO:bvr29CN38WW(V2.15):bd01/28/2011:svnLENOVO:pn20042:pvrLenovoG560:rvnLENOVO:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: 20042
dmi.product.version: Lenovo G560
dmi.sys.vendor: LENOVO

orlexy (orlexy) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Seth Forshee (sforshee) wrote :

The description here isn't very informative. It's slow compared to what? The same machine booted in Windows? Previous Ubuntu releases?

One probable cause is that transmit aggregation as been enabled by default for some Intel hardware due to firmware bugs which caused unstable connections, which will definitely impact performance on 802.11n networks. If you know that your hardware worked fine with a previous Ubuntu release, or if you just want to see if it helps, you can boot Ubuntu with the iwlwifi.11n_disable=8 option to force transmit aggregation to be enabled. If you find this helps and gives you a stable connection, you can make this option permanent by creating a file named /etc/modprobe.d/iwlwifi-11n.conf which has the following text:

options iwlwifi 11n_disable=8

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
orlexy (orlexy) wrote :

In the old version 12.04 Ubuntu everything worked. Speed ​​was 100megabit per second.
In windows 7 too high speed.
After installing 14.04 speeds has become less than 40 megabits
iwlwifi 11n_disable = 8 - this method does not work
(Translated using google translator)

orlexy (orlexy) on 2014-09-18
Changed in linux (Ubuntu):
assignee: nobody → orlexy (orlexy)
madbiologist (me-again) wrote :

This might be fixed in the Ubuntu 15.04 "Vivid Vervet" kernel 3.19.0-17.17 by this commit:

iwlwifi: fix max_ht_ampdu_exponent for older devices

The diff file mentions your Centrino Advanced-N 6235.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers