[Lenovo ThinkPad Edge E540] Suspend Failure

Bug #1340376 reported by Jörn Horstmann on 2014-07-10
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

The laptop failed to suspend, screen went black but the fan stayed on. Resume was not possible. The suspend problem still occurs with mainline kernel-3.16-rc4.

WORKAROUND: Disable USB3 in the BIOS.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-31-generic 3.13.0-31.55
ProcVersionSignature: Ubuntu 3.13.0-31.55-generic 3.13.11.4
Uname: Linux 3.13.0-31-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jh 2145 F.... pulseaudio
 /dev/snd/controlC1: jh 2145 F.... pulseaudio
CurrentDesktop: GNOME
Date: Thu Jul 10 21:42:38 2014
InstallationDate: Installed on 2014-06-06 (33 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:07dc Intel Corp.
 Bus 001 Device 002: ID 09da:9066 A4 Tech Co., Ltd
 Bus 001 Device 004: ID 04f2:b398 Chicony Electronics Co., Ltd
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 20C6CTO1WW
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-31-generic root=UUID=9224c861-9b53-444d-9e76-641537f1428e ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-31-generic N/A
 linux-backports-modules-3.13.0-31-generic N/A
 linux-firmware 1.127.4
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/13/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: J9ET87WW (2.07 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20C6CTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: 0B98405 STD
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrJ9ET87WW(2.07):bd05/13/2014:svnLENOVO:pn20C6CTO1WW:pvrThinkPadEdgeE540:rvnLENOVO:rn20C6CTO1WW:rvr0B98405STD:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20C6CTO1WW
dmi.product.version: ThinkPad Edge E540
dmi.sys.vendor: LENOVO

Jörn Horstmann (jhorstmann) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
description: updated
summary: - Suspend Failure on Thinkpad E540 20C6CTO1WW
+ [Lenovo ThinkPad Edge E540] Suspend Failure
tags: added: bios-outdated-2.08
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Jörn Horstmann (jhorstmann) wrote :

Updated the BIOS to the newest version, this ist the output of dmidecode:

J9ET91WW (2.11 )
07/04/2014

The suspend behaviour is unchanged

Detroyer (destroyer954) wrote :

I have the exact same issue on Ubuntu 13.10 and 14.04, I've also tried running kernel 3.15, issue persisted. Disabling USB 3.0 fixes it, but I had to also add this in order to run ethernet after resume

gksu mousepad /etc/pm/config.d/unload_modules
SUSPEND_MODULES="$SUSPEND_MODULES r8169"

tags: added: latest-bios-2.11
removed: bios-outdated-2.08

Jörn Horstmann, could you please test the latest upstream kernel available from the very top line at the top of the page (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-3.16-rc4

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Destroyer, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in linux (Ubuntu):
importance: Low → Medium
Jörn Horstmann (jhorstmann) wrote :

Christpher, thanks for guiding me through this process. The bug still exists in the latest upstream rc:

$ uname -a
Linux JH-EDGE-E540 3.16.0-031600rc4-generic #201407061635 SMP Sun Jul 6 20:36:26 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Attached is the dmesg output after following the steps described at https://wiki.ubuntu.com/DebuggingKernelSuspend

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.16-rc4
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Jörn Horstmann, could you please provide the missing information following https://wiki.ubuntu.com/DebuggingKernelSuspend ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jörn Horstmann (jhorstmann) wrote :

Here is the output of `cat /proc/acpi/wakeup`, sorry I missed that while reading the wiki the first time. Did I miss anything else?

Jörn Horstmann, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel ?

Please provide a direct URL to your e-mail to the mailing list once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Jörn Horstmann (jhorstmann) wrote :

This issue is now also reported on the kernel bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=80351

Jörn Horstmann, I'm not clear on why you submitted a bug report based on the instructions provided in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1340376/comments/10 , as it doesn't mention that anywhere. As well, you didn't include most of this information upstream requires when reporting to the mailing list (not Bugzilla).

Jörn Horstmann (jhorstmann) wrote :

That instructions could have been a bit more clear on what the correct upstream mailing list was.

I first tried on linux-usb (http://marc.info/?l=linux-usb&m=140534633328101&w=2) and got pointed to linux-pm (http://marc.info/?l=linux-usb&m=140535047629911&w=2) where I was instructed to file a bug in bugzilla (http://marc.info/?l=linux-pm&m=140542653722449&w=2).

The information from the form described at https://wiki.ubuntu.com/Bugs/Upstream/kernel was included in the mailing list posts and is also attached to bugzilla. If there is any information still missing please let me know.

Zlatko Zlatev (zlatko-zlatev) wrote :

According to bugzilla.kernel.org this is fixed in BIOS(UEFI) 2.18. Cheers!

Jörn Horstmann, as per http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-edge-laptops/thinkpad-edge-e540 an update to your computer's buggy and outdated BIOS is available (2.18). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful. As well, you don't have to create a new bug report.

Once the BIOS is updated, and the information above is provided, then please mark this report Status Confirmed.

Thank you for your understanding.

tags: added: bios-outdated-2.18
removed: latest-bios-2.11
Changed in linux (Ubuntu):
status: Triaged → Incomplete
SilverFire (d-naumenko-a) wrote :

I faced this bug with BIOS 2.11.

Then I updated BIOS to the latest version 2.20 and I can confirm that suspend works fine now.

Thank you!

tags: added: bios-outdated-2.20
removed: bios-outdated-2.18
SilverFire (d-naumenko-a) wrote :

Status changed to "Fix Released" because the bug is out of the Linux scope and the BIOS updated that fixes this bug is released by the device vendor.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released

SilverFire, this is not Fix Released as defined in https://wiki.ubuntu.com/Bugs/Status .

Changed in linux (Ubuntu):
status: Fix Released → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.