[Dell Inspiron 7537] Wireless key does not work

Bug #1339456 reported by Po-Hsu Lin on 2014-07-09
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Medium
AceLan Kao
Trusty
Medium
AceLan Kao
Utopic
Medium
AceLan Kao
linux (Ubuntu)
Medium
Edward Lin
Trusty
Undecided
AceLan Kao
Utopic
Undecided
AceLan Kao

Bug Description

SRU Justification:

Impact: The wireless hotkey is not working on those Dell machines,
   Dell Inspiron 7737/7537/5437/3437 and Vostro 3446, due to the BIOS
doesn't handle Win8 OSI.

Fix: Adding those machines into quirk list that disable WIN8 OSI by default.

Testcase: Tested on Dell Inspiron 7537

--

CID: 201306-13867 Dell Inspiron 7537

The wireless key is not working on this system.
Steps:
1, Install 14.04 + update (3.13.0-30), boot to desktop
2. Try to disable the wireless network / Bluetooth by pressing the wireless key

Expected result:
* Wireless network / Bluetooth should be disabled.

Actual result:
* Nothing happened

Debug information:
ubuntu@201306-13867:~$ sudo showkey -k
kb mode was ?UNKNOWN?
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
keycode 28 release
keycode 240 press
keycode 240 press
keycode 240 press
^Ccaught signal 2, cleaning up...

xev cannot detect any wireless key event

Bug 1289238 is similar to this one, but it's "Fix committed" for Trusty, maybe not released yet.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-30-generic 3.13.0-30.55
ProcVersionSignature: Ubuntu 3.13.0-30.55-generic 3.13.11.2
Uname: Linux 3.13.0-30-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1697 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1697 F.... pulseaudio
CurrentDesktop: Unity
Date: Tue Jul 8 22:32:16 2014
HibernationDevice: RESUME=UUID=45ae699a-bd5e-44f6-890e-94b66eb327cb
InstallationDate: Installed on 2014-07-08 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Dell Inc. Dell System Inspiron 15 7000 Series 7537
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-30-generic.efi.signed root=UUID=09af688c-93ed-4a09-864a-53e21c9f2719 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-30-generic N/A
 linux-backports-modules-3.13.0-30-generic N/A
 linux-firmware 1.127.4
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/15/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: White Tip Mountain
dmi.board.vendor: Intel Corp.
dmi.board.version: FAB3
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: Intel Corporation
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd08/15/2013:svnDellInc.:pnDellSystemInspiron157000Series7537:pvr:rvnIntelCorp.:rnWhiteTipMountain:rvrFAB3:cvnIntelCorporation:ct9:cvr0.1:
dmi.product.name: Dell System Inspiron 15 7000 Series 7537
dmi.sys.vendor: Dell Inc.

Po-Hsu Lin (cypressyew) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Daniel Manrique (roadmr) on 2014-07-09
Changed in linux (Ubuntu):
importance: Undecided → Medium
Anthony Wong (anthonywong) wrote :

@PHLin, does it work if you provide parameter acpi_osi="!Windows 2012" ?

Changed in hwe-next:
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Po-Hsu Lin (cypressyew) on 2014-07-24
Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Po-Hsu Lin (cypressyew)
Po-Hsu Lin (cypressyew) wrote :

Hello Anthony,
Yes it work with the acpi_osi=\"!Windows 2012\" parameter added.

Changed in linux (Ubuntu):
assignee: Po-Hsu Lin (cypressyew) → Anthony Wong (anthonywong)
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Edward Lin (airken)
Changed in hwe-next:
assignee: nobody → Edward Lin (airken)
Edward Lin (airken) on 2014-07-29
Changed in linux (Ubuntu):
status: Confirmed → In Progress
Edward Lin (airken) wrote :

Quirk for Dell Inspiron 7737/7537/5437/3437 and Vostro 3446 is accepted by upstream.
And the patch will be merged in 3.18.

http://permalink.gmane.org/gmane.linux.acpi.devel/70627

Anthony Wong (anthonywong) wrote :

Acelan, can you take over this bug from Edward, and submit the patch for Ubuntu Trusty and Utopic kernels?

Changed in hwe-next:
assignee: Edward Lin (airken) → nobody
Tim Gardner (timg-tpi) on 2014-11-05
Changed in linux (Ubuntu Trusty):
assignee: nobody → AceLan Kao (acelankao)
status: New → Fix Committed
Changed in linux (Ubuntu Utopic):
assignee: nobody → AceLan Kao (acelankao)
status: New → Fix Committed
Chris J Arges (arges) on 2014-11-06
description: updated
Tim Gardner (timg-tpi) on 2014-11-06
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in hwe-next:
assignee: nobody → AceLan Kao (acelankao)
status: New → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
tags: added: verification-needed-utopic
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-utopic' to 'verification-done-utopic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

AceLan Kao (acelankao) on 2014-12-09
tags: added: verification-done-trusty
removed: verification-needed-trusty
tags: added: verification-done-utopic
removed: verification-needed-utopic
Launchpad Janitor (janitor) wrote :
Download full text (14.0 KiB)

This bug was fixed in the package linux - 3.13.0-41.70

---------------
linux (3.13.0-41.70) trusty; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1396112

  [ Chris J Arges ]

  * [Config] CONFIG_SCOM_DEBUGFS=y for powerpc/powerpc64-smp
    ppc64el/generic
    - LP: #1395855

  [ Upstream Kernel Changes ]

  * Revert "KVM: x86: Handle errors when RIP is set during far jumps"
    - LP: #1393477
  * Revert "net/macb: add pinctrl consumer support"
    - LP: #1393477
  * Revert "iwlwifi: mvm: treat EAPOLs like mgmt frames wrt rate"
    - LP: #1393477
  * Revert "ipmi: simplify locking"
    - LP: #1383921
  * ACPI / blacklist: add Win8 OSI quirks for some Dell laptop models
    - LP: #1339456
  * ACPI / battery: Accelerate battery resume callback
    - LP: #838543
  * tools: cpu-hotplug fix unexpected operator error
  * netlink: reset network header before passing to taps
    - LP: #1393477
  * rtnetlink: fix VF info size
    - LP: #1393477
  * myri10ge: check for DMA mapping errors
    - LP: #1393477
  * tcp: don't use timestamp from repaired skb-s to calculate RTT (v2)
    - LP: #1393477
  * sit: Fix ipip6_tunnel_lookup device matching criteria
    - LP: #1393477
  * tcp: fix tcp_release_cb() to dispatch via address family for
    mtu_reduced()
    - LP: #1393477
  * tcp: fix ssthresh and undo for consecutive short FRTO episodes
    - LP: #1393477
  * packet: handle too big packets for PACKET_V3
    - LP: #1393477
  * openvswitch: fix panic with multiple vlan headers
    - LP: #1393477
  * vxlan: fix incorrect initializer in union vxlan_addr
    - LP: #1393477
  * l2tp: fix race while getting PMTU on PPP pseudo-wire
    - LP: #1393477
  * bonding: fix div by zero while enslaving and transmitting
    - LP: #1393477
  * bridge: Check if vlan filtering is enabled only once.
    - LP: #1393477
  * bridge: Fix br_should_learn to check vlan_enabled
    - LP: #1393477
  * net: allow macvlans to move to net namespace
    - LP: #1393477
  * tg3: Work around HW/FW limitations with vlan encapsulated frames
    - LP: #1393477
  * tg3: Allow for recieve of full-size 8021AD frames
    - LP: #1393477
  * xfrm: Generate blackhole routes only from route lookup functions
    - LP: #1393477
  * xfrm: Generate queueing routes only from route lookup functions
    - LP: #1393477
  * macvtap: Fix race between device delete and open.
    - LP: #1393477
  * gro: fix aggregation for skb using frag_list
    - LP: #1393477
  * hyperv: Fix a bug in netvsc_start_xmit()
    - LP: #1393477
  * ip6_gre: fix flowi6_proto value in xmit path
    - LP: #1393477
  * team: avoid race condition in scheduling delayed work
    - LP: #1393477
  * sctp: handle association restarts when the socket is closed.
    - LP: #1393477
  * tcp: fixing TLP's FIN recovery
    - LP: #1393477
  * sparc64: Do not disable interrupts in nmi_cpu_busy()
    - LP: #1393477
  * sparc64: Fix pcr_ops initialization and usage bugs.
    - LP: #1393477
  * sparc32: dma_alloc_coherent must honour gfp flags
    - LP: #1393477
  * sparc64: sun4v TLB error power off events
    - LP: #1393477
  * sparc64: Fix corrupted thread fault code.
    - LP: #1393477
  * sparc64: find_node adjustment
   ...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (16.7 KiB)

This bug was fixed in the package linux - 3.16.0-26.35

---------------
linux (3.16.0-26.35) utopic; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1398118

  [ Upstream Kernel Changes ]

  * Revert "drm/nouveau: punt fbcon resume out to a workqueue"
  * Revert "drm/nouveau/kms: take more care when pulling down accelerated
    fbcon"

linux (3.16.0-26.34) utopic; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1395892

  [ Chris J Arges ]

  * [Config] CONFIG_SCOM_DEBUGFS=y for powerpc/powerpc64-smp ppc64el/generic
    - LP: #1395855

  [ Tim Gardner ]

  * [Config] CONFIG_GENWQE_PLATFORM_ERROR_RECOVERY=1 for powerpc/ppc64el
    - LP: #1392021

  [ Upstream Kernel Changes ]

  * Revert "usb: dwc3: dwc3-omap: Disable/Enable only wrapper interrupts in
    prepare/complete"
    - LP: #1393401
  * Revert "iwlwifi: mvm: treat EAPOLs like mgmt frames wrt rate"
    - LP: #1393401
  * Revert "block: all blk-mq requests are tagged"
    - LP: #1393401
  * ACPI / blacklist: add Win8 OSI quirks for some Dell laptop models
    - LP: #1339456
  * PCI: Remove "no hotplug settings from platform" warning
    - LP: #1390182
  * drm/nouveau/kms: take more care when pulling down accelerated fbcon
    - LP: #1386695
  * drm/nouveau: punt fbcon resume out to a workqueue
    - LP: #1386695
  * drm/tilcdc: Fix the error path in tilcdc_load()
    - LP: #1393401
  * builddeb: put the dbg files into the correct directory
    - LP: #1393401
  * switch iov_iter_get_pages() to passing maximal number of pages
    - LP: #1393401
  * fuse: honour max_read and max_write in direct_io mode
    - LP: #1393401
  * usb: phy: return -ENODEV on failure of try_module_get
    - LP: #1393401
  * PM / clk: Fix crash in clocks management code if !CONFIG_PM_RUNTIME
    - LP: #1393401
  * rt2x00: support Ralink 5362.
    - LP: #1393401
  * wireless: rt2x00: add new rt2800usb devices
    - LP: #1393401
  * NFS: Fix /proc/fs/nfsfs/servers and /proc/fs/nfsfs/volumes
    - LP: #1393401
  * nfs: fix duplicate proc entries
    - LP: #1393401
  * ext4: check EA value offset when loading
    - LP: #1393401
  * jbd2: free bh when descriptor block checksum fails
    - LP: #1393401
  * ext4: don't check quota format when there are no quota files
    - LP: #1393401
  * target: Fix queue full status NULL pointer for SCF_TRANSPORT_TASK_SENSE
    - LP: #1393401
  * vfs: fix data corruption when blocksize < pagesize for mmaped data
    - LP: #1393401
  * ext4: fix mmap data corruption when blocksize < pagesize
    - LP: #1393401
  * ext4: grab missed write_count for EXT4_IOC_SWAP_BOOT
    - LP: #1393401
  * qla_target: don't delete changed nacls
    - LP: #1393401
  * target: Fix APTPL metadata handling for dynamic MappedLUNs
    - LP: #1393401
  * iser-target: Disable TX completion interrupt coalescing
    - LP: #1393401
  * ext4: don't orphan or truncate the boot loader inode
    - LP: #1393401
  * ext4: add ext4_iget_normal() which is to be used for dir tree lookups
    - LP: #1393401
  * ext4: fix reservation overflow in ext4_da_write_begin
    - LP: #1393401
  * ext4: Replace open coded mdata csum feature to helper function
    - LP: #1393401
  * ext4: move error ...

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers