ppc64le kernel module nx_crypto blocks loading other kernel modules

Bug #1338666 reported by bugproxy on 2014-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Tim Gardner
Utopic
Medium
Unassigned

Bug Description

== Comment: #0 - David A. Harnett <email address hidden> - 2014-03-12 20:43:09 ==
---Problem Description---
On Ubuntu 14.04 ppc64le in a Power7 LPAR , if kernel module nx_crypto is already loaded ,
attempts to load additional kernel modules fail with this message :

modprobe: ERROR: could not insert 'xxx': Invalid argument

where xxx is the name of module we tried to load .
dmesg shows:
[ 33.012917] nx: scatter/gather list overflow, pid: 806

---uname output---
Linux c277f3u1crash2 3.13.0-17-generic #37-Ubuntu SMP Mon Mar 10 21:47:19 UTC 2014 ppc64le ppc64le ppc64le GNU/Linux

---Additional Hardware Info---
special PowerVM Little Endian firmware level b0108l_1446.780

Machine Type = Power 780+ 9179-MHD LPAR

---Debugger---
A debugger is not configured

---Steps to Reproduce---
 "lsmod" , if nx_crypto module not loaded , then "modprobe nx_crypto" ;
try to load any kernel module , "modprobe nfs"

Stack trace output:
 no

Oops output:
 no

System Dump Info:
  The system is not configured to capture a system dump.

*Additional Instructions for Dave <email address hidden> , no backup:
-Post a private note with access information to the machine that the bug is occuring on.
-Attach sysctl -a output output to the bug.

== Comment: #3 - David A. Harnett <email address hidden> - 2014-03-12 21:19:42 ==
Circumvention : add directive "blacklist nx_crypto" to a file in directory /etc/modprobe.d

Problem does not occur on Ubuntu 14.04 powerpc64 Big Endian image running in LPAR on same hardware .

== Comment: #5 - Leonidas Da Silva Barbosa <email address hidden> - 2014-03-13 14:48:17 ==
David,

can you provide us with a

cat /etc/issue
cat /proc/cpuinfo
uname -a

from the system where the problem does not happen?

== Comment: #6 - David A. Harnett <email address hidden> - 2014-03-13 15:24:55 ==
This is the requested output from the BE image in another LPAR on the same physical machine .

$ cat /etc/issue
Ubuntu Trusty Tahr (development branch) \n \l

$ cat /proc/cpuinfo
processor : 0
cpu : POWER7 (architected), altivec supported
clock : 3724.000000MHz
revision : 2.0 (pvr 004a 0200)

processor : 1
cpu : POWER7 (architected), altivec supported
clock : 3724.000000MHz
revision : 2.0 (pvr 004a 0200)

processor : 2
cpu : POWER7 (architected), altivec supported
clock : 3724.000000MHz
revision : 2.0 (pvr 004a 0200)

processor : 3
cpu : POWER7 (architected), altivec supported
clock : 3724.000000MHz
revision : 2.0 (pvr 004a 0200)

timebase : 512000000
platform : pSeries
model : IBM,9179-MHD
machine : CHRP IBM,9179-MHD

$ uname -a
Linux c277f3u1admin2 3.13.0-17-powerpc64-smp #37-Ubuntu SMP Mon Mar 10 21:58:15 UTC 2014 ppc64 ppc64 ppc64 GNU/Linux

== Comment: #10 - Leonidas Da Silva Barbosa <email address hidden> - 2014-03-14 13:19:42 ==
David,

The hardware that are you running both image is over a PowerVM LE ?

== Comment: #11 - David A. Harnett <email address hidden> - 2014-03-14 13:32:42 ==
This model Power 780 (Saturn MR class) Power7 machine has special IBM internal use only firmware that permits both LE and BE OS images to run in separate PowerVM LPARs simultaneously . Our contact for the firmware is David Larson , <email address hidden>

This is the third problem I observed on this machine where LE OS has problems but the same function works correctly on a nearly equivalent level of BE OS on the same physical machine .

1) nvram command fails with segfault - to be fixed in powerpc-utils package
2) ibmveth kernel driver for PowerVM virtual ethernet device - fixed in an Ubuntu 14.04 kernel
3) this problem
Common thread seems to be drivers that interface with firmware/hardware platform features .

== Comment: #17 - Cody P. Schafer <email address hidden> - 2014-05-14 14:02:52 ==
I've seen issues on POWER8-PowerVM-ppc64le with nx-crypto, dmesg attached.

note: this is still LE, but is also on P8 (not P7 as this bug was originally reported).

== Comment: #18 - Cody P. Schafer <email address hidden> - 2014-05-14 14:04:55 ==
Also, in my case further modules load without issue. The only problem is the log spam.

== Comment: #19 - Cody P. Schafer <email address hidden> - 2014-05-14 14:05:17 ==
kernel is v3.15-rc4-260-g38583f0 (from linus's tree)
uname -a:
Linux host 3.15.0-rc4-testing+ #8 SMP Wed May 14 02:21:38 PDT 2014 ppc64le ppc64le ppc64le GNU/Linux

== Comment: #20 - George C. Wilson <email address hidden> - 2014-05-14 14:13:32 ==
Hi Cody. NX crypto isn't supported on little endian kernels. We don't intend to support it because the P8 VMX crypto instructions should provide faster AES acceleration and also userspace support for it. The nx_crypto should be blacklisted or disabled in the kernel config for little endian.

== Comment: #21 - Cody P. Schafer <email address hidden> - 2014-05-14 14:15:28 ==
Ok, in that case someone needs to submit a patch to add a dependency on BE in the kernel's KConfig.

== Comment: #22 - George C. Wilson <email address hidden> - 2014-05-14 14:23:46 ==
Leonidas and Marcelo, could you please submit such a patch? It should probably go upstream into the defconfig as well, I'd imagine.

== Comment: #26 - Leonidas Da Silva Barbosa 2014-06-26 09:35:22 EDT ==

Kernel upstream already has this dependency:

here is the upstream commit
8b9f9269bcfb4fe9b44bb52aac1ce796834109fe

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-105629 severity-critical

Default Comment by Bridge

------- Comment From <email address hidden> 2014-07-07 16:47 EDT-------
Ubuntu:

In short: this kernel module is not supported on PPC LE. The simple patch to handle this is here:

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=8b9f9269bcfb4fe9b44bb52aac1ce796834109fe

We are requesting this for 14.10. Thx.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1338666/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

We have this patch queued for our first v3.16 based kernel upload for Utopic (14.10). Marking this Fix Committed for now.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Fix Committed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Tim Gardner (timg-tpi) on 2014-07-09
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) wrote :

v3.16-rc1

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
bugproxy (bugproxy) on 2014-07-16
tags: added: targetmilestone-inin1410
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2014-08-20 16:49 EDT-------
(In reply to comment #42)
> This bug is awaiting verification that the kernel in -proposed solves the
> problem. Please test the kernel and update this bug with the results. If the
> problem is solved, change the tag 'verification-needed-trusty' to
> 'verification-done-trusty'.
>
> If verification is not done by 5 working days from today, this fix will be
> dropped from the source code, and this bug will be closed.
>
Please don't do that. That's not very much time.

> See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you!

David or anyone: Can you please follow the above instructions to see if you can install updated kernel?

Thx -DaveH.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2014-08-20 17:51 EDT-------
I tested 14.04 and it's working fine. The NX driver is not included.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2014-08-20 19:20 EDT-------
(In reply to comment #46)
> I tested 14.04 and it's working fine. The NX driver is not included.

Thanks, Marcello.

Closing now. Thanks for your help, Canonical.

Tim Gardner (timg-tpi) on 2014-08-21
tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers