[Dell Studio 1458] Black (off) screen after waking from suspend

Bug #1332764 reported by Atul on 2014-06-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

The laptop wakes up from suspend with a black screen i.e. screen not turned ON. The keyboard and mouse seems to be responsive as backlit turns ON if I click any key or touch track pad.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-29-generic 3.13.0-29.53
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
Uname: Linux 3.13.0-29-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: atul 2085 F.... pulseaudio
 /dev/snd/controlC0: atul 2085 F.... pulseaudio
CurrentDesktop: Unity
Date: Fri Jun 20 22:55:37 2014
HibernationDevice: RESUME=UUID=15f965f3-ae06-4b09-a249-61c32e50481e
InstallationDate: Installed on 2014-04-19 (62 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Dell Inc. Studio 1458
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-29-generic root=UUID=12be9505-0800-40e5-8928-e60118a8f0c2 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-29-generic N/A
 linux-backports-modules-3.13.0-29-generic N/A
 linux-firmware 1.127.2
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/27/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0VF0FR
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A06
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd07/27/2010:svnDellInc.:pnStudio1458:pvrA06:rvnDellInc.:rn0VF0FR:rvrA06:cvnDellInc.:ct8:cvrA06:
dmi.product.name: Studio 1458
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.

Atul (atulkakrana) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Hi,

I was testing the mainstream kernel and got an error regarding 'bcmwl' package.

Atul

Atul (atulkakrana) wrote :

Hi,

Testing the mainstream kernel as suggested broke my wifi i.e. no wifi connections available.

Atul

description: updated
tags: added: bios-outdated-a07
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
summary: - Black (off) screen after waking from suspend
+ [Dell Studio 1458] Black (off) screen after waking from suspend
Atul (atulkakrana) wrote :

Hi Christopher,

In past, I have tried to update the bios with the version (v07) available on Dell support website but even after installing the update the bios version stays same (v06). I think there is some problem with this specific bios update package so it cant be applied to my system.

Anything else I could do? This big needs to be fixed.

Atul

Atul (atulkakrana) wrote :

Hi Chris,

I tested the upstream kernel-3.16rc2 but bug still exists. Damn...

Atul

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.16rc2
removed: apport-bug
Atul (atulkakrana) wrote :

Hi

I updated the bios to latest version (A07) but the bug still exists even in upstream kernel-3.16rc2

Atul

tags: removed: bios-outdated-a07
tags: added: kernel-bug-exists-upstream-3.16-rc2
removed: kernel-bug-exists-upstream-3.16rc2
tags: added: apport-bug latest-bios-a07
Atul (atulkakrana) wrote :

Hi Chris,

FYI while uninstalling upstream kernel to return back to original stable kernel some key packages like 'dpkg' got removed so I had to re-install Ubuntu OS.

Here is the output of:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

A07
05/12/2011

Atul

Atul, did this problem not occur in a release prior to 14.04?

Changed in linux (Ubuntu):
importance: Low → Medium
Atul (atulkakrana) wrote :

Hi Chris,

I don't remember having this problem before. Tell me what else could I do to provide you with more information?

Atul

Atul, could you specify which prior release specifically you didn't have this problem with?

Atul (atulkakrana) wrote :

Hi Chris,

Ubuntu 13.10 was installed previously. I upgraded from Ubuntu 12.04 to Ubuntu 13.010 and now made a fresh install to Ubuntu 14.04.

BTW why bug is marked as incomplete?

Atul

Atul, just to clarify, both 13.10 and 12.04 didn't have the problem?

Atul (atulkakrana) wrote :

Hi Chris,

I cannot recall if I had same problem with Ubuntu 12.04 as its been a long time. There was no problem with Ubuntu 13.10.

I have been trying all sorts of thing from internet but problem still persists.

Atul

Atul, could you please test the latest mainline kernel via http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-rc5-utopic/ and advise to the results?

tags: added: regression-release
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers