[Dell Inspiron 5547/5447] Unable to contorl brightness with fglrx driver on AMD Radeon R7 M260 [1002:6900]

Bug #1332437 reported by Po-Hsu Lin on 2014-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
Trusty
Medium
Edward Lin
Utopic
Undecided
Unassigned
linux (Ubuntu)
Medium
Edward Lin
Trusty
Undecided
Unassigned

Bug Description

CID: 201401-14542 Dell Inspiron 5547

This issue is similar to bug 1332379, but with I+A config,
Brightness cannot be controlled without the open-source driver as well.

Steps:
1. Install 14.04 + update (3.13.0-29) + fglrx
2. Try to adjust the screen brightness with hotkeys and "Brightness and Lock" applet

Expected result:
* Screen brightness could be adjusted in both ways.

Actual result:
* Unable to control screen brightness, the brightness indicator would change according to key press on the hotkeys

Debugging information:
ubuntu@201401-14542:~$ ls /sys/class/backlight/
acpi_video0 intel_backlight

ubuntu@201401-14542:~$ grep -r . /proc/acpi/
/proc/acpi/button/lid/LID0/state:state: open
/proc/acpi/wakeup:Device S-state Status Sysfs node
/proc/acpi/wakeup:P0P1 S4 *disabled
/proc/acpi/wakeup:LID0 S3 *enabled
/proc/acpi/wakeup:EHC1 S0 *enabled pci:0000:00:1d.0
/proc/acpi/wakeup:XHC S0 *enabled pci:0000:00:14.0
/proc/acpi/wakeup:PXSX S4 *disabled
/proc/acpi/wakeup:RP03 S3 *disabled pci:0000:00:1c.0
/proc/acpi/wakeup:PEGP S4 *disabled pci:0000:03:00.0
/proc/acpi/wakeup:PEGA S4 *disabled
/proc/acpi/wakeup:PEG0 S4 *disabled
/proc/acpi/wakeup:PEGP S4 *disabled
/proc/acpi/wakeup:PEG1 S4 *disabled
/proc/acpi/wakeup:PEG2 S4 *disabled

ubuntu@201401-14542:~$ dmesg | grep 'ACPI: Video'
[ 16.334321] ACPI: Video Device [PEGP] (multi-head: yes rom: no post: no)
[ 16.335955] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-29-generic 3.13.0-29.53
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
Uname: Linux 3.13.0-29-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1689 F.... pulseaudio
 /dev/snd/controlC1: ubuntu 1689 F.... pulseaudio
CRDA:
 country TW:
  (2402 - 2472 @ 40), (3, 27)
  (5270 - 5330 @ 40), (3, 17), DFS
  (5735 - 5815 @ 40), (3, 30)
CurrentDesktop: Unity
Date: Fri Jun 20 03:14:08 2014
HibernationDevice: RESUME=UUID=202f89f5-b720-4ad7-b55e-dce344e24df1
InstallationDate: Installed on 2014-06-20 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Dell Inc. Inspiron 5547
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-29-generic root=UUID=7cc3cad1-0797-443f-b3d3-5484a70cc255 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-29-generic N/A
 linux-backports-modules-3.13.0-29-generic N/A
 linux-firmware 1.127.2
SourcePackage: linux
StagingDrivers: rts5139
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/12/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X18
dmi.board.name: 08KNCD
dmi.board.vendor: Dell Inc.
dmi.board.version: X01
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: X18
dmi.modalias: dmi:bvnDellInc.:bvrX18:bd02/12/2014:svnDellInc.:pnInspiron5547:pvrX18:rvnDellInc.:rn08KNCD:rvrX01:cvnDellInc.:ct8:cvrX18:
dmi.product.name: Inspiron 5547
dmi.product.version: X18
dmi.sys.vendor: Dell Inc.

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Yes, brightness control with fglrx could work with the latest daily-live kernel
Also, it works with fglrx removed (running the Intel GPU)

ubuntu@201401-14542:~$ uname -a
Linux 201401-14542 3.16.0-999-generic #201406200205 SMP Fri Jun 20 06:06:05 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

If it's a duplicated bug, please feel free to change the bug status.
Thanks

Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Edward Lin (airken)
Edward Lin (airken) wrote :

@Po-Hsu,
Can you add "video.use_native_backlight=1" to grub to see if backlight control works ?

Edward Lin (airken) wrote :

@Po-Hsu,
Please skip comment #7.

Since latest kernel fixes this issue, it should be win8 backlight issue.
Backlight control is moved to gfx after win8.
video.use_native_backlight=1 is set as default after 3.16-r2.

Utopic release should fix this issue.

Po-Hsu Lin (cypressyew) wrote :

Also affects 201401-14528 Dell Inspiron 5447
with the same graphic card, 3.16.0-rc4 would fix this.

summary: - [Dell Inspiron 5547] Unable to contorl brightness with fglrx driver on
- AMD Radeon R7 M260 [1002:6900]
+ [Dell Inspiron 5547/5447] Unable to contorl brightness with fglrx driver
+ on AMD Radeon R7 M260 [1002:6900]
tags: added: 201401-14528
Po-Hsu Lin (cypressyew) wrote :

Tweak in comment #7 works on 201401-14528

Edward Lin (airken) wrote :

@Po-Hsu,
Can you try this kernel for bug 1333638 / bug 1250401 / bug 1332437 to see if it fixes the backlight issue ?
http://people.canonical.com/~airken/bug/lp1332437/

Edward Lin (airken) wrote :

Backlight works with the kernel mentioned in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1333638/comments/10.

I will submit a sauce patch for Dell Inspiron 5547/5447/5737 and Vostro 5470.

Edward Lin (airken) wrote :

Upstream accepts the patch for Dell Inspiron 5737.
https://kernel.googlesource.com/pub/scm/linux/kernel/git/rafael/linux-pm/+/08a56226d84706d402372d891550e130ef5df9f0

And the bug for Vostro 5470 is set to invalid.
I will submit the sauce patch for Dell Inspiron 5547/5447 only.

Edward Lin (airken) on 2014-07-10
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Edward Lin (airken) on 2014-08-21
tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: New → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Invalid
Changed in linux (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers