[3.2] KVM: x86: emulate movdqa

Bug #1330177 reported by Anton Nayshtut on 2014-06-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Anton Nayshtut

Bug Description

[SRU Justification]

[Explanation]
movdqa emulation is not supported in kernel 3.2, so it's relevant only for Precise 3.2 kernels.

[Impact]
Without movdqa emulation the MS SVVP "PCI Hardware Compliance Test for Systems" fails for Windows 2012 VM.

This test fails and hangs the VM to the point that the VM becomes unusable.

[Test Case]
Windows 2012 Guest VMs running "PCI Hardware Compliance Test for Systems" SVVP test.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1330177

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Tim Gardner (timg-tpi) on 2014-06-16
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Precise):
assignee: nobody → Anton Nayshtut (anton.nayshtut)
status: New → In Progress
Chris J Arges (arges) on 2014-07-02
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Anton Nayshtut (anton.nayshtut) wrote :

Verified by both me and Victor Tapia (vtapia).

tags: added: verification-done-precise
removed: verification-needed-precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers